Survey by Qualaroo
+ Reply to Thread
Results 1 to 19 of 19
Like Tree1Likes
  • 1 Post By farjam

Thread: Suzuki Baleno CNG Problem

  1. #1
    PakWheeler hassan44's Avatar
    Join Date
    Aug 2009
    Location
    Rawalpindi
    Posts
    120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Suzuki Baleno CNG Problem

    AOA TO ALL PAKWHEELS MEMBERS...


    DEAR ALL ...


    Iam facing a new kind of problem with my 2005 baleno jxr... mileage 31000 kms ... actually car is missing on cng and little i mean giving some little very little burps on petrol also... i just got tuned my car from suzuki rawalpindi motors 9, 10 days ago ... changed the oil ... and spark plugs ( NGK ) ... well i was reading many topics etc about missing problem ...i know its common in this model... well the main problem is that some times car has no pickup and sometimes pickup is better ... today i asked CNG mechanic about this issue and he said ke yaar spark plugs change kardo bosch ke lagwa lo ... but maine 10 days pehle i change kiye hain plugs ... secong ke backfiring is sever on cng specially on low rpm 1-2 ... n when i switch on the ac on cng tab backfiring nahi hoti kafi kam ho jati hai almost zero second i read ke air filter ka problem bhi hota ha so i checked airfilter box clamps etc and also cleaned air filter myself but still backfiring continuous iam worried about my car.. i dont wana try differnt type of heeri stuff with my car ... so need your guys help... ill be thankful to you.

  2. #2
    Senior PakWheeler jaggi's Avatar
    Join Date
    Jan 2009
    Location
    Lahore
    Age
    24
    Posts
    7,245
    Mentioned
    36 Post(s)
    Tagged
    2 Thread(s)

    Default

    bro pershan na ho.......suzuki prob he daiti heyB-)
    Imran Khan --PTI (Pakistan Tehreek-e-Insaf) --

  3. #3
    PakWheeler farjam's Avatar
    Join Date
    May 2006
    Location
    Rawalpindi
    Age
    26
    Posts
    343
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    my baleno had same problem(backfire).
    i put high performance plugs(double tip).
    no more backfire.
    murtaza_9 likes this.
    every day i wake up and die a little.

  4. #4
    PakWheeler farjam's Avatar
    Join Date
    May 2006
    Location
    Rawalpindi
    Age
    26
    Posts
    343
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    my baleno had same problem(backfire).
    i put high performance plugs(double tip).
    no more backfire.
    every day i wake up and die a little.

  5. #5
    DMX
    DMX is offline
    PakWheeler DMX's Avatar
    Join Date
    Jul 2006
    Location
    Karachi
    Age
    30
    Posts
    123
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Cause(s) might be a leak in the air intake system, incorrect timing, clogged fuel lines/filter/pump, bad airflow sensor or maybe rich supply of fuel causing incomplete combustion which is leading to the backfire

  6. #6
    PakWheeler hassan44's Avatar
    Join Date
    Aug 2009
    Location
    Rawalpindi
    Posts
    120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Anyone else? I have tried many expert mechanics and Rude 3s Suzuki dealers... checked everything related to electric stuff .. changed plugs... checked wires coils sensors mixtures airfilter/box but still giving backfirres on cng and petrol ??? iam actually fed up now... spending 2 3 days in a week with mechanics and by giving them money.. if it will be going like this then ill sell my car very soon ... any experts here who can help me out please?... still waiting...

  7. #7
    Senior PakWheeler FLi_GTi's Avatar
    Join Date
    Jun 2005
    Location
    Ahead of you!
    Age
    36
    Posts
    3,118
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    What DMX said. Suzi's are known to cark an ignition coil or two leading to the backfire. replace and they should be ok.
    |||||||||||||||||||||||||||||| C2G - GARAGE | SHOP | TUNE +92 346 8776643 |||||||||||||||||||||||||||||||

  8. #8
    PakWheeler hassan44's Avatar
    Join Date
    Aug 2009
    Location
    Rawalpindi
    Posts
    120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    @Gti... Sir Suzuki 3s Dealers have already checked the Coils.. even replaced them with some other baleno's coil(s 4a while but it Use koi fark ni para tappet ve already ajusted CNG etc mixtures everything is Good.... then they opened the plugs for 4th time and changed THE gap from 80 to 100 .. car stopped patakhe for a while... Now the main problem is car is giving Burps on Both fuels In IDle postion if you press accelerator Continuously on 1000-2000 RPM. ..Acceleration pick everything is okay now Alhumdulilah but Still giving Burps on Idle 1000-2000Rpm on both fuels still cant figure out the main problem ...

  9. #9
    Senior PakWheeler FLi_GTi's Avatar
    Join Date
    Jun 2005
    Location
    Ahead of you!
    Age
    36
    Posts
    3,118
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Call the number in my signature and bring it in for a look see. Should have you sorted.
    |||||||||||||||||||||||||||||| C2G - GARAGE | SHOP | TUNE +92 346 8776643 |||||||||||||||||||||||||||||||

  10. #10
    PakWheeler faysal24's Avatar
    Join Date
    May 2005
    Location
    Chicago
    Age
    36
    Posts
    117
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I have has similar problems with my Liana RXI CNG.i had the coils changed from Plaza. They costed me 8000 Rs then. Later after 6 months I had the same problem again. This time I went to suzuki defence and they said its a problem with my AC compressor...such a stupid reply. I have been told by the people at the dealership that its a company fault with the coils...
    So, please check your coils again....see for any spark marks on it

  11. #11
    Newbie drmohsin's Avatar
    Join Date
    Aug 2005
    Location
    Karachi
    Age
    40
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by hassan44



    AOA TO ALL PAKWHEELS MEMBERS...


    DEAR ALL ...


    Iam facing a new kind of problem with my 2005 baleno jxr... mileage 31000 kms ... actually car is missing on cng and little i mean giving some little very little burps on petrol also... i just got tuned my car from suzuki rawalpindi motors 9, 10 days ago ... changed the oil ... and spark plugs ( NGK ) ... well i was reading many topics etc about missing problem ...i know its common in this model... well the main problem is that some times car has no pickup and sometimes pickup is better ... today i asked CNG mechanic about this issue and he said ke yaar spark plugs change kardo bosch ke lagwa lo ... but maine 10 days pehle i change kiye hain plugs ... secong ke backfiring is sever on cng specially on low rpm 1-2 ... n when i switch on the ac on cng tab backfiring nahi hoti kafi kam ho jati hai almost zero second i read ke air filter ka problem bhi hota ha so i checked airfilter box clamps etc and also cleaned air filter myself but still backfiring continuous iam worried about my car.. i dont wana try differnt type of heeri stuff with my car ... so need your guys help... ill be thankful to you.



    Brother, there is a sensor in butterfly/throttle body. Ask your mechanic to check that. I had same problem of (pickup/no pickup), which has been solved by changing the sensor.


    Also check fuel pump of your car and try to keep your fuel levels well above red line. It is very common in baleno, get new one (economical, Chinese fuel pump worth 1000 Rs for 2 years).


    Hope it work. Good luck

  12. #12
    Senior PakWheeler madhouse12's Avatar
    Join Date
    May 2007
    Location
    Rawalpindi
    Age
    35
    Posts
    7,325
    Mentioned
    160 Post(s)
    Tagged
    7 Thread(s)

    Default

    I know this is kinda late reply but for other users who might stumble upon it....

    with CNG, a lot depends upon the quality of CNG that u get from stations. get the throttle body of your engine cleaned as there might be carbon deposits there.

  13. #13
    Senior PakWheeler chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    24
    Posts
    10,710
    Mentioned
    53 Post(s)
    Tagged
    3 Thread(s)

    Default

    please make sure the plug gapping is no more or less then 1.1mm
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  14. #14
    PakWheeler djyawar's Avatar
    Join Date
    Aug 2008
    Location
    Islamabad
    Age
    28
    Posts
    449
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i had the same prob!
    get Ultima 8mm Plug wires(Yellow color), backfiring is due to less current....if possible then do the electronic tunning of your car...inshALLAH problem will be solved.....if not then we'll see inshALLAH this is not a big problem...

  15. #15
    PakWheeler wkwaseem's Avatar
    Join Date
    Mar 2010
    Location
    Karachi
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Never too late...
    The CNG kit is having oil inside which is causing all this problem. Just get your CNG kit opened and serviced from a cng shop (its not a complicated job as it sounds)... and don't forget to clean the cylinder (they will do it without wasting much of your gas).
    this oil comes into our gas cylinders when we get it filled from stations which are having low pressure.
    All the best!

  16. #16
    PakWheeler waqar_naturalperson's Avatar
    Join Date
    Apr 2010
    Location
    Karachi
    Age
    29
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i'm facing so much problem in my baleno car "car is so much missing and other problem is that when i drive the car and if i use the brake then rpm of my car decreases and car also heatup then car stop and then when i start, it takes time to start then after some minutes the car again that type of problem"
    so please give me advice that what should i do .. and which macanic is perfect for solve that types of problems..the car have been computerized checked but the computer could not find out the problem...Please Help me

  17. #17
    Senior PakWheeler argtr65's Avatar
    Join Date
    Dec 2008
    Location
    Karachi
    Age
    48
    Posts
    1,255
    Mentioned
    17 Post(s)
    Tagged
    6 Thread(s)

    Default

    Check ground wire properly,clean & reinstall if necessary.
    Never loose hope in life,every step gives u something.

  18. #18
    PakWheeler Dani80pk's Avatar
    Join Date
    Aug 2009
    Location
    Karachi
    Age
    34
    Posts
    390
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Default

    Have you checked the crank sensor. If not, do check it and get it cleaned and if so desired replace it. It will most likely solve your problem. Have seen many balenos fixed by doing this.

  19. #19
    Senior PakWheeler Skill's Avatar
    Join Date
    Aug 2009
    Location
    Other
    Posts
    7,517
    Mentioned
    60 Post(s)
    Tagged
    36 Thread(s)

    Default

    1450rs ka hay crank sensor mitsubishi japan ka,qabli 500 tk milna chahiya
    https://www.facebook.com/skillgrafik

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •