Survey by Qualaroo
+ Reply to Thread
Results 1 to 12 of 12

Thread: Suzuki Alto 2007 starting problem - help!!

  1. #1
    PakWheeler Follow
    dangerousminds's Avatar
    Join Date
    Nov 2005
    Location
    Rawalpindi
    Age
    33
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Suzuki Alto 2007 starting problem - help!!

    Assalam o Alaikum all,

    I own a Suzuki Alto 2007 which has been giving me problems for a long time. If the car has been parked for some time (more than 5 or 6 hours) then it does not start. This happens on both petrol and cng. I have changed the battery but the problem remains. I have shown the car to atleast a dozen mechanics, including the suzuki ones, and they do different things but no one has been able to fix the problem. The only way to get it going is through dhakka start. The car usually does not give any problems if it is started within 6 hours.

    Also, since last week, the car suddenly turns off while running on the road. If i start it agan, it runs fine for a few minutes before turning off again. This is also happening on both petrol and cng.

    Please help.
    Thanks.


  2. #2
    Senior PakWheeler Follow
    fahadsoulsnatcher911's Avatar
    Join Date
    Jul 2009
    Location
    Karachi
    Age
    21
    Posts
    2,876
    Follows
    0
    Following
    0
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get it tuned maybe that can solve the problem

  3. #3
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Following are the possible causes for this problem,
    1. Improper tappet adjustment.
    2. Defective Cng conversion switch.
    3. Loose or corroded electrical connections.
    4. Bad ignition coil or ignitor.
    5. Bad spark plugs.
    6. Bad plug cords or distributor cap
    7. Improper ignition timing.
    8. Dirty or chocked air filter.
    Get it checked accordingly.
    Never loose hope in life,every step gives u something.

  4. #4
    PakWheeler Follow
    dangerousminds's Avatar
    Join Date
    Nov 2005
    Location
    Rawalpindi
    Age
    33
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    OK, thanks. Do you know of any good mechanic in Isb/Rwp area which specialises in these area?

  5. #5
    PakWheeler Follow
    dangerousminds's Avatar
    Join Date
    Nov 2005
    Location
    Rawalpindi
    Age
    33
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @fahdsoulsnatcher911: Yes I have done that, tepid adjustment, tuning, battery change, running and starting the car on petrol, also took out the wire for radio (i was suspecting the problem might have been coming from the car radio) .. if i park the car and then start it again after a few minutes it starts almost immediately ... really don't know where the problem lies.

  6. #6
    PakWheeler Follow
    1431's Avatar
    Join Date
    Oct 2011
    Location
    Abbotabad
    Posts
    65
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    just do engine tune.....

  7. #7
    Senior PakWheeler Follow
    brownrose78's Avatar
    Join Date
    Aug 2006
    Location
    Karachi
    Posts
    1,594
    Follows
    5
    Following
    10
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    2
    Best Answers
    1
    Good Answers
    2

    Default

    same haappened to my mehran long time ago, this is common for lo mielage car.
    mine was settled when i got my self/generator service

    they cleaned the coil & it really works
    do these
    Patriotism is when love of your own people comes first; nationalism, when hate for people other than your own comes first.

  8. #8
    Senior PakWheeler Follow
    fahadwizz's Avatar
    Join Date
    Feb 2011
    Location
    Karachi
    Age
    35
    Posts
    2,383
    Follows
    1
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    3

    Default

    If my alto would miss the first self in the morning - It won't start. The harder i'll try more stubborn it would become. Sometimes even dhakka wouldn't work. The prblem got solved on its own after a few 1000 KMs.

    I still remember the horrifying winter mornings all dressed up for work and car wouldnt start .

  9. #9
    Senior PakWheeler Follow
    zunny's Avatar
    Join Date
    Mar 2008
    Location
    Other
    Age
    37
    Posts
    4,107
    Follows
    5
    Following
    0
    Mentioned
    29 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    can exactly understand ur problem. I also have the same car n its a genetic problem of all altos. Tried many mechs.changed plugs etc but to no avail. Then found 1 road side mechanic n he did his magic. Afterwards another famous local mech tuned it but again prob persisted . Again the same problems after lot of visits to different mechanics. Till the time that very road side mechanic did his majic again. Alto is a P.I.A when it comes to starting. It would start on the 1st self or wont at all! Lolz. Then all day would be fine n starting with a qtr of rotation of the ignition key.
    'RESPECT',DIY projects: 1) 'CRUISEMATEC' 1st PKDM 8th Gen Civic with OEM Honda CRUISE CONTROL 2)Steering Audio Controls 3)AUX for OEM 8th Gen 6 CD CHANGER 4)Leather RED H logo!

  10. #10
    PakWheeler Follow
    dangerousminds's Avatar
    Join Date
    Nov 2005
    Location
    Rawalpindi
    Age
    33
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The last mechanic blamed the problem on the tracker installed in my car. So i took my useless car to the tracking company. They disabled the tracker and it still wouldnt start. Then i took it to a suzuki mechanic in rwp, he spent 5 minutes on it and claimed that he's done some magic Lets see, if the problem persists, i'll leave the car with him over the weekend.

    Any suggestions will be more than welcome.

  11. #11
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,597
    Follows
    31
    Following
    6
    Mentioned
    1018 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Exclamation


    In case the problem is still there.

    Visit a reliable mechanic and request for a distributor overhaul Only. He will remove the assembly from engine and dismantle it completely. wash it with petrol & soft brush, the springs for centrifugal weights must be DONE, if not then after reassembly change the point, scrub the rotar metal softly, Clean NOT SCRATCH the centre carbon and 3 pins in distributor cap.

    IF anything appears damaged broken change the complete distributor assembly - Buy a GENUINE from Suzuki shop not from JUNK yard.

    do come back & post on forum how you managed to get rid of problem

  12. #12
    PakWheeler Follow
    dangerousminds's Avatar
    Join Date
    Nov 2005
    Location
    Rawalpindi
    Age
    33
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    So this suzuki mechanic did identify the fault to be with the distributor. A while back, a mechanic had 'fixed' the distributor, but the problem had again come up after a few weeks so I asked him to replace it. A new distributor costs 54000 Rs. so I got a second hand one for 4000 Rs. and got it installed. Lets see (and pray) that the problem does not come up again.

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •