Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Suzuki Alto K6A 660cc 2004 not starting

  1. #1
    PakWheeler Follow
    ukhawar's Avatar
    Join Date
    Oct 2013
    Location
    Lahore
    Age
    32
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Suzuki Alto K6A 660cc 2004 not starting

    Hello all and Salam.
    I seek advice regarding the basic checks to make on Alto 660cc to start it. When switched on i hear a whistling sound which i suppose must be off fuel pump which last for 3-4 seconds. I have already check fuse box which seems okay. any other suggestions how to start it. The battery is also getting down because of the several failed self attempts. Engine is not cranking and self is getting weaker. Looking forward for your expert replies. thanks.

    Suzuki Alto Japanese 660cc
    Type : LA-HA23S
    Engine: K6A


  2. #2
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,381
    Follows
    18
    Following
    0
    Mentioned
    406 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    is fuel going to injectors ?
    plugs have current?
    how r u checking the fuse box inside and outside one?

    cant u afford a decent electrician
    or u want to blow something by ur own
    Life is short and very unpredictable just like a Quarter mile .....

  3. #3
    Senior PakWheeler Follow
    nfssaad's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    29
    Posts
    3,179
    Follows
    0
    Following
    1
    Mentioned
    50 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    first check with a friend. see if each plug is creating a spark by taking them out one by and one and holding close to unpainted metal ground of body, while your friend turns the ignition key.

    then check if all the injectors are getting current. you will need a multimeter for that.

    loosen the fuel rail. and take of the fuel pump line. that line is pressurised so it will spray some fuel. every time you turn the ignition the fuel pump should work and the line should spray out petrol. if not then some thing is wrong with the fuel pump.

    also the fuel pump is located in the fuel tank.... are you sure that is what you are hearing?
    the problem is not our govt... its the people..

  4. #4
    PakWheeler Follow
    daisyjohn's Avatar
    Join Date
    Nov 2013
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ? Check the battery terminal cable connections.
    ? The car makes a clicking noise but won?t start this sound usually means a dead battery. If not, check the wiring to and from the starter for a loose connection.
    ? You may be out of fuel, or the fuel isn?t getting to your engine.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •