Survey by Qualaroo
+ Reply to Thread
Page 171 of 226 FirstFirst ... 71121161169170171172173181221 ... LastLast
Results 3,401 to 3,420 of 4519
Like Tree488Likes

Thread: Tips for Baleno

  1. #1
    PakWheeler Follow
    bostupthecar's Avatar
    Join Date
    Jul 2009
    Location
    Rawalpindi
    Age
    61
    Posts
    186
    Follows
    5
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Tips for Baleno

    i have a lot of experience of using and maintaining baleno all types of balenos.its really a marvelous car of suzuki.but little diffferent to maintain from other cars.if u have some problems discuss with me on this forum.B-)


  2. #3401
    PakWheeler Follow
    abbasi_faheem's Avatar
    Join Date
    Sep 2009
    Location
    Karachi
    Age
    32
    Posts
    148
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @NiGhTShAdE dear oil consumption is very low, from Karachi to Sukkur long drive 480 km only 1/4 ltr required...

    Sent from my QMobile A51 using PW Forums mobile app

  3. #3402
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abbasi_faheem View Post
    @NiGhTShAdE dear oil consumption is very low, from Karachi to Sukkur long drive 480 km only 1/4 ltr required...

    Sent from my QMobile A51 using PW Forums mobile app
    Means about 0.5lit/1000km....which is not very good....
    Smoke at start usually means worn out valve seals.....
    What viscosity of oil are you using?

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  4. #3403
    PakWheeler Follow
    abbasi_faheem's Avatar
    Join Date
    Sep 2009
    Location
    Karachi
    Age
    32
    Posts
    148
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by NiGhTShAdE View Post
    Means about 0.5lit/1000km....which is not very good....
    Smoke at start usually means worn out valve seals.....
    What viscosity of oil are you using?

    Sent from my QMobile i10 using PW Forums mobile app
    Dear this 0.5 ltrs per 1000 km is due to some oil leakage from timing belt seal...otherwise the oil consumption is very low. However I don't know the viscosity of oil I'm using caltax red bottle oil...

    Sent from my QMobile A51 using PW Forums mobile app

  5. #3404
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abbasi_faheem View Post
    Dear this 0.5 ltrs per 1000 km is due to some oil leakage from timing belt seal...otherwise the oil consumption is very low. However I don't know the viscosity of oil I'm using caltax red bottle oil...

    Sent from my QMobile A51 using PW Forums mobile app
    Ok....Caltex Red bottle is 20W50... recommended for engines that consume oil...it is a thick oil...
    Just go for valve seals and ring replacement....do go for total overhaul....it would cost you around 7-8K....that is what i can judge from your comments...

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  6. #3405
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Replacement of car depends on condition of your car and avg condition of cars available in market....only you can judge ....

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  7. #3406
    PakWheeler Follow
    abbasi_faheem's Avatar
    Join Date
    Sep 2009
    Location
    Karachi
    Age
    32
    Posts
    148
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by NiGhTShAdE View Post
    Ok....Caltex Red bottle is 20W50... recommended for engines that consume oil...it is a thick oil...
    Just go for valve seals and ring replacement....do go for total overhaul....it would cost you around 7-8K....that is what i can judge from your comments...

    Sent from my QMobile i10 using PW Forums mobile app
    Dear I got estimates from 2 mechanics one said 10k and other said 14k...
    Plz suggest any if u can...

    Sent from my QMobile A51 using PW Forums mobile app

  8. #3407
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abbasi_faheem View Post
    Dear I got estimates from 2 mechanics one said 10k and other said 14k...
    Plz suggest any if u can...

    Sent from my QMobile A51 using PW Forums mobile app
    Get the breakup of cost...labour should be around 3K....rest for parts....

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  9. #3408
    PakWheeler Follow
    farhanmazhar96's Avatar
    Join Date
    May 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy Baleno got a strange problem...urgent advise required please

    I have got baleno 2000 with G15A distributer enigne...
    I was running fine before but yesterday i got stuck in traffic jam for 5 hours in islamabad and after 5 hours the car started losing power and jerking also the heat gauge comes to 60 % without ac(as usually it stays at 30% without ac). Car did not turn off but i also did not take the acceleration , so i turn off the car for about 30 minutes and than started when roads were clear and it drove very fine on the motorway and showed no loss of power but still the heat needle goes to 50 percent after traveling 150km on the motor way but without loss of power and any apparent problem...please advise what is wrong in the car as i have to drive it on long routes...urgent response required please.

  10. #3409
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by farhanmazhar96 View Post
    I have got baleno 2000 with G15A distributer enigne...
    I was running fine before but yesterday i got stuck in traffic jam for 5 hours in islamabad and after 5 hours the car started losing power and jerking also the heat gauge comes to 60 % without ac(as usually it stays at 30% without ac). Car did not turn off but i also did not take the acceleration , so i turn off the car for about 30 minutes and than started when roads were clear and it drove very fine on the motorway and showed no loss of power but still the heat needle goes to 50 percent after traveling 150km on the motor way but without loss of power and any apparent problem...please advise what is wrong in the car as i have to drive it on long routes...urgent response required please.
    The loss of power that you are experiencing could be due to over heating....under normal circumstances temp needle should be at 30-40%....
    For over heating check for leaks...check whether radiator is to rusty and chocked or not and lastly check for head gasket...and make sure that your radiator fan turns on at max 40% temp needle reading....

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  11. #3410
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by NiGhTShAdE View Post
    The loss of power that you are experiencing could be due to over heating....under normal circumstances temp needle should be at 30-40%....
    For over heating check for leaks...check whether radiator is to rusty and chocked or not and lastly check for head gasket...and make sure that your radiator fan turns on at max 40% temp needle reading....

    Sent from my QMobile i10 using PW Forums mobile app
    Keep in mind modern Aluminun Block engines though high performing, are very very sensitive to heat...just one overheating and you could end up with ruined engine....

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  12. #3411
    PakWheeler Follow
    farhanmazhar96's Avatar
    Join Date
    May 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    There is no problem with radiator and coolent is well at its level....
    Now i am confused whether the problem is related with fuel pump or heat gasket as the car works fine after 30 min of rest

  13. #3412
    PakWheeler Follow
    abbasi_faheem's Avatar
    Join Date
    Sep 2009
    Location
    Karachi
    Age
    32
    Posts
    148
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abbasi_faheem View Post
    Dear I got estimates from 2 mechanics one said 10k and other said 14k...
    Plz suggest any if u can...

    Sent from my QMobile A51 using PW Forums mobile app
    OK dear @NiGhTShAdE, I'll get the estimate with breakup and then let u know by tomorrow... Ur very helping...thanks bro...

    BTW I need one more suggestion my car does not have any advancer installed the pickup on CNG is very less than that on petrol and it gives 110km in Rs. 500/- CNG without Ac in city and 150-160 without Ac on motorways...so should I go for advancer? Will it increase the CNG average? And what is the cost of advancer without emulator?

    Sent from my QMobile A51 using PW Forums mobile app

  14. #3413
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by farhanmazhar96 View Post
    There is no problem with radiator and coolent is well at its level....
    Now i am confused whether the problem is related with fuel pump or heat gasket as the car works fine after 30 min of rest
    Check at what level of temp needle does fan turn on? And does it turn off after some time? This could be very helpful in solving the problem...

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  15. #3414
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abbasi_faheem View Post
    OK dear @NiGhTShAdE, I'll get the estimate with breakup and then let u know by tomorrow... Ur very helping...thanks bro...

    BTW I need one more suggestion my car does not have any advancer installed the pickup on CNG is very less than that on petrol and it gives 110km in Rs. 500/- CNG without Ac in city and 150-160 without Ac on motorways...so should I go for advancer? Will it increase the CNG average? And what is the cost of advancer without emulator?

    Sent from my QMobile A51 using PW Forums mobile app
    U r welcome Bro....
    Advancers certainly help in improving the performance on CNG...
    I have two Balenos....both give around 140km in city without ac and around 110km with ac with 55L FF CNG cylinder..

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  16. #3415
    PakWheeler Follow
    abbasi_faheem's Avatar
    Join Date
    Sep 2009
    Location
    Karachi
    Age
    32
    Posts
    148
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    110km with ac in city means 150-160km with ac on motorways...bro I'll love to get my car tunned up....

    Any CNG setting expert suggestion for me @ karachi...

    Sent from my QMobile A51 using PW Forums mobile app

  17. #3416
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I am from Lahore...hope someone from Karachi would turn up for help....

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  18. #3417
    PakWheeler Follow
    farhanmazhar96's Avatar
    Join Date
    May 2013
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The fan is direct and no thermostat installed

  19. #3418
    PakWheeler Follow
    abbasi_faheem's Avatar
    Join Date
    Sep 2009
    Location
    Karachi
    Age
    32
    Posts
    148
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by NiGhTShAdE View Post
    I am from Lahore...hope someone from Karachi would turn up for help....

    Sent from my QMobile i10 using PW Forums mobile app
    OK brother,

    Thanks plz...

    Sent from my QMobile A51 using PW Forums mobile app

  20. #3419
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by farhanmazhar96 View Post
    The fan is direct and no thermostat installed
    That leaves you with only three possible options..
    1)Head gasket is damaged. You can check this by opening the cap of radiator and let the car idle..there should be no air bubbles or oil in the radiator....
    There should also be no water in mobil oil. Check via dipstick and there should be no creamy substance under oil cap...
    Any of the above signs means head gasket is gone....
    2) Your radiator could be full of scale.
    3) Temp gauge could be faulty....

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

  21. #3420
    PakWheeler Follow
    NiGhTShAdE's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    29
    Posts
    918
    Follows
    1
    Following
    1
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by farhanmazhar96 View Post
    The fan is direct and no thermostat installed
    Btw direct fans are highly not recommended and neither is removing T valve...it could ruin your engine....if you face heating issue...remove the root cause instead of doing above mentioned things....

    Sent from my QMobile i10 using PW Forums mobile app
    NiGhT ShAdE>>~

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •