Survey by Qualaroo
+ Reply to Thread
Page 221 of 226 FirstFirst ... 121171211219220221222223 ... LastLast
Results 4,401 to 4,420 of 4519
Like Tree488Likes

Thread: Tips for Baleno

  1. #1
    PakWheeler Follow
    bostupthecar's Avatar
    Join Date
    Jul 2009
    Location
    Rawalpindi
    Age
    61
    Posts
    186
    Follows
    5
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Tips for Baleno

    i have a lot of experience of using and maintaining baleno all types of balenos.its really a marvelous car of suzuki.but little diffferent to maintain from other cars.if u have some problems discuss with me on this forum.B-)


  2. #4401
    PakWheeler Follow
    moizadil's Avatar
    Join Date
    Apr 2016
    Posts
    324
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Okay so can you please elaborate in what sequence did your problems occur? Something similar happened to me. Im guessing you had the second problem first and then when you got the throttle body cleaned the rpm started to surge, am I right?

    I experienced similar sort of problems with my baleno and I assessed that the throttle body needed cleaning. However, my dad took the car to the mechanic and he fixed the problem by deattaching the cng leads behind the engine and the problem went away. 3 days back I wanted to clean the throttle body myself and I went ahead with it, just wanted to do it for some reason. Upon cleaning the throttle body I found a metal piece blocking the air pipe going to the throttle body (CNG purposes). The car was designed to work on cng although I've never used cng but the equipment is still there. So I got rid of those and my car response has become so much better and everything was fine besides the rpm which was idling at 900 rpm. Before cleaning it idled at 800 rpm so I become over efficient and sprayed the throttle body and IAC valve with carb cleaner again to make it idle at 800 and since then I have been getting rpm surges exactly like you mentioned. Rpm is jumping upto 2500 and idles 1000. I think this is how you problem has occur. Another thing ive noticed is that when i move the steering wheel the rpm jumps up a good 700 before coming back to 1000, I know it should fluctuate when the steering is moved but no this much, does this happen with your car? I have even tried Idle relearning and that didnt work.

    For your first problem I'd suggest to get rid of the CNG wirings and other systems attached to your engine if you still have that in tact. Im a noob and have no real knowledge about the engine but in the time I have kept this car I have experienced problems similar to your and the culprit the CNG system. Maybe this would solve your problem.

    And if you find a solution for your surging rpm please do let me know in this thread

  3. #4402
    Newbie Follow
    sabahat6753's Avatar
    Join Date
    Aug 2016
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default missing problem

    Dear, i have 99 model baleno, recently i have changed its head gaskit, before this it was working well, but after gaskit, its accleration is not smooth, at slow race when it starts acclerates the engine vibrates little like missing but when we increase accleartion it becomes smooth, where can be the problem?.
    Regards
    Sabahat

  4. #4403
    Newbie Follow
    sabahat6753's Avatar
    Join Date
    Aug 2016
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Dear, i have 99 model baleno, recently i have changed its head gaskit, before this it was working well, but after gaskit, its accleration is not smooth, at slow race when it starts acclerates the engine vibrates little like missing but when we increase accleartion it becomes smooth, where can be the problem?.
    Regards
    Sabahat

  5. #4404
    PakWheeler Follow
    46121's Avatar
    Join Date
    Apr 2015
    Location
    Lahore
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Aoa guys, I have baleno 05, It's suspension needs repair / replacement. Should I go for kabli spares or new Taiwanese/Chinese. Secondly please suggest a good workshop in Lahore for suspension.one more thing is I installed 1.5 lits ekabli engine . It's distributor based and I can't get its throttle sensor from anywhere.Help would be appreciated. Thanks

  6. #4405
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,312
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by 46121 View Post
    Aoa guys, I have baleno 05, It's suspension needs repair / replacement. Should I go for kabli spares or new Taiwanese/Chinese. Secondly please suggest a good workshop in Lahore for suspension.one more thing is I installed 1.5 lits ekabli engine . It's distributor based and I can't get its throttle sensor from anywhere.Help would be appreciated. Thanks
    Get new OEM items for suspension



    Sent from my iPhone using PW Forums
    Just Do It Your Self!!!!!

  7. #4406
    PakWheeler Follow
    shery_leo's Avatar
    Join Date
    Jul 2014
    Location
    Karachi
    Posts
    355
    Follows
    1
    Following
    4
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by bostupthecar View Post
    i have a lot of experience of using and maintaining baleno all types of balenos.its really a marvelous car of suzuki.but little diffferent to maintain from other cars.if u have some problems discuss with me on this forum.B-)

    hi baleno master

    please look into this add and tell me was there a Japanese version of this car and what u suggest of buying this car

    https://www.olx.com.pk/item/suzuki-b...tml#1f600af6a4

    please advise asap
    I am Just Like a Mirror Reflecting The Images You Do

  8. #4407
    PakWheeler Follow
    tahir.farooq's Avatar
    Join Date
    Feb 2015
    Location
    N/A
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Please go for Suspension work@
    Khan Motors (Mr.Zaheer Khan)
    Al-Karim Chowk,
    Township Lahore.

  9. #4408
    PakWheeler Follow
    46121's Avatar
    Join Date
    Apr 2015
    Location
    Lahore
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tahir.farooq View Post
    Please go for Suspension work@
    Khan Motors (Mr.Zaheer Khan)
    Al-Karim Chowk,
    Township Lahore.
    Thanks

  10. #4409
    PakWheeler Follow
    46121's Avatar
    Join Date
    Apr 2015
    Location
    Lahore
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Guys how much would it cost for RC or used ECU plus wiring of g15a engine

  11. #4410
    Newbie Follow
    hxeeshan's Avatar
    Join Date
    Sep 2016
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Hello guys. I am having a problem with my Baleno 2005 JXR. Almost 2 months ago I had to overhaul the engine of baleno and since then the car does not start when it gets hot. It starts on after one or two minutes when it cools down a bit. It has a perfectly working generator(Japanese), new battery(Excide 65 Amp) and a new self(Japanese). Can you please tell me what could be the problem as I ahve done everything according to my knowledge which may have caused that problem. Any further recommendation to resolve this problem??

  12. #4411
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by hxeeshan View Post
    Hello guys. I am having a problem with my Baleno 2005 JXR. Almost 2 months ago I had to overhaul the engine of baleno and since then the car does not start when it gets hot. It starts on after one or two minutes when it cools down a bit. It has a perfectly working generator(Japanese), new battery(Excide 65 Amp) and a new self(Japanese). Can you please tell me what could be the problem as I ahve done everything according to my knowledge which may have caused that problem. Any further recommendation to resolve this problem??
    If engine cranks properly,then hot starting problem could be because of;


    1. Leaky fuel injectors.
    2. Bad fuel pump relay.
    3. Bad fuel pressure regulator.
    4. Bad crank position sensor or its wiring.
    Never loose hope in life,every step gives u something.

  13. #4412
    Senior PakWheeler Follow
    khahsan's Avatar
    Join Date
    Jan 2007
    Location
    Islamabad
    Age
    35
    Posts
    1,610
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by argtr65 View Post
    If engine cranks properly,then hot starting problem could be because of;


    1. Leaky fuel injectors.
    2. Bad fuel pump relay.
    3. Bad fuel pressure regulator.
    4. Bad crank position sensor or its wiring.
    I have the same problem
    When car is hot, it does not start if stopped. Engine does not cranks and shows symptoms like a dead battery issue. But it starts perfect after 5-6 minutes.
    Battery, starter everything checked.

    Sent from my HTC Desire 626s using PW Forums mobile app
    jay sakoon nahi..te chaer k vekh (A Random Shehzore 2012)

  14. #4413
    Senior PakWheeler Follow
    khahsan's Avatar
    Join Date
    Jan 2007
    Location
    Islamabad
    Age
    35
    Posts
    1,610
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Today on ring road i was driving at 100kmph. Suddenly it felt that the rear left tire has hit something like a rock or something and produced a sudden loud noise. I stopped the car thinking of a tire blast. But there was nothing and everything was fine. Car drive was perfect as well. Dont know what happened. What else should i get checked?

    Sent from my HTC Desire 626s using PW Forums mobile app
    jay sakoon nahi..te chaer k vekh (A Random Shehzore 2012)

  15. #4414
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khahsan View Post
    I have the same problem
    When car is hot, it does not start if stopped. Engine does not cranks and shows symptoms like a dead battery issue. But it starts perfect after 5-6 minutes.
    Battery, starter everything checked.

    Sent from my HTC Desire 626s using PW Forums mobile app
    Its usually happened because of a old / weak battery,also make sure battery terminals are properly tight.If all these things are ok then check valve timing and valve Clearance.
    Never loose hope in life,every step gives u something.

  16. #4415
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khahsan View Post
    Today on ring road i was driving at 100kmph. Suddenly it felt that the rear left tire has hit something like a rock or something and produced a sudden loud noise. I stopped the car thinking of a tire blast. But there was nothing and everything was fine. Car drive was perfect as well. Dont know what happened. What else should i get checked?

    Sent from my HTC Desire 626s using PW Forums mobile app
    Check rear strut assembly and as well as tyre & rim.
    Never loose hope in life,every step gives u something.

  17. #4416
    PakWheeler Follow
    manii009's Avatar
    Join Date
    Apr 2012
    Location
    Karachi
    Posts
    122
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    hey everyone. I am having some issues. i know these might be the minor one but for me it is a pain in the butt. I own suzuki baleno 99 model which is on petrol means no cng in my car. The issue i am facing is, the car rpm at idle gets too low. i dont have the rpm meter but as per my assumption, it gets to a point of 450 to 500. When i am idle at traffic signal, the car vibrates due to low rpm(steering wheel vibrates). Second thing i observed is my car rpm fluctuates some times, not on regular basis but at few intervals. for the update i had serviced my throttle body with the iac sensor. i removed it and serviced it properly. the plugs were cleaned as oil deposit was there. i changed the air filter also. To cut short this issue started a while back when the car started to shut off at idle. that issue got resolved but this thing came on. I know all of you guys are well experienced in baleno subject, so any help is appreciated.

    My car air compressor is also making a buzzing noise when it is turned on. i guess it need replacement.

    P.s. I live in Karachi, any good mechanic recommendation would be a huge favor.

  18. #4417
    PakWheeler Follow
    engr.asfandyar's Avatar
    Join Date
    Oct 2016
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Bro can u give me ur cell number. I hv 1 major issue to discuss regarding overheating and pressure building in radiator

  19. #4418
    PakWheeler Follow
    hasan_lhr's Avatar
    Join Date
    Apr 2008
    Location
    Lahore
    Age
    35
    Posts
    120
    Follows
    0
    Following
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have recently purchased Suzuki Baleno 2004-05 boss it is outclass. Bought it in 550k. Sir believe me it is awesome with Genuine condition it has everything which you want to have in your car. Baleno is far better than what i expected.

  20. #4419
    PakWheeler Follow
    attikhan87's Avatar
    Join Date
    May 2016
    Location
    Karachi
    Age
    28
    Posts
    29
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Looking for baleno in 4.5 lacs

    Sent from my C5303 using PW Forums mobile app

  21. #4420
    Senior PakWheeler Follow
    abid110's Avatar
    Join Date
    Jan 2014
    Location
    Karachi
    Posts
    3,909
    Follows
    4
    Following
    0
    Mentioned
    90 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    3
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by attikhan87 View Post
    Looking for baleno in 4.5 lacs

    Sent from my C5303 using PW Forums mobile app
    Aaram se mil jaegi 2003/4 ka model of crystal lights...but most balenos in market are fully used up and not worthy of buying...me ne bht search ki thi recently

    Sent from my QMobile Z10 using Tapatalk

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •