Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: Help needed: Electrical problem in Baleno

  1. #1
    PakWheeler Follow
    Dani80pk's Avatar
    Join Date
    Aug 2009
    Location
    Karachi
    Age
    36
    Posts
    394
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Help needed: Electrical problem in Baleno

    My car's check engine light comes on some times alongwith battery light. The battery also goes dead without any indication mostly whether engine is cold or hot. I took my car to show room today and they checked it with Tech-1 and tech-2 and it reports "Wrong engine system selected". They finally concluded that wiring of car is impaired by some electrician and said that they will not do any thing and asked me to take it some where else. Please tell me what to do???


  2. #2
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3991 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    hmm - pretty weird if Suzuki cant handle it, but Ive done a lot of cars that suzuki couldnt handle. I think firstly you need to check if your alternator is not shoving thick A/C volts into the battery due to a faulty diode in the rectifier, If it is it can also lead to bad signals from the engine position sensors hence check light

  3. #3
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3991 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    you can PM me for fixing this

  4. #4
    PakWheeler Follow
    Dani80pk's Avatar
    Join Date
    Aug 2009
    Location
    Karachi
    Age
    36
    Posts
    394
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    hmm - pretty weird if Suzuki cant handle it, but Ive done a lot of cars that suzuki couldnt handle. I think firstly you need to check if your alternator is not shoving thick A/C volts into the battery due to a faulty diode in the rectifier, If it is it can also lead to bad signals from the engine position sensors hence check light
    Thanks for the prompt reply. How can I check whether the alternator is not doing its job. Secondly check engine light always comes with battery light. Whenever i have to left car for more than an hour, I disconnect negitive terminal of battery and it does fine. If I left that connected, it becomes weak. Can you give me your contact number on my email address dani_80_pk@hotmail.com so that I can talk to you in detail.

  5. #5
    PakWheeler Follow
    Dani80pk's Avatar
    Join Date
    Aug 2009
    Location
    Karachi
    Age
    36
    Posts
    394
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @all. Pakwheelers. Where are you??? Please help me yar .

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •