Survey by Qualaroo
+ Reply to Thread
Results 1 to 9 of 9

Thread: Baleno 2005 :: Heating Problem

  1. #1
    PakWheeler Follow
    asif.jafry's Avatar
    Join Date
    Feb 2010
    Location
    Karachi
    Age
    36
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Baleno 2005 :: Heating Problem

    Aoa
    I've recently encountered a problim in my Baleno 2005. My car runs normally with or without A/C. The temperature remains normal (i.e. at mid level). But when i get stuck in traffic jams, the temperature starts to rise. And it remains around Quarter higher than mid level until my car is stuck. As soon as i get out of traffic n' reaches certain speed level, say in 3rd gear the temperature comes back to normal and remains so for as long as i drive.

    I've checked teh readiotor, the coolant level is fine. The coolant is new as well, only two weeks old. Can anyone help please??


  2. #2
    Senior PakWheeler Follow
    Ishtiaq778's Avatar
    Join Date
    Feb 2010
    Location
    Dina
    Posts
    1,172
    Follows
    1
    Following
    1
    Mentioned
    81 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear Asif, im not an expert but would like to share my experencne.
    1. check the speed of radiator fan, i thing the fan is not doing its job well,
    2. When you got serviced the radiator last time?
    3. When your car was tuned?

  3. #3
    PakWheeler Follow
    khanusman79's Avatar
    Join Date
    Jan 2010
    Location
    Islamabad
    Age
    37
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    This used to happen in my old suzuki khyber and it was eventually found that engine had blown gasket.

  4. #4
    PakWheeler Follow
    asif.jafry's Avatar
    Join Date
    Feb 2010
    Location
    Karachi
    Age
    36
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks for the quick replies guys!!

    My radiotor last got the serviced less than an year ago and I got the car tuned only a month ago. I tried to check the fan and kept my car started for about an hour with AC on. The temperature remained at mid level throughout but the fan did not start!! I don't know if it's faulty or the temperature was not high enough to get it started!! Not too gud with trouble shooting off the car!!

  5. #5
    PakWheeler Follow
    Dani80pk's Avatar
    Join Date
    Aug 2009
    Location
    Karachi
    Age
    36
    Posts
    394
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Probably blown fan motor. I had baleno 99 and its fan used to turned on after 5-10 min of idling.

  6. #6
    Senior PakWheeler Follow
    Ishtiaq778's Avatar
    Join Date
    Feb 2010
    Location
    Dina
    Posts
    1,172
    Follows
    1
    Following
    1
    Mentioned
    81 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ok, check the thermal gauge, as well as fan, go to a good auto electrition for this check, your problem will be solved soon Insha Allah

  7. #7
    PakWheeler Follow
    asif.jafry's Avatar
    Join Date
    Feb 2010
    Location
    Karachi
    Age
    36
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks bro!!

  8. #8
    Senior PakWheeler Follow
    Proverbial_Slang's Avatar
    Join Date
    May 2005
    Location
    Lahore
    Posts
    3,903
    Follows
    0
    Following
    0
    Mentioned
    29 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check the fan speed and get ur radiator cleaned from outside. Spray water in it and clean all the gunk.
    Death is not the greatest loss in life. The greatest loss is what dies inside us while we live.

  9. #9
    PakWheeler Follow
    asif.jafry's Avatar
    Join Date
    Feb 2010
    Location
    Karachi
    Age
    36
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks all for the replies!! I got my car checked n' it turned out that fan and thermostat were fine. I've got the radiator serviced now... Still to check teh result as not stuck traffic yet! !

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •