Survey by Qualaroo
+ Reply to Thread
Results 1 to 10 of 10

Thread: Baleno's Problem

  1. #1
    PakWheeler Follow
    LatY567's Avatar
    Join Date
    Oct 2004
    Location
    Karachi
    Age
    32
    Posts
    53
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Baleno's Problem

    salam guyz
    my baleno is showin engine check sign and it disappears after few minutes and its shows again .....
    i changed plugs ,plug wires, engine oil, oil filter, air filter and all tht but it still appear and go again
    and yeh RPM is not stable tooo when i start the engine it goes upto 2000 and slowly comes to 1000 but it keeps goin up and down....
    do u guys know any Efi expert in karachi or can anyone tell me da exact location of khan autos at korangi road??
    plz help me out guys....
    thankz

  2. #2
    PakWheeler Follow
    LatY567's Avatar
    Join Date
    Oct 2004
    Location
    Karachi
    Age
    32
    Posts
    53
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    please help me out guyz!! am waiting for your replies.....

  3. #3
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    MAP sensor is faulty

    change it
    AE 86

  4. #4
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Hello!
    some of the sensors is messing up....
    meanwhile is ur Baleno is converted on CNG?????
    if yes.....the emulator wiring is messed up.......or say wrong wired...
    if on petrol....some of the sensor is not working properly..
    Thanxxx
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  5. #5
    PakWheeler Follow
    jhashmif1's Avatar
    Join Date
    Jun 2005
    Location
    N/A
    Age
    44
    Posts
    221
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    This may be your EFI acting up. Balenos are apparently notorious for these problems. I have a baleno too, but it does not have this problem...yet. I was talking to a mechanic in Karachi and he said that the baleno EFI problem should only be taken to authorised Suzuki dealers because these are the only guys who have the "diagnostics" to check and correct the problem. The best thing for you is to do this. Dont go anywhere but to a authorised Suzuki showroom/dealership.
    I pretend to work, they pretend to pay me

  6. #6
    PakWheeler Follow
    LatY567's Avatar
    Join Date
    Oct 2004
    Location
    Karachi
    Age
    32
    Posts
    53
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    salam
    well guyz i went to one of suzuki dealership and they ppl checked my car on techone system .. they said your V.S.C sensor is givin some error ... and they flashed ecu after checkin tht ... and now my car is ok and rpm is stable too ...
    well i have JXL with factory CNG ... anyway thankz to All of ou ... TGC

  7. #7
    PakWheeler Follow
    maqac's Avatar
    Join Date
    Mar 2006
    Location
    Lahore
    Age
    22
    Posts
    84
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    how much they charged ie cost of this VSC ...
    also visit http://www.flex-a-lite.com/auto/html/vsc.html

  8. #8
    PakWheeler Follow
    maqac's Avatar
    Join Date
    Mar 2006
    Location
    Lahore
    Age
    22
    Posts
    84
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    how much they charged ie cost of this VSC ...
    also visit http://www.flex-a-lite.com/auto/html/vsc.html

  9. #9
    PakWheeler Follow
    aerodyn's Avatar
    Join Date
    Mar 2006
    Location
    Lahore
    Age
    31
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    please tell me how much did they charged you?
    I have a beleno too and I am facing the exact problem. It is also JXL CNG and rpm suddenly goes up to 2.5 and CHECK ENGINE light appears. I have to shut down the engine and start again then to continue driving

  10. #10
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    after some research i found out that it is neither the MAP nor the TPS but it is the fault of ISCV
    ISCV=Idle speed control Valve
    The ISCV can be removed easily by opening the 4 Throttle body nuts at the Intake side . and do remove the HOT water lines going in the ISCV. the function of this sensor is to increase the RPM of car when cold and as the required temp is reached it signa;ls the ECU to normal RPM.

    The problem with ISCV of Baleno is that it has ECU trigger and that is to increase the RPM as the AC is turned on. Toyotas usually have a separate idle controller / enhancer to increase rpm on AC usage and it doesnt go bad easlily.

    The baleno,s ISCV gets very dirty (as time passes) and starts giving bad signal to ECU and the fact is it can even happen on petrol too . CNG aint the only factor for that and the "Chek Engine " light comes up.

    Replacing the ISCV sensor is recommended but cleaniing it by WD40 or petrol also enhances the ISCV,s life(remove before cleaning).

    or try this !

    1.remove the air intake plastic pipe
    2.start ur car on petrol ( dont accelerate)
    3.u will see a small channel in the bottom of the throttle body, spray some WD40 in it and accelerate the engine around 3500 RPM for some time
    4.repeat the procedure (it will clean the channels and the jammed solenoid of ISCV usually gets free)
    5.If above doesnt work, replace the ISCV , or clean by removing it

    ----------------------
    AE 86

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •