Survey by Qualaroo
+ Reply to Thread
Results 1 to 18 of 18
Like Tree3Likes
  • 1 Post By waleed96
  • 1 Post By saboor73
  • 1 Post By saboor73

Thread: Engine rebuilt and something about sensors.

  1. #1
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Engine rebuilt and something about sensors.

    So I have a Baleno 2002 JXL (G13B engine) and I just had the engine rebuilt(new valves, piston rings, head gasket), I have gone through 500km after the rebuild and I am wondering if i should use "engine flush" or some type of oil additive like "Engine Treatment" etc to quiet it down a little bit as it is a little annoying with the noise. Plus, the engine vibrates a little on CNG, on petrol its fine. Also, after the rebuild when i turn on the A/C on CNG it loses power like CRAZY, i have a hard time even making the car to MOVE in first gear but when it is going like on motorway, the AC and power is fine even in Fifth gear!

    Plus, I did a little research online and found out that Baleno as they are called Esteem in America were equipped with MAF sensors, EGR valves and also an O2 sensor, neither of which are equipped on my car! those two sensors can make one hell of a difference in a smooth operation of the engine and also mileage so what do i do?? Is it possible to DIY this?? Can i get these sensors and equip my car too??

    Help a fella PLEASE!


  2. #2
    PakWheeler Follow
    waleed96's Avatar
    Join Date
    May 2014
    Location
    Karachi
    Age
    20
    Posts
    334
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    2

    Default

    First of all, after the rebuilt, you are supposed to drive your car on petrol for 1000 to 1500 kms.

  3. #3
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes thats what i planned to do but on petrol the car's rpm was way too responsive, a nudge and it would go screaming to 2000 rpms and i wasnt comfortable with that, still i drove it the first 300 kms on petrol and then some mechanics recommended CNG coz its a very "tammed" fuel, basically its a lousy fuel so i thought maybe it would put less stress on the engine and the rpm wont jump around so much, i've managed to drive 500 km with rpm ranging from 1500-2000 ...

  4. #4
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,545
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Iac valve can be reason for high rpm on petrol


    What is check light status?

  5. #5
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No check Engine light, ya thts exactly what the issue was, a dirty IAC and faulty throttle body which i fixed, now the problem that i have isnt of high rpm, its of low rpm and loss of engine power on CNG when the AC is turned on, anyway, somebody on the forum told me about getting the CNG speed adjusted, i'll do that and see if it helps, thanks a lot! (Y)

  6. #6
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,545
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by nayfus08 View Post
    No check Engine light, ya thts exactly what the issue was, a dirty IAC and faulty throttle body which i fixed, now the problem that i have isnt of high rpm, its of low rpm and loss of engine power on CNG when the AC is turned on, anyway, somebody on the forum told me about getting the CNG speed adjusted, i'll do that and see if it helps, thanks a lot! (Y)
    Your car have ff CNG or aftermarket?

  7. #7
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,545
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    And I hope you relubed IAC valve after cleaning it

  8. #8
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Your car have ff CNG or aftermarket?
    Whats ff?? It was company fitted yeah... why?

  9. #9
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    And I hope you relubed IAC valve after cleaning it
    Yeah the mechanic did relube it although i dont know if he did it right...

  10. #10
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,545
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by nayfus08 View Post
    Whats ff?? It was company fitted yeah... why?
    FF means factory fitted ff CNG on baleno is very easy to work with

  11. #11
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,545
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by nayfus08 View Post
    Yeah the mechanic did relube it although i dont know if he did it right...
    What he used to relibe IAC valve?

  12. #12
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    What he used to relibe IAC valve?
    Just regular engine oil...

  13. #13
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,545
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by nayfus08 View Post
    Just regular engine oil...
    Bad idea use atf or powerstreering oil

  14. #14
    PakWheeler Follow
    hyder_m29's Avatar
    Join Date
    Feb 2015
    Location
    Karachi
    Age
    31
    Posts
    176
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    Also, confirm that your mechanic hasn't disabled the engine check light. They tend to do that if they find problems they don't how to solve. Usually this is done by turning the key to the On position - if the check light turns On, then the check light is good. If it doesn't light up, it's been disabled.

  15. #15
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,545
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by hyder_m29 View Post
    Also, confirm that your mechanic hasn't disabled the engine check light. They tend to do that if they find problems they don't how to solve. Usually this is done by turning the key to the On position - if the check light turns On, then the check light is good. If it doesn't light up, it's been disabled.
    Old method now these day the wire check light parallel to alternator by doing this they ensure check light stay on when engine is shut and ignition switch is on and goes off on start engine

    The proper way to see check light is to unplug temperature sensor if check light stays off then above thing is done if it comes on its working fine

  16. #16
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Old method now these day the wire check light parallel to alternator by doing this they ensure check light stay on when engine is shut and ignition switch is on and goes off on start engine

    The proper way to see check light is to unplug temperature sensor if check light stays off then above thing is done if it comes on its working fine
    Checklight is fine, ironic isnt it though?? the very thing tht usually tells u wats wrong goes bad itself haha....
    The check engine light is good, i checked following the temp sensor method and it came on

  17. #17
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by nayfus08 View Post
    Just regular engine oil...
    So i gotta take it all out again? uffffff... will do that someday later maybe, im trying a few things first if the problem is fixed then good if not then ill have to give this a try too..

  18. #18
    PakWheeler Follow
    nayfus08's Avatar
    Join Date
    Sep 2015
    Age
    24
    Posts
    23
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Bad idea use atf or powerstreering oil
    So i gotta take it all out again? uffffff... will do that someday later maybe, im trying a few things first if the problem is fixed then good if not then ill have to give this a try too..

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •