Survey by Qualaroo
+ Reply to Thread
Results 1 to 14 of 14

Thread: check engine message on my baleno

  1. #1
    PakWheeler Follow
    mewithwishes's Avatar
    Join Date
    May 2008
    Location
    Islamabad
    Age
    36
    Posts
    357
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default check engine message on my baleno

    aoa guyz


    i have a baleno 2001 ,since last four days i am getting a message on my screen saying check engine,initially i thought change of oil is due and it might be an indication for that as the quantity might have got low,i changed that this morning and still this message appears in front ,i have got a bit of doubt about the plug wires for my car,is that making an effect??or what else can be a possible reason
    Only a fool repeats the same thing and expects a different result

  2. #2
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @mewihwishes what screen are you talking about?
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  3. #3
    PakWheeler Follow
    mewithwishes's Avatar
    Join Date
    May 2008
    Location
    Islamabad
    Age
    36
    Posts
    357
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check engine mesasge on the front
    Only a fool repeats the same thing and expects a different result

  4. #4
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    OOOO i see it's called a ''INSTRUMENT PANEL'' BTW you should check your air filter,your spark plugs and your fuel filter!
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  5. #5
    Senior PakWheeler Follow
    riz_'s Avatar
    Join Date
    Sep 2007
    Location
    Select City
    Age
    50
    Posts
    6,175
    Follows
    0
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Rather than guessing why the light is on; go to a mechanic with OBD scanner. They will be able to tell you precisely why the light is on and how to rectify the problem.

    The reason may be as simple as loose fuel fill cap to as complicated as a failure or imminent failure of a vital power train component. It is never a good practice to ignore such warnings.
    My opinions, suggestions and thoughts are strictly my own. I reserve the right to be human and make mistakes.

  6. #6
    PakWheeler Follow
    mewithwishes's Avatar
    Join Date
    May 2008
    Location
    Islamabad
    Age
    36
    Posts
    357
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanks riz,if i go to a cng computerise mechanic will they be able to diagnose this problem
    Only a fool repeats the same thing and expects a different result

  7. #7
    Senior PakWheeler Follow
    usman_khawaja's Avatar
    Join Date
    May 2008
    Location
    Sialkot
    Age
    35
    Posts
    2,143
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro, change Oil filter, air filter, engine oil and plugs. I hope the issue will be fixed. This issue appears sometimes in the following cases,


    1- If the car is not serviced for a longer time.


    2- And this issue comes rarely If engine is washed with a high water pressure.


    Anyways, you should also consult this problem with Suzuki motors in your area.
    SEO, SEM and Internet Marketing Evangelist

  8. #8
    Senior PakWheeler Follow
    riz_'s Avatar
    Join Date
    Sep 2007
    Location
    Select City
    Age
    50
    Posts
    6,175
    Follows
    0
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mewithwishes



    thanks riz,if i go to a cng computerise mechanic will they be able to diagnose this problem



    If that mechanic has an OBD scanner, then yes.
    My opinions, suggestions and thoughts are strictly my own. I reserve the right to be human and make mistakes.

  9. #9
    PakWheeler Follow
    Ehtesham4's Avatar
    Join Date
    Jan 2007
    Location
    Lahore
    Age
    62
    Posts
    50
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hi, before changing anything I wud suggest to do one thing.


    Remove the Minus(-) battery connector while the engine is stopped and leave it for about 2 mins. and then reconnect. Check if it is gone otherwise you should go to some workshop who have the Computer code diagnostic machine.


    Normally it is from the catalyte converter or oxygen sensor malfunction. Anyway just try this.
    -

  10. #10
    PakWheeler Follow
    gunshippilot's Avatar
    Join Date
    Aug 2006
    Location
    Lahore
    Age
    43
    Posts
    610
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    go to any electrician who can tell you what is the problem ...normally it takes 10-15 mins.....

    there is some code 2 blinks, 3 blinks,of cx light can tell the problem......

    waiesay koi khaas pareshan honay ki baat nahin hay this is not a mechanical faliure.....some wire must have gotten damaged some where.......
    Flying is my passion.

  11. #11
    PakWheeler Follow
    mewithwishes's Avatar
    Join Date
    May 2008
    Location
    Islamabad
    Age
    36
    Posts
    357
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i appreciate your suggestions reagarding the issue,and will give put for an inspection tomorow morning





    god bless u
    Only a fool repeats the same thing and expects a different result

  12. #12
    Senior PakWheeler Follow
    panicslayer's Avatar
    Join Date
    Nov 2008
    Location
    Islamabad
    Age
    35
    Posts
    10,044
    Follows
    2
    Following
    0
    Mentioned
    10 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    As some brother said to replace the battery terminal... Wrong.... As this check engine is due to some fault's code send the the ECU.... removing battery terminal will wash that code but won't correct the real issue....

    @poster... get ur car checked ASAP. The mechanic himself will do the battery thing to remove the code BUT AFTER diagnosing the problem
    Suggestions required

  13. #13
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,956
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    the check lite comes mostly coz of a loose wire i.e incomplete current. or a short circuit

    if the problem is there removing the batery terminal wud not resolve the issue it wud remain there.

    the best solution is a OBD device which wud tell u wat the fault is.

    earlier only dealers had these but now many other workshops have them and charge accordingly.
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  14. #14
    PakWheeler Follow
    Ehtesham4's Avatar
    Join Date
    Jan 2007
    Location
    Lahore
    Age
    62
    Posts
    50
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Again, before doing anything just try it. Unplug the Negative battery terminal, waiting 2 mins and then reconnect.


    It will clear the code from the computer's memory of your car. Some time this code appears temporarily with some minor fault but is corrected by itself like Oxygen sensor get some dust or the Catalyte converter get choked, which by pressing the pedal few times clears the mess but Check Engine light will not go unless computers memory is not cleared.


    After reconnecting when you start the car computer will run a diagnostics itself and if the error is still their it will show the error else it will disappear.


    Hope i am able to make a point. I did this to my sons car and it worked.
    -

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •