Survey by Qualaroo
+ Reply to Thread
Results 1 to 3 of 3

Thread: Belta 2008 transmission shifting issue

  1. #1
    PakWheeler Follow
    farrukh_mohd's Avatar
    Join Date
    May 2009
    Location
    Karachi
    Age
    46
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Angry Belta 2008 transmission shifting issue

    Hi guys,

    I have Belta 2008 1000cc, recently belta having problem in shifting of gears.

    I did changed transmission oil & clean oli filter from Toyota eastern & put on computer there was no error or code showing in computer.

    Whenever I put on AC transmission works fine but car become heated same shifting problem starts and on without AC
    from the initial it not shifting gear.

    When I accelerate race very slowly car do shift properly.

    Please guys suggest me what to do or any buddy have same kind of experience & how fix it ?

    Thanks,
    Farrukh khan


  2. #2
    PakWheeler Follow
    ayyansheikh's Avatar
    Join Date
    Feb 2013
    Location
    Lahore
    Posts
    37
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    does this problem occur after changing transmission oil?

  3. #3
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,829
    Follows
    7
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by farrukh_mohd View Post
    Hi guys,

    I have Belta 2008 1000cc, recently belta having problem in shifting of gears.

    I did changed transmission oil & clean oli filter from Toyota eastern & put on computer there was no error or code showing in computer.

    Whenever I put on AC transmission works fine but car become heated same shifting problem starts and on without AC
    from the initial it not shifting gear.

    When I accelerate race very slowly car do shift properly.

    Please guys suggest me what to do or any buddy have same kind of experience & how fix it ?

    Thanks,
    Farrukh khan
    Wrong transmission oil can be an issue.
    which oil you are using?
    Be Addicted To Help Others.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •