Survey by Qualaroo
+ Reply to Thread
Page 158 of 162 FirstFirst ... 58108148156157158159160 ... LastLast
Results 3,141 to 3,160 of 3239
Like Tree807Likes

Thread: Toyota Belta Owners & Fan Club

  1. #1
    Senior PakWheeler Follow
    lovable's Avatar
    Join Date
    Dec 2006
    Location
    Gujranwala
    Age
    32
    Posts
    1,702
    Follows
    1
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Belta Owners & Fan Club

    HELLO !

    Come discuss your Beltas here.

    Praise your rides.....

    Show your rides here....

    Get information from xperts.

    Discuss with each other...

    Belta owners and Fan's Club join and enjoy every thing here......

    i am starting it with my Ride .......

    and waiting for others to join.......

    TOYOTA BELTA (2005-2012)
    (JAPAN-SPEC)

    (complied by murtaza_murti):

    Optional engines:

    - 1KR-FE 1.0L (1000cc) inline 3-cylinder, 71HP/63 Ib-ft torque
    - 2SZ-FE 1.3L (1300cc) inline 4-cylinder, 86HP/89 Ib-ft torque
    - 2NZ-FE (comes in 4WD variants only) (1300cc) inline 4-cylinder, 84HP/89 Ib-ft torque

    * Note: All of the engines are equipped with VVT-i

    Drivetrains:

    - 1KR-FE = FF (front-wheel drive)
    - 2SZ-FE = FF (front-wheel drive)
    - 2NZ-FE = 4WD/AWD (four-wheel drive/all-wheel drive)

    Transmissions:

    - 1KR-FE = Super CVT-i
    - 2SZ-FE = Super CVT-i
    - 2NZ-FE = 4-Speed automatic with Super Select ECT with Gate Shifter

    Packages/variants/selections:

    B Package = Complete base package; manual windows, plastic door panels, black non-powered mirrors, black door handles, black trunk garnish, silver steel wheels with no wheel caps and base FM/AM radio.

    X Package = Powered windows, powered/re-tractable side-view mirrors, fabric door panels, chrome trunk garnish, colored handles and mirrors, built-in CD player or TV/NAV option, keyless entry, headlight beam adjuster (came in limited models) and black steel wheels with wheel caps.

    XS Package = Sports package same as the 1.0L X but with 14'' alloy wheels, rear LED trunk spoiler, RPM meter, fog lamps and side skirts.

    XL Package = All options of the X package but with a RPM meter, rear speakers, climate control, rear armrest, 50/50 split seats.

    G Package = All options of the L package but with Keyless Go option (push button start, door and trunk sensors, smart key). Alloy wheels, body-kit, fog lamps, iON purifier, multi-function steering wheel and voice TV/NAV with bluetooth and G-Book are optional factory options.

    Chassis code, DBA-KSP92:

    - 1.0L B
    - 1.0L X
    - 1.0L XS

    Chassis code, DBA-SCP92:

    - 1.3L X B (Business)
    - 1.3L X
    - 1.3L XS
    - 1.3L X 'L'
    - 1.3L G

    Chassis code, CBA-NCP96 (4WD):

    - 1.3L X (4WD)
    - 1.3L X 'L' (4WD)
    - 1.3L G (4WD)

    Colors:

    - Meteorite Grey Metallic
    - Silver Streak Mica
    - Barcelona Red Mica
    - Jade Sea Green Metallic
    - Polar White
    - Pearl White Metallic
    - Zephyr Blue Metallic
    - Pacific Blue Metallic

    Factory tire sizes:

    - 1.0L (B and X): 165/70/R14
    - 1.0L XS with 14'' alloys: 175/65/R14
    - 1.3L (XB, X): 165/70/R14
    - 1.3: (XS, XL and G) with 15'' alloys: 185/60/R15

    Face-lift came out in the 4th quarter of 2008, changes were as follows:

    - RPM meter standard in all models
    - RPM meter in XL & G changed colors and font
    - XL package replaces L package
    - Mesh front grill
    - Indicators removed from fenders
    - Side-view mirrors now with built-in indicators
    - Lighter grey interior color (dashboard, door panels, headliner etc)
    - Different seat fabric pattern
    - XL & G now have thicker bolster seats
    - Beige carpet instead of black
    - Rear door window switches merged with door armrests
    - Different wheel caps for G
    - Different 8-spoke alloy wheel design for XL & G
    - Key fob remote buttons switched to plastic from rubber
    - XS (sport) package dis-continued

    Manuals:

    - 1KR-FE Engine repair manual:


    http://webpages.charter.net/scott.mcclure/Yaris/1KR-FE/


    - Owners manual in English (ZIP file):

    https://docs.google.com/file/d/0B8-K...VFE/edit?pli=1

    NOTE: The production of the Toyota Belta and Yaris sedan STOPPED in the third quarter of 2012 in Japan and North America. The Belta was known as the Vios elsewhere. The new shape Vios came out in 2013 to replace the previous model in Thailand, Malaysia, Indonesia and other southeastern Asian countries along with Arabian Gulf countries and in some Middle Eastern countries.

    F U R Q A N

  2. #3141
    PakWheeler Follow
    AABBDDuullaahh's Avatar
    Join Date
    May 2009
    Location
    Lahore
    Age
    20
    Posts
    374
    Follows
    0
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ajall View Post
    Aoa. Everyone. After a long time again I m chipping in the forum please. Day before yesterday I went to Lahore from Islamabad on my Belta 78k ODO meter, and came back today. On my journey back, I felt car was a bit heavy with engine more roaring noise. And after 100kmh speed it required hard pressing of acceleration pedal. And it also consumed about 40% more fuel as compared to previous routine. At lahore I only got my air filter cleaned by putting air with pressure. Nothing else. Engine roars more noise less acceleration, with pressing hard it touches to 120kmh, and consuming more fuel. My request to gurus of Belta, please diagnose, and advise me what to do. Thanks.

    Sent from my XT1254 using PW Forums mobile app
    Some possible reasons could be.
    1) fuel. You may have refuelled your car at lahore and the fuel you got was low quality, hence less power per unit and higher consumption.
    2) Wrong placement of the air filter could have a little effect too. If the filter doesn't sit properly air can escape from the sides, this can increase the engine noise and may cause increased fuel consumption.
    3) Check the engine oil level. A reduction in engine oil will cause engine noise to increase and the additional friction will increase your fuel consumption.
    4) could be the inclination. A little after pindi bhattian till islamabad it's almost a constant climb. (Though at first its very little, still if you carry an altitude meter it shows that you're slightly ascending)

  3. #3142
    PakWheeler Follow
    s0ulquiver's Avatar
    Join Date
    Mar 2009
    Location
    Islamabad
    Age
    28
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Totally belta engine vibrate

    Dear all,
    Please help me out. I am facing an issue, car engine vibrant on idle (few vibration on P/N mode with out AC but with AC it vibrant too much) drive is prefect with or with out ac and facing no vibration on drive mode.

    Thanks in advance.

  4. #3143
    PakWheeler Follow
    adeelraja78's Avatar
    Join Date
    Oct 2014
    Location
    Karachi
    Age
    33
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by s0ulquiver View Post
    Dear all,
    Please help me out. I am facing an issue, car engine vibrant on idle (few vibration on P/N mode with out AC but with AC it vibrant too much) drive is prefect with or with out ac and facing no vibration on drive mode.

    Thanks in advance.
    Probably because of dropping rpm. Please check ignition coil, spark plug and connectors and may your injectors need cleaning..

  5. #3144
    PakWheeler Follow
    ajall's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Posts
    220
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by AABBDDuullaahh View Post
    Some possible reasons could be.
    1) fuel. You may have refuelled your car at lahore and the fuel you got was low quality, hence less power per unit and higher consumption.
    2) Wrong placement of the air filter could have a little effect too. If the filter doesn't sit properly air can escape from the sides, this can increase the engine noise and may cause increased fuel consumption.
    3) Check the engine oil level. A reduction in engine oil will cause engine noise to increase and the additional friction will increase your fuel consumption.
    4) could be the inclination. A little after pindi bhattian till islamabad it's almost a constant climb. (Though at first its very little, still if you carry an altitude meter it shows that you're slightly ascending)
    Thanks .Brother .I will look into it.

    Sent from my XT1097 using PW Forums mobile app

  6. #3145
    PakWheeler Follow
    ajall's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Posts
    220
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Aoa. brother.checked plugs,changed new air filter, tank refilled from Islamabad. But problem still persists. Starting is fine, slow acceleration is fine. But if hard press the pedal, more noise but less and slow acceleration, and after touching 100kmh , car hardly goes beyond. Please advise and help me. Any problem in CVT, can also create the same problem?

    Sent from my XT1097 using PW Forums mobile app

  7. #3146
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ajall View Post
    Aoa. brother.checked plugs,changed new air filter, tank refilled from Islamabad. But problem still persists. Starting is fine, slow acceleration is fine. But if hard press the pedal, more noise but less and slow acceleration, and after touching 100kmh , car hardly goes beyond. Please advise and help me. Any problem in CVT, can also create the same problem?

    Sent from my XT1097 using PW Forums mobile app
    Reset the ECU and see if that helps. Disconnect the battery terminals for a few mins and then connect and drive around normally for awhile.

  8. #3147
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Reset the ECU and see if that helps. Disconnect the battery terminals for a few mins and then connect and drive around normally for awhile.
    Battery ok? Throttle body clean probably carbon buildup?

  9. #3148
    PakWheeler Follow
    ajall's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Posts
    220
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Affirmative, throttle body also cleaned. ECU also reset by disconnecting negative terminal for 10 minutes.if it is right procedure of resettingnECU.

    Sent from my XT1097 using PW Forums mobile app

  10. #3149
    PakWheeler Follow
    ajall's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Posts
    220
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Any good workshop other than Toyota, at Islamabad. please.?

    Sent from my XT1097 using PW Forums mobile app

  11. #3150
    PakWheeler Follow
    zahidb's Avatar
    Join Date
    Jul 2010
    Location
    Lahore
    Posts
    52
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ok mate... this is an issue with almost all Beltas (1000cc) & some Vitz...sad news is theres no 100% cure.. doing the following will reduce it.. but once this vibration starts happening it doesnt goes away .. trust me.. i have been 'fighting' this for the past 5 years

    anyway.. you can do the following routines for "reducing" this idle vibration

    regular throttle body cleansing/tuning/plugs cleansing (after every 2-3k km) & afterwards getting your RPMs reset thru computer

    get your CAT (Jaali) cleaned (its at the front of the engine behind bumper.. it made a huge difference in performance once i got it cleaned last month..)

    get the EFI (fuel injectors serviced)

    change your CVT-TC transmission oil if you havent done so & the car has mileage of over 50k km. needs to be replaced after every 40-50 k

    regularly add/mix HOBC whenever available/possible

    you may add extra Earth to your engine.. its does slightly reduced this vibration in my case

    & last..I have heard that changing engine is the final option (with 1300cc)


    Quote Originally Posted by s0ulquiver View Post
    Dear all,
    Please help me out. I am facing an issue, car engine vibrant on idle (few vibration on P/N mode with out AC but with AC it vibrant too much) drive is prefect with or with out ac and facing no vibration on drive mode.

    Thanks in advance.

  12. #3151
    Senior PakWheeler Follow
    Nabeel_Ali's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    24
    Posts
    3,509
    Follows
    2
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by zahidb View Post
    ok mate... this is an issue with almost all Beltas (1000cc) & some Vitz...sad news is theres no 100% cure.. doing the following will reduce it.. but once this vibration starts happening it doesnt goes away .. trust me.. i have been 'fighting' this for the past 5 years

    anyway.. you can do the following routines for "reducing" this idle vibration

    regular throttle body cleansing/tuning/plugs cleansing (after every 2-3k km) & afterwards getting your RPMs reset thru computer

    get your CAT (Jaali) cleaned (its at the front of the engine behind bumper.. it made a huge difference in performance once i got it cleaned last month..)

    get the EFI (fuel injectors serviced)

    change your CVT-TC transmission oil if you havent done so & the car has mileage of over 50k km. needs to be replaced after every 40-50 k

    regularly add/mix HOBC whenever available/possible

    you may add extra Earth to your engine.. its does slightly reduced this vibration in my case

    & last..I have heard that changing engine is the final option (with 1300cc)
    Indeed this issue is in every vitz/belta. I too have tried everything on my 2nd gen vitz though vibrations are reduced but don't go permanently.
    Coming to my 3rd gen vitz. It's genuine 40k driven now and it had also started to vibrate a little. I will get it tuned asap from Toyota 3s.

    Sent from my SM-N920C using Tapatalk

  13. #3152
    PakWheeler Follow
    adeelraja78's Avatar
    Join Date
    Oct 2014
    Location
    Karachi
    Age
    33
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ajall View Post
    Aoa. brother.checked plugs,changed new air filter, tank refilled from Islamabad. But problem still persists. Starting is fine, slow acceleration is fine. But if hard press the pedal, more noise but less and slow acceleration, and after touching 100kmh , car hardly goes beyond. Please advise and help me. Any problem in CVT, can also create the same problem?

    Sent from my XT1097 using PW Forums mobile app
    Call him 03008911244 (faisal) he might help you

  14. #3153
    PakWheeler Follow
    ajall's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Posts
    220
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Where s his workshop, please.

    Sent from my XT1097 using PW Forums mobile app

  15. #3154
    PakWheeler Follow
    adeelraja78's Avatar
    Join Date
    Oct 2014
    Location
    Karachi
    Age
    33
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ajall View Post
    Where s his workshop, please.

    Sent from my XT1097 using PW Forums mobile app
    His workshop is in khi.

  16. #3155
    PakWheeler Follow
    ajall's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Posts
    220
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Brother but I am at Islamabad......

    Sent from my XT1097 using PW Forums mobile app

  17. #3156
    PakWheeler Follow
    adeelraja78's Avatar
    Join Date
    Oct 2014
    Location
    Karachi
    Age
    33
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ajall View Post
    Brother but I am at Islamabad......

    Sent from my XT1097 using PW Forums mobile app
    Bro you can get his opinion on that issue.

  18. #3157
    PakWheeler Follow
    ajall's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Posts
    220
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ok. thanks. brother

  19. #3158
    PakWheeler Follow
    adeelraja78's Avatar
    Join Date
    Oct 2014
    Location
    Karachi
    Age
    33
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ajall View Post
    Ok. thanks. brother
    Your welcome

  20. #3159
    PakWheeler Follow
    tanveer70's Avatar
    Join Date
    Nov 2012
    Location
    Karachi
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by adeelraja78 View Post
    Yes i know them very well.. Mr Arsalan own that showroom i m regular customer of him. He got a mechanic i dont remeber his name but that mechanic used to work in toyota south. Call mr arsalan directly 03008233793
    thankyou for vauable information.
    I visited toyota defence few days ago in search of my queries, regarding CVT fluid check up they told me to wait for 35 to 40 k kms and discouraged me an early check up as I was insisting for that due to suspicion of odometer manipulation in JDMs. As far as coolant matter was concerned they asked me to use toyota life long coolant not distal water at any cost to restore the the required level.
    these should be simple and straight forward issues but local toyota dealers have made them real issues! I think with increase in the japanese imports toyota should arrange services for JDM at local level.

  21. #3160
    Senior PakWheeler Follow
    arkhitekt's Avatar
    Join Date
    Aug 2015
    Age
    33
    Posts
    3,660
    Follows
    10
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    3

    Default

    Just after 3 months i have sold my Belta 2009, 1000cc and one of the stupid most cars i have ever bought. It takes ages to accelerate and if God Forbid someone infront brakes to slow you down, you are back to square one. Drove a few more cars to compare and they were all the same. My hair have slightly gone white as i started getting old with that slow response. Replaced it with a pkdm City AT 2010 and I'm feeling slightly young driving it compared to Belta. Don't know what the JDM fuss and airbags are for if a car doesn't move.


    https://www.pakwheels.com/forums/sho...d.php?t=272964

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •