Survey by Qualaroo
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 20 of 52

Thread: Problem in L15a1 Vtec Swapped City

  1. #1
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Problem in L15a1 Vtec Swapped City

    Salaams Guys!

    I recently swapped my o4 City iDSI with L15a1 1.5 Vtec of the local Steermatic and JDM Honda Fit and Jazz with Manual tranny ECU and on stock Manual tranny.
    The problem I am facing is that the car denies to Rev above 4000 RPM. It looks like the fuel cut off at redline. The wiring was complete uncut with the engine. Got new exhaust manifold for O2 sensor aswell. Besides the 4000RPM cutoff, I am facing missing and bad idling..

    I require expertise suggestions here. Spent more than 50K on an engine that denies to Rev. Looking forward to expertise and valuable suggestions.


    Problem in L15a1 Vtec Swapped City - 207317

    Problem in L15a1 Vtec Swapped City - 207318

    Problem in L15a1 Vtec Swapped City - 207319

    Problem in L15a1 Vtec Swapped City - 207320

    Attached Images Attached Images     
    Gari ki deals only on PakWheels!

  2. #2
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Pictures not showing..
    Gari ki deals only on PakWheels!

  3. 28-02-2011, 07:58 PM

    Senior PakWheeler


  4. #3
    Senior PakWheeler Follow
    qwertypoiu's Avatar
    Join Date
    Feb 2007
    Location
    Lahore
    Posts
    29,130
    Follows
    2
    Following
    1
    Mentioned
    153 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    1

    Default

    Fixed
    RIP

  5. #4
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Pictures showing now, all by Mod :p
    Thanks qwertyuiop
    Gari ki deals only on PakWheels!

  6. #5
    Senior PakWheeler Follow
    dani123's Avatar
    Join Date
    Nov 2008
    Location
    London
    Age
    22
    Posts
    1,702
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    nice... swAAPPPED
    Just because you're friendly doesn't mean you're insincere Of course..

  7. #6
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Try That Fahad As I Suggest...... ) Most Likely will Solve Your Problem........
    That was Tight Fit B.t.w.......Its Local used L15A??? With FIT or JAZZ Manual Tranny and ECU Also??? Or ECU of L15A Itself???? Using Loom Of?????
    You Sure Pinout Of BOTH ECU's Is same ???
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  8. #7
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I am quiet UNSURE on that Farrukh Bhai! :p
    Gari ki deals only on PakWheels!

  9. #8
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,958
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    on which fuel ?

  10. #9
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by margallar View Post
    on which fuel ?
    Gasoline
    Gari ki deals only on PakWheels!

  11. #10
    Senior PakWheeler Follow
    salik990's Avatar
    Join Date
    May 2006
    Location
    Karachi
    Age
    33
    Posts
    4,250
    Follows
    2
    Following
    0
    Mentioned
    57 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ur ecu is from L15a1 vtec from steermatic? u need the manual ecu for tht as u have swapped the manual gearbox
    My lugnuts require more torque than your Vtec can put out...

  12. #11
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,367
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    u sure the ECU is for L15A manual transmission?
    Life is short and very unpredictable just like a Quarter mile .....

  13. #12
    PakWheeler Follow
    UmarSattar's Avatar
    Join Date
    Jan 2009
    Location
    Lahore
    Age
    30
    Posts
    371
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It is definately ECU..u need to remap ur ECU as a close friend of mine swapped engine in 2002 civc JDM VTech he suffered the same problem....But unfortunately he was unable to get the ECU remaped...He got frustradted and old it out...

  14. #13
    Senior PakWheeler Follow
    ahsan1702's Avatar
    Join Date
    Mar 2006
    Location
    Karachi
    Age
    27
    Posts
    4,028
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No check engine light ? Sounds alot like the VTEC issue

    You ARE using the L15A1 VTEC ECU right ?
    1st Generation Integration

  15. #14
    PakWheeler Follow
    Machizmo's Avatar
    Join Date
    Feb 2005
    Location
    Islamabad
    Age
    36
    Posts
    221
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Does it cut off after 4K like a proper rev limiter or does it kind of stall around that range and refuse to go higher?
    They say power is nothing without control....i say if you're in control, you're not driving fast enough.

  16. #15
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salik990 View Post
    ur ecu is from L15a1 vtec from steermatic? u need the manual ecu for tht as u have swapped the manual gearbox
    It's a Manual tranny ECU sir.
    Gari ki deals only on PakWheels!

  17. #16
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by hash4u View Post
    u sure the ECU is for L15A manual transmission?
    What could make me sure about that? How to check that? There is no such sticker or something written on the ECU.
    Gari ki deals only on PakWheels!

  18. #17
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by UmarSattar View Post
    It is definately ECU..u need to remap ur ECU as a close friend of mine swapped engine in 2002 civc JDM VTech he suffered the same problem....But unfortunately he was unable to get the ECU remaped...He got frustradted and old it out...
    How to get an ECU remapped?
    Gari ki deals only on PakWheels!

  19. #18
    Senior PakWheeler Follow
    faadmemood's Avatar
    Join Date
    Jul 2005
    Location
    Lahore
    Posts
    2,886
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Machizmo View Post
    Does it cut off after 4K like a proper rev limiter or does it kind of stall around that range and refuse to go higher?
    It's the other thing. It's not a proper cut off as in the redline.
    Gari ki deals only on PakWheels!

  20. #19
    PakWheeler Follow
    Machizmo's Avatar
    Join Date
    Feb 2005
    Location
    Islamabad
    Age
    36
    Posts
    221
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    If it's like symptom 1, then:
    Solution 1: Make sure your vendor did not hand you the original steermatic ecu. That will get you nowhere. Swap it with a manual L15A VTEC Ecu.
    Solution: 2: Revert to your stock ECU and get a VTEC controller and lay out separate wires for VTEC.

    If it's like symptom 2, then:
    You're engine is not revving easily after 4K beacuse it's being denied the right amount of air to breathe in that range, courtesy of your unengaging vtec.
    Solution 1: Make sure you got a VTEC ecu with the package.
    Solution 2: Make sure you have the wires for VTEC laid out if you used your stock harness.

    Should work flawlessly.
    They say power is nothing without control....i say if you're in control, you're not driving fast enough.

  21. #20
    PakWheeler Follow
    Machizmo's Avatar
    Join Date
    Feb 2005
    Location
    Islamabad
    Age
    36
    Posts
    221
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thought so. Your's is symptom 2. Check ECU part no and post here. I'll let you know if its meant for your motor or not.
    They say power is nothing without control....i say if you're in control, you're not driving fast enough.

+ Reply to Thread
Page 1 of 3 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •