Survey by Qualaroo
+ Reply to Thread
Results 1 to 10 of 10
Like Tree2Likes
  • 2 Post By hash4u

Thread: Honda City 2005 EPS light issue

  1. #1
    PakWheeler Follow
    secrets's Avatar
    Join Date
    Mar 2010
    Location
    Islamabad
    Age
    35
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Honda City 2005 EPS light issue

    i have recently purchased Honday City 2005. i am facing a problem though EPS light always stays on and Steering is hard...
    Guys guide me what could be the problem?

    note: alignment is checked. no problem there.


  2. #2
    Senior PakWheeler Follow
    rozzzzz's Avatar
    Join Date
    Oct 2005
    Location
    Islamabad
    Posts
    21,924
    Follows
    12
    Following
    0
    Mentioned
    140 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    EPS in 05 city ? when
    MOTOR MANIACS ... An automotive service and repair workshop
    https://www.facebook.com/pages/Motor-Maniacs/721830141231922

  3. #3
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,366
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    ^^
    EPS came in 2003 city idsi onwards
    the light is indicating your power steering unit is malfunctioning
    take your car to a honda workshop or to the guys who do suspension steering work
    Life is short and very unpredictable just like a Quarter mile .....

  4. #4
    Senior PakWheeler Follow
    panicslayer's Avatar
    Join Date
    Nov 2008
    Location
    Islamabad
    Age
    35
    Posts
    10,044
    Follows
    2
    Following
    0
    Mentioned
    10 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    That shows EPS motor has gone mad. U might need to replace that
    Suggestions required

  5. #5
    Senior PakWheeler Follow
    a4awais's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    35
    Posts
    1,287
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    EPS motor is faulty or might be an issue with wiring. Better to visit any honda workshop.
    http://www.facebook.com/jadoon.awais

  6. #6
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,399
    Follows
    131
    Following
    0
    Mentioned
    3987 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    the EPS has shut down - as it has detected a fault, I used to reset and repair hundreds of these after every rain season specially on cars with heavy garbage chinese alloy wheels.

    Take it to Honda, they will scan it, and correct whatever has gone wrong - there are about 16 fault codes for the EPS system.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  7. #7
    PakWheeler Follow
    secrets's Avatar
    Join Date
    Mar 2010
    Location
    Islamabad
    Age
    35
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    the EPS has shut down - as it has detected a fault, I used to reset and repair hundreds of these after every rain season specially on cars with heavy garbage chinese alloy wheels.

    Take it to Honda, they will scan it, and correct whatever has gone wrong - there are about 16 fault codes for the EPS system.
    one thing i like to add... when you start car EPS is working and no light but once you reached to speed near hundred EPS stops working and light lit up?
    any clue?

  8. #8
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,399
    Follows
    131
    Following
    0
    Mentioned
    3987 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    most probably - the EPS unit is losing the VSS signals for too long - or the steering is set off centre, or the car itself needs something aligned.

    Have Honda scan it - its quick and is done from the same DLC where the engine is checked from, it will show up the code, and they SHOULD know what to repair. In my experiences, faults ranged from motor failure (rain water), or torque sensor failure (water) or even general PROM fault within the EPS box.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  9. #9
    PakWheeler Follow
    zeeshanlucky's Avatar
    Join Date
    May 2008
    Location
    Lahore
    Age
    32
    Posts
    55
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation @zulfikar

    bro i wana ask u i cant pm u caz ur inbox is full kindly contact me at 03314800488
    DaDy CoOl

  10. #10
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    the EPS has shut down - as it has detected a fault, I used to reset and repair hundreds of these after every rain season specially on cars with heavy garbage chinese alloy wheels.

    Take it to Honda, they will scan it, and correct whatever has gone wrong - there are about 16 fault codes for the EPS system.
    Yes rain it is. Its been raining all day and i had to travel in huge amount of water. Adding to that my left passenger side screen is leaky somewhere. Water has done some magic and EPS is off. DTC Code is 3 my worst fears. Opened EPS ECU there was no water nothing inside. Dried it with hair drier.

    Note this is intermittent. Sometime it works and while driving from left i hear a relay go off "tick" and eps dies.

    Diagnostic steps please. I have opened the ECU nothing seems abnormal, its grips are dry and clean too
    93 Accord CB7 (Sold) / 2005 CL7

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •