Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Thread: (Help) Honda City iDsi Misfiring on CNG

  1. #1
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default (Help) Honda City iDsi Misfiring on CNG

    Aoa fellow PWers.

    As the topic suggests, my iDsi 2004 is misfiring on CNG since the past few days. The issue started off as rpm dropping, loss of power at low rpms, stalling etc.
    Yesterday, I took to a mechanic. he checked it and said its current issue. So he looked for problems and found a dead fuse jacket. I got it replaced. Now the rpm drops have gone mostly, the car is ok but it misfires a lot. Often dies.

    Just on CNG. Mechanics have no idea whats wrong, everyone makes a wild guess and thats all.

    Another thing, while driving, suppose here is a check post so I brake from 100kph to 40kph and put it in 2nd gear, when I release the clutch pedal, the car encounters a wild hard jerk, as if the engine had died and came back to life due to motion.

    What could be the cause? Need help!

    Regards
    Fawad.
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  2. #2
    Senior PakWheeler Follow
    sk_020's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Age
    22
    Posts
    3,316
    Follows
    1
    Following
    0
    Mentioned
    66 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Advancer is the culprit. I'm facing exact same problem in my city and I had taken a panga with advancer due to which it had gone mad and car started giving a big jerk as u explained on downshifting and sometimes on shifting up.
    go to CNG mechanic. Take a test drive with new advancer. If you feel any difference. then it is surely advancer.

  3. #3
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks for the explanation bro!!

    BTW, how did u tune it? Was yours 2 in 1 setup? I did tune the advancer according to a v.useful thread posted on PW. I guess I messed it up more.
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  4. #4
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    BUMP for anyone else who might have an answer.
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  5. #5
    Senior PakWheeler Follow
    sk_020's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Age
    22
    Posts
    3,316
    Follows
    1
    Following
    0
    Mentioned
    66 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by RollOnBigMaMa View Post
    Thanks for the explanation bro!!

    BTW, how did u tune it? Was yours 2 in 1 setup? I did tune the advancer according to a v.useful thread posted on PW. I guess I messed it up more.
    No problem bro.
    I think you have followed a tomasetto advancer thread. I did the same and ended up ruining the advancer. I don't know whether it is 2 in 1 or else. I was setting it's timing. Which ruined the advancer. A happy 5-6k ka kharcha muft ka..

  6. #6
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It might be due to oil in cng kit,get it checked.
    Never loose hope in life,every step gives u something.

  7. #7
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,377
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    backfiring can be due to bad plugs
    or advancer
    since this car has no plug wires or distributor we can rule that out(and assuming car is fine on petrol)
    do check advancer wiring/fuses etc before opting for replacement
    Life is short and very unpredictable just like a Quarter mile .....

  8. #8
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check Plugs and Plug Wires plus check air filter too. Usually advancer does this type of problem get it diagnosed from a good CNG technician or I suggest to take advancer out install the desi T bolt and then see if happens? I highly recommend use of advancer and use Manual T bolt for only a few kms to check.

  9. #9
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Sk_KingpiN View Post
    No problem bro.
    I think you have followed a tomasetto advancer thread. I did the same and ended up ruining the advancer. I don't know whether it is 2 in 1 or else. I was setting it's timing. Which ruined the advancer. A happy 5-6k ka kharcha muft ka..
    haha, yes exactly. I followed it as well. Btw this silver city in ur dp was involved? or some other city?

    and yaar, I don't know if tuning can ruin an advancer.
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  10. #10
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    BUMP guyz, still need help, advancer installed in corolla GLi and used for 450kms. Not an issue. I touched 165+kph with it. Advancer is fine. Plugs are also ok.

    The other day, found another bad fuse jacket, wasn't THAT bad but still got it replaced. Now the issue is that car doesn't idle on CNG while cold.

    As soon as engine reaches optimum temp, it becomes fine. But misfiring has almost gone, now there are small lags in acceleration. one can feel that the car lost its power for about a second or so and came back to life.
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  11. #11
    Senior PakWheeler Follow
    sk_020's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Age
    22
    Posts
    3,316
    Follows
    1
    Following
    0
    Mentioned
    66 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by RollOnBigMaMa View Post
    haha, yes exactly. I followed it as well. Btw this silver city in ur dp was involved? or some other city?

    and yaar, I don't know if tuning can ruin an advancer.
    YEah. the city in my dp was involved. Got it cnged couple of months back.

  12. #12
    Senior PakWheeler Follow
    sk_020's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Age
    22
    Posts
    3,316
    Follows
    1
    Following
    0
    Mentioned
    66 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by RollOnBigMaMa View Post
    BUMP guyz, still need help, advancer installed in corolla GLi and used for 450kms. Not an issue. I touched 165+kph with it. Advancer is fine. Plugs are also ok.

    The other day, found another bad fuse jacket, wasn't THAT bad but still got it replaced. Now the issue is that car doesn't idle on CNG while cold.

    As soon as engine reaches optimum temp, it becomes fine. But misfiring has almost gone, now there are small lags in acceleration. one can feel that the car lost its power for about a second or so and came back to life.
    Most probably throttle body needs service.

  13. #13
    PakWheeler Follow
    umair94's Avatar
    Join Date
    Apr 2011
    Location
    Islamabad
    Posts
    342
    Follows
    0
    Following
    1
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I was facing a similar issue with my Cultus. First I got air filter changed and got the CNG kit serviced.(Oil removal procedure) But that didn't help much. Then I got tappets adjusted, Plug wires and Spark Plugs changed and problem was solved.

    Might be different for ur car but u can give these things a check

  14. #14
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Sk_KingpiN View Post
    Most probably throttle body needs service.
    But its perfect on petrol? The issue is only on CNG, started a few days back. Before that I could easily kill a GLi with this car.
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  15. #15
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Carby cultus or Efi? and don't you think the issue if realted to tappets n stuff should be on petrol as well?
    Quote Originally Posted by umair94 View Post
    I was facing a similar issue with my Cultus. First I got air filter changed and got the CNG kit serviced.(Oil removal procedure) But that didn't help much. Then I got tappets adjusted, Plug wires and Spark Plugs changed and problem was solved.

    Might be different for ur car but u can give these things a check
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  16. #16
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    BUMP!!! Help
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  17. #17
    Senior PakWheeler Follow
    Durrani_45's Avatar
    Join Date
    Mar 2012
    Location
    Islamabad
    Age
    20
    Posts
    5,244
    Follows
    0
    Following
    0
    Mentioned
    142 Post(s)
    Tagged
    11 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bro get ur cng removed ur engines life is getting less day by day due to cng btw its idsi cng ki kiya zarorat hai apko shehzaday
    miles to go

  18. #18
    PakWheeler Follow
    Rex_K's Avatar
    Join Date
    Oct 2012
    Location
    Select City
    Posts
    577
    Follows
    0
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^^

    Durrani Bhai, Koi hum jesa Petrol afford nae kr skta. Har koi Durrani thori hota hai. Ap tu apni car Jet fuel pr bhi chala sktay ho.

  19. #19
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,377
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    then adjust gas flow screw for the lag
    and the iddle screw on reducer to fine tune it
    if that doesnt work, kit has its own choke, that might need to be fixed
    Life is short and very unpredictable just like a Quarter mile .....

  20. #20
    PakWheeler Follow
    umair94's Avatar
    Join Date
    Apr 2011
    Location
    Islamabad
    Posts
    342
    Follows
    0
    Following
    1
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by RollOnBigMaMa View Post
    Carby cultus or Efi? and don't you think the issue if realted to tappets n stuff should be on petrol as well?
    Efi cultus. Jus Tappets didnt help the situation either. Main culprit were the wires, and plugs had to be changed anyways. Car was jus doin on CNG only so i wasnt accepting all the wires need changing thing either. Then the mechanic proved it by putting some borrowed wires. Dont know the logic or reasoning behind this but it solved the issue. Mechanic also said tappets can also cause it but failed to explain y only on CNG

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •