Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Honda City IDSI - Blower not working.

  1. #1
    PakWheeler Follow
    xyshani's Avatar
    Join Date
    Apr 2008
    Location
    Lahore
    Age
    86
    Posts
    190
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy Honda City IDSI - Blower not working.

    Salams.

    My daughter was fidgeting with the fan switch of my city 2004 today and the fan blower stopped working.

    Now, the Ac switch comes on and the ac lines inside the engine are as cool as they can be. But there is absolutely no air thrown out at any setting from the blower at any fan speed.

    can i get an opinion from the experts? my guess is that there might be a blown fuse.

    regards,
    Xyshani

    -

  2. #2
    PakWheeler Follow
    j12johny's Avatar
    Join Date
    Jul 2013
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by xyshani View Post
    Salams.

    My daughter was fidgeting with the fan switch of my city 2004 today and the fan blower stopped working.

    Now, the Ac switch comes on and the ac lines inside the engine are as cool as they can be. But there is absolutely no air thrown out at any setting from the blower at any fan speed.

    can i get an opinion from the experts? my guess is that there might be a blown fuse.

    regards,
    Xyshani


    check fuse of blower if that was ok then check relay of fan if relay was ok so it mean you have bad switch

  3. #3
    PakWheeler Follow
    xyshani's Avatar
    Join Date
    Apr 2008
    Location
    Lahore
    Age
    86
    Posts
    190
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by j12johny View Post
    check fuse of blower if that was ok then check relay of fan if relay was ok so it mean you have bad switch
    I checked the fuses both in the cabin and in the engine bay. All seems to be fine. The switch is fine as well. I say this because when the AC button is pressed, the AC only turns on if i move the switch to 1 or some other position.

    so i think now i will have to check the relay. will do and update you.

    thanks
    -

  4. #4
    Senior PakWheeler Follow
    talhawaleed's Avatar
    Join Date
    May 2009
    Location
    Islamabad
    Posts
    1,812
    Follows
    1
    Following
    0
    Mentioned
    115 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by xyshani View Post
    I checked the fuses both in the cabin and in the engine bay. All seems to be fine. The switch is fine as well. I say this because when the AC button is pressed, the AC only turns on if i move the switch to 1 or some other position.

    so i think now i will have to check the relay. will do and update you.

    thanks
    problem coming from fan speed is related to blowers resistor.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •