Survey by Qualaroo
+ Reply to Thread
Results 1 to 16 of 16

Thread: Honda City 2010 clutch issue

  1. #1
    PakWheeler Follow
    aliahmadsabir's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    304
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy Honda City 2010 clutch issue

    AOA guys,

    as you all know now a days its rainy season, i was driving my honda city 2010 manual in Lahore, car was full with 5 passengers, there was almost 1 foot water on the road, car was going very fine, but when i crossed over the speed breaker car lost its clutch intact, i was releasing the clutch but car was not picking it up, car took very fast jerks if i tried to release whole clutch, any suggestion and idea? car is still under warranty. after few seconds it start working perfectly.

    Thanks


  2. #2
    Senior PakWheeler Follow
    Lea300's Avatar
    Join Date
    Oct 2008
    Location
    Lahore
    Age
    25
    Posts
    2,309
    Follows
    0
    Following
    0
    Mentioned
    42 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    the same happened with me with my 2013 city aspire
    I do it because i can, I can because I want to, I want to because you said I couldn't =)

  3. #3
    PakWheeler Follow
    aliahmadsabir's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    304
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Lea300 View Post
    the same happened with me with my 2013 city aspire
    so no idea why that happened?

  4. #4
    Senior PakWheeler Follow
    Retaliator's Avatar
    Join Date
    Apr 2006
    Location
    Rawalpindi
    Age
    8
    Posts
    1,445
    Follows
    4
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by aliahmadsabir View Post
    AOA guys,

    as you all know now a days its rainy season, i was driving my honda city 2010 manual in Lahore, car was full with 5 passengers, there was almost 1 foot water on the road, car was going very fine, but when i crossed over the speed breaker car lost its clutch intact, i was releasing the clutch but car was not picking it up, car took very fast jerks if i tried to release whole clutch, any suggestion and idea? car is still under warranty. after few seconds it start working perfectly.

    Thanks
    Exactly the same thing happened with my Swift DLX in about a foot deep water. But it got fine instantly and the clutch is good as ever. In my case i think the catalytic convertor got wet. the engine stalled and it felt as if the clutch is creating problem.

    I think the clutch and gearbox is completely waterproof and water didnt enter it.
    -

  5. #5
    Senior PakWheeler Follow
    Retaliator's Avatar
    Join Date
    Apr 2006
    Location
    Rawalpindi
    Age
    8
    Posts
    1,445
    Follows
    4
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Now what I am thinking is as a preventive measure should we change the clutch fluid???
    @Xulfiqar
    -

  6. #6
    PakWheeler Follow
    mustafa8228's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Posts
    428
    Follows
    0
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    just take it to a honda dealership if u want to be on the safe side , but i think its perfectly fine if its not creating any problem now
    last year , i had an xli 2012 and it suffered such an incident where water level was about 3 feet. the doors leaked and water was all into the cabin , lights failed , even the water entered the engine and got mixed with oil , but there was nothing wrong with the clutch whatsoever..
    For those ten seconds or less, I'm free

  7. #7
    Senior PakWheeler Follow
    digitalmohsin's Avatar
    Join Date
    Aug 2009
    Location
    Lahore
    Age
    27
    Posts
    1,350
    Follows
    1
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    same happened with my mehran.
    20GB Free Online Storage: Sign-up Now: https://copy.com?r=CPom47

  8. #8
    PakWheeler Follow
    aliahmadsabir's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    304
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i dont think Honda people will do anything, they only do if they able to reproduce the issue.

  9. #9
    Senior PakWheeler Follow
    digitalmohsin's Avatar
    Join Date
    Aug 2009
    Location
    Lahore
    Age
    27
    Posts
    1,350
    Follows
    1
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i think water gets into clutch plate therefore clutch slips and jadders for a bit and then when that water evaporates it goes back to normal.
    20GB Free Online Storage: Sign-up Now: https://copy.com?r=CPom47

  10. #10
    PakWheeler Follow
    aliahmadsabir's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    304
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i found almost same issue here,
    Clutch issues after running through water [Archive] - Honda Prelude Forum : Honda Prelude Forums
    look at last reply of that thread.

  11. #11
    Senior PakWheeler Follow
    wasay_ahmed's Avatar
    Join Date
    Nov 2006
    Location
    Lahore
    Age
    29
    Posts
    4,959
    Follows
    3
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    isnt itwheel spin due to very low traction specially in gravle.Comeonn ppl these r not offroad mud bashing machine nor we usually use wet tires specifically.its normal

  12. #12
    Senior PakWheeler Follow
    talhabinomar's Avatar
    Join Date
    May 2011
    Location
    Lahore
    Age
    26
    Posts
    2,469
    Follows
    2
    Following
    0
    Mentioned
    38 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    3

    Default

    do not take your car out of the house and let it dry. then tell the situation

  13. #13
    PakWheeler Follow
    danishijaz's Avatar
    Join Date
    Feb 2012
    Location
    Lahore
    Posts
    160
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    same situation happened with my 2012 city today... what could be the reason???? after 3 min the clutch was OK.. experts please

  14. #14
    PakWheeler Follow
    aliahmadsabir's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    304
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by danishijaz View Post
    same situation happened with my 2012 city today... what could be the reason???? after 3 min the clutch was OK.. experts please

    Since that my car clutch is working fine.

  15. #15
    PakWheeler Follow
    danishijaz's Avatar
    Join Date
    Feb 2012
    Location
    Lahore
    Posts
    160
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    every time when water level is high, my car does same and after that no any trouble... and perfect clutch performance

  16. #16
    PakWheeler Follow
    Saqib369's Avatar
    Join Date
    Jun 2013
    Location
    Lahore
    Posts
    65
    Follows
    1
    Following
    4
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I drove my Honda City in 1.5 feet high water last year and didn't have any issue except that its brakes felt little loose for few seconds and then back to normal. I guess that's normal with all cars.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •