Survey by Qualaroo
+ Reply to Thread
Results 1 to 14 of 14

Thread: honda city 2003 steering steering hard

  1. #1
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default honda city 2003 steering steering hard

    honda city 2003 steering hard like normal old car mechanic said its bcoz of wheel size is big is that possible or bcoz of eps pump.


  2. #2
    Senior PakWheeler Follow
    metalhead's Avatar
    Join Date
    Oct 2006
    Location
    Wah cantt
    Posts
    1,301
    Follows
    1
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    you have eps or hydraulic one?
    Please elaborate your problem. Is it all time hard or in certain conditions like at cold start, or low rpm, etc.

  3. #3
    Senior PakWheeler Follow
    cooldevil's Avatar
    Join Date
    Nov 2010
    Location
    Islamabad
    Posts
    3,047
    Follows
    1
    Following
    0
    Mentioned
    45 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    is it idsi or hypervalve city? i guess idsi has eps while hypervalve has got hydraulic p.s! in case of idsi , eps motor will need a replacement and in case of hypervalve, hydraluic pump will need replacement!

  4. #4
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    its ISDI mouse shape how much motor cost

  5. #5
    PakWheeler Follow
    mohsinuniversal's Avatar
    Join Date
    Dec 2013
    Location
    Karachi
    Age
    29
    Posts
    59
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Rhagvan View Post
    its ISDI mouse shape how much motor cost
    if it is idsi then go to a good nearest electrition check the wiring connectors usually this 80% happens due bad EPS controller card it mounts inside your vehicle dash on the driver side .
    if its controller itself you may get this reconditioned about 6000 PKR
    if its a bad motor its around 8000 PKR Reconditioned

  6. #6
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,399
    Follows
    131
    Following
    0
    Mentioned
    3987 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Is the EPS malfunction indication on?

    If yes then scan it for error codes and have it reset after you repair the problem, the EPS module has a NVM (non volatile memory) hence it remains in its state and will stop power assist permanently if a fault is detected unless its cleared or reset again.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  7. #7
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    Is the EPS malfunction indication on?

    If yes then scan it for error codes and have it reset after you repair the problem, the EPS module has a NVM (non volatile memory) hence it remains in its state and will stop power assist permanently if a fault is detected unless its cleared or reset again.
    Thanks for your reply when i start my car EPS light shows and gone but steering is hard on turning left more hard on right less hard but no EPS light light shows after drivng few KM its appears

  8. #8
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,399
    Follows
    131
    Following
    0
    Mentioned
    3987 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    you have a fault in the torque sensor, you need to reset the unit and retest, I used to do a lot of these in Accord CF3 models, This happens when you palm the steering wheel and turn it too fast. The motor overheats and the controller cuts down assist.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  9. #9
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    you have a fault in the torque sensor, you need to reset the unit and retest, I used to do a lot of these in Accord CF3 models, This happens when you palm the steering wheel and turn it too fast. The motor overheats and the controller cuts down assist.
    steering is hard when i start the car from idle

  10. #10
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    you have a fault in the torque sensor, you need to reset the unit and retest, I used to do a lot of these in Accord CF3 models, This happens when you palm the steering wheel and turn it too fast. The motor overheats and the controller cuts down assist.
    and computer diagnostic shop can reset this fault or i have to go honda i know honda charge too much

  11. #11
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    you have a fault in the torque sensor, you need to reset the unit and retest, I used to do a lot of these in Accord CF3 models, This happens when you palm the steering wheel and turn it too fast. The motor overheats and the controller cuts down assist.
    and computer diagnostic shop can reset this fault or i have to go honda i know honda charge too much

  12. #12
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,399
    Follows
    131
    Following
    0
    Mentioned
    3987 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by Rhagvan View Post
    and computer diagnostic shop can reset this fault or i have to go honda i know honda charge too much
    ask for it. a deep level scan can check. there is also a manual way but i dont recommend it to novice experience
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  13. #13
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    ask for it. a deep level scan can check. there is also a manual way but i dont recommend it to novice experience
    Xulfi bhai if u don mind tell me the manual way i will not do my self i will ask the professional to do that according to your instruction if u don want to disclose this in public PM me plzzz thankful to you

  14. #14
    PakWheeler Follow
    Rhagvan's Avatar
    Join Date
    May 2013
    Posts
    120
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    ask for it. a deep level scan can check. there is also a manual way but i dont recommend it to novice experience
    i went to computer diagnostic shop he scan and told me sensor need service but no result after that he told me card need to changed

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •