Survey by Qualaroo
+ Reply to Thread
Results 1 to 6 of 6

Thread: Throttle position calibration

  1. #1
    PakWheeler Follow
    danish.ijaz.754's Avatar
    Join Date
    Feb 2013
    Location
    Lahore
    Age
    27
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Throttle position calibration

    Car is Honda city 2012. Odo reading 40k.
    I was having no problem regarding RPM. Even when switch on AC, car RPM needle was still to its position somewhere at 8500-900 RPM.
    Today i go for engine ans gear oil change the person asked me did you clean throttle on 40K. I said NO... he said its necessary. I told me i have never felt any issue so why i do throttle cleaning??? He said just clean car throttle and you will feel a good change. First i ignored but later i thought i should do DIY. I open the air filter assembly and throttle was having carbon on plate. I asked my cousin to sit inside car and switch it on (Dont start engine) and press the accelerator, he did the same and throttle opened. In this way i cleaned the throttle with microfiber cloth and NASA spray on cloth. To maximum possible extent, i cleaned it softly without pushing throttle plate (Round butterfly type). After that i re assemble the air assembly and go for drive. i see when car was at some speed (e.g 50km/h) and i pressed the clutch the RPM starts to raise and fall (1800 --- 1200, 1800---1200). I thought throttle sensor calibration is out so i went to work shop and asked him to calibrate throttle on scanner. He connected the scanner and made a call to someone for help. He did PCM reset, live data reset.... i dont what these are nd finished. I went for test drive but RPM still moves between 1100-1000 at moving car when clutch pressed and at still car RPM after 3 sec remains at 900-950 but as i switch on Head lights or AC, RPM moves upward till 1100 and then after 3 sec stable at 900.
    Before all this i never feel any RPM fluctuation due to AC on/off or Head lights ON/OFF.
    I know i did mistake by doing DIY when it was not required...anyways kindly tell what is the reason ??? is Throttle not properly calibrated or something else????
    Zulfiqar bhai help out in this issue


  2. #2
    PakWheeler Follow
    danish.ijaz.754's Avatar
    Join Date
    Feb 2013
    Location
    Lahore
    Age
    27
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    scholars died??? :/

  3. #3
    Senior PakWheeler Follow
    ahsanonline's Avatar
    Join Date
    Jan 2007
    Location
    Rawalpindi
    Age
    86
    Posts
    2,295
    Follows
    3
    Following
    3
    Mentioned
    19 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Idle speed hunting is common after a TB service.
    An ecu reset by taking battery terminals off usually does the trick.

    But it takes a few days for the ecu to recalibrate itself because it needs cold-hot-cold cycles to determine idle speed, which it does every time the car gets to operating temps from a cold start. If you didn't take off any electrical connectors/sensors or fiddle around with the throttle plate manually, then in my experience this is the most likely situation.

    Give it a couple days to relearn. I usually do a cold start and let the engine warm-up itself till the radiator fan comes on.
    Selling Vitz+local cars - compatible bluetooth Ecu Scantool, High-amp car chargers, Apple-certified Lightning Cables, etc. Click on my name and see my started threads for details.

  4. #4
    PakWheeler Follow
    danish.ijaz.754's Avatar
    Join Date
    Feb 2013
    Location
    Lahore
    Age
    27
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i drive car for almost 200km after TB service and now feels little better but when i switch ON AC and car stand still then RPM fluctuation occurs for 1-2 sec only then fine

  5. #5
    Senior PakWheeler Follow
    babarhyd's Avatar
    Join Date
    Jul 2005
    Location
    Hyderabad
    Age
    30
    Posts
    1,956
    Follows
    1
    Following
    1
    Mentioned
    94 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by danish.ijaz.754 View Post
    i drive car for almost 200km after TB service and now feels little better but when i switch ON AC and car stand still then RPM fluctuation occurs for 1-2 sec only then fine
    U didn't notice before cleaning because u were not paying attention than. It happens with all cars no biggy.

  6. #6
    PakWheeler Follow
    danish.ijaz.754's Avatar
    Join Date
    Feb 2013
    Location
    Lahore
    Age
    27
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hmm may be but perhaps it was not before. anyhow i did not feel any difference after cleaning throttle. Either its not properly cleaned (as i did not open it) or it was already clean.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •