Survey by Qualaroo
+ Reply to Thread
Results 1 to 3 of 3

Thread: Honda City 2002 Speedometer Problem

  1. #1
    PakWheeler Follow
    ameriaz's Avatar
    Join Date
    Aug 2014
    Location
    Lahore
    Age
    23
    Posts
    41
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Honda City 2002 Speedometer Problem

    Hello Everyone i need some info from you experienced people.
    I've got my first Car Honda City 2002 ALHAMDULLILAH and i need some help about its speedometer.The problem is speedometer is not working other than that RPM, TEMP and FUEL Works Fine but Speedometer isn't when i drive around at 20/30 there's some kind of bearing sound in meter and when car gains speed so the sound of bearing does.FUEL Meter works fine but when i switch off the car the fuel needle goes ups and down slowly.So i need to know if i should get the meter repaired or should i buy new one from BILAL GANJ or the problem is about meter wires.Please guide me.Thanks


  2. #2
    Senior PakWheeler Follow
    taz_rulez's Avatar
    Join Date
    Oct 2007
    Location
    Peshawar
    Posts
    2,411
    Follows
    0
    Following
    0
    Mentioned
    61 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Congratulations bro
    There is a speedometer wire coming from the cabin to the engine bay and hooked just below the left side of air filter. You need to locate it in the engine bay area. Once done take it out and check the condition. If its worn out change it else grease it up put it back in tightly. It so happens that the wire is loosely fit and gets detatched by itself. About the bearing sound from the meter same process but from the inside of car. Take off your meter behind it is a small rotating object with the same wire coming from the engine. Take it out inspect grease it up and put back properly. Hopefully the problem will be solved.
    Kenwood | JVC | Pioneer | Hertz | Alpine | JBL ... x)
    http://www.facebook.com/taz.photos

  3. #3
    Senior PakWheeler Follow
    fahadwizz's Avatar
    Join Date
    Feb 2011
    Location
    Karachi
    Age
    35
    Posts
    2,383
    Follows
    1
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    3

    Default

    First replace the cable... In most cases cable causes the particular noise you have mentioned.

    If the cable is disconnected you should see a CEL

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •