Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Advancer

  1. #1
    PakWheeler Follow
    mfaheem's Avatar
    Join Date
    Sep 2006
    Location
    Karachi
    Age
    42
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default Need advice for advancer installation

    I have City 2000 Exis. From few days I noticed car is running very heavy specially when AC is on. Sometimes car shutoff (AC on) I think its due to low GAS pressure or RMP.
    Today I visited CNG mechanic he tuned CNG setting and when I went on test drive with him noticed same issue occurs on slow speed (AC still on) and car starts knocking. Also noticed RMP go up around 2000 ~ 2500. But car run smoothly when AC is off and no RMP issue.

    Then mechanic recommended me to installed Advancer (currently not installed) also assured me that after installation of Advancer I will not face this problem.

    Need expert opinions from folks.


  2. #2
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,548
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Your car have distributor no need of advancer

  3. #3
    PakWheeler Follow
    mfaheem's Avatar
    Join Date
    Sep 2006
    Location
    Karachi
    Age
    42
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Any opinion

  4. #4
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,548
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Seem like your ac system is overcharged and putting extra load on engine

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •