Survey by Qualaroo
+ Reply to Thread
Results 1 to 8 of 8

Thread: Honda City 06 [Engine Light On]

  1. #1
    PakWheeler Follow
    Luke_mani's Avatar
    Join Date
    Feb 2004
    Location
    Islamabad
    Age
    35
    Posts
    528
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Honda City 06 [Engine Light On]

    I recently had a Landi Renzo CNG kit fitted in my city (manual) and tthe engine light has come on?

    What could be the reasons behind it? Should i take it to the cng fitter or honda dealership?
    Why drink and drive, when you can smoke and fflllyyyy...

  2. #2
    PakWheeler Follow
    raoaltaf's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    37
    Posts
    261
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    it happens to my car as well whenever i do install any electric thing. i am not expert but easy way is to unplug + termianl wire from battery and then plug it back. it should be off.
    -

  3. #3
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,380
    Follows
    18
    Following
    0
    Mentioned
    406 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    @Luke_mani
    go back to the cng guy.tell him to recheck wiring he did for emulator/advancer.then disconnect and reconnect battery lead to reset ecu
    Life is short and very unpredictable just like a Quarter mile .....

  4. #4
    PakWheeler Follow
    Luke_mani's Avatar
    Join Date
    Feb 2004
    Location
    Islamabad
    Age
    35
    Posts
    528
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanx for the help guys, really appreciate it.
    Why drink and drive, when you can smoke and fflllyyyy...

  5. #5
    PakWheeler Follow
    AKSS's Avatar
    Join Date
    Apr 2008
    Location
    Islamabad
    Age
    38
    Posts
    9
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I hav city 07 m/t and have been facing same problem since i got install cng. I had tried to solve ths problem by disconnecting baterry terminals and got service of throtle body but still facing same problem. While driving on petrol it does not turn on. However car running fine on cng except ths chk engine light.
    -

  6. #6
    PakWheeler Follow
    azeemchowhan's Avatar
    Join Date
    Apr 2005
    Location
    Rawalpindi
    Age
    37
    Posts
    86
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    AKSS..
    I had the same problem with my Civic, check the advancer..it will not be working properly...get it replaced and it will do the work...My rpoblem was solved after replacing the advancer..

  7. #7
    PakWheeler Follow
    AKSS's Avatar
    Join Date
    Apr 2008
    Location
    Islamabad
    Age
    38
    Posts
    9
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Azeemchowhan
    thanx 4 ur advice. my advancer has been checked by three macanics and all were saying it is ok. Anyhow i will get it chk again by somene else
    -

  8. #8
    PakWheeler Follow
    vik_vik's Avatar
    Join Date
    Jan 2007
    Location
    Islamabad
    Age
    33
    Posts
    919
    Follows
    2
    Following
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i had the same issue but I myself increased the race from the cng kit and now this problem has been resolved so giv it a try and i believe this problem will be gone.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •