Survey by Qualaroo
+ Reply to Thread
Results 1 to 14 of 14

Thread: CITY iSDI Caution light problem

  1. #1
    PakWheeler Follow
    priuslover's Avatar
    Join Date
    Nov 2008
    Location
    Lahore
    Age
    38
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default CITY iSDI Caution light problem

    Hi all
    Please help out...new manual honda city one month old with cng...gives engine malfunction caution (orange light on panel) during CNG operation. it Problem also on petrol. Car usually keeps running but sometimes a speed slow down occurs and engine shuts off. on restarting the engine, the light usually goes off but comes up again.

    CNG workshop first changed the advancer to correct the problem. but no change. Now he is asking to put two emulators!! Is it understandable??
    Got checked from honda as well and they say it happens with cng conversion at times.
    Now i want this resolved to drive trouble/worry free.
    Please guide.

  2. #2
    PakWheeler Follow
    ati41's Avatar
    Join Date
    Oct 2007
    Location
    Islamabad
    Age
    45
    Posts
    234
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The CNG kit on your car Honda City has not been properly installed and the Lambda Oxygen Sensor has not been correctly accounted for. F

    The CNG Kit on your car SHOULD have the following components EXACTLY as stated below:

    CNG Kit Landi Renzo TN1B + LC 01
    STAP 78 (Spark Timing Advance Processor)
    Emulator LR Bosh II (For Honda)

    It is important not to mix and match components (such as a Neotek Advancer and landi renzo reducer and all components should come from one manufacturer).

    Secondly as stated above as well, the importance of connecting the to all relevent sensors on the engine such as Throttle Position Sensor (TPS), Oxygen Sensor, Crank Sensor etc.

    LC01 is basically a small computer operated stepper motor that ensures that the correct amount of gas goes into the engine and it is required for your engine because your engine is of EURO 3 Specifications. LC01 does require a computer and a trained technician to calibrate the computer for your engine the time it is installed.

    Be careful of the locally made Kits stamped as Landi Renzo. They are dangerous and hurt your engine.

    I strongly suggest that you go to a REPUTABLE WELL KNOWN SHOP (NOT road side conversion Novices) to get your car checked professionally on the basis of the Points mentioned above.

    Hope this helps

  3. #3
    PakWheeler Follow
    AKSS's Avatar
    Join Date
    Apr 2008
    Location
    Islamabad
    Age
    38
    Posts
    9
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Same case is with my city. I heard most of honda cities has the same problem on CNG. I got it check by different mecanics but unable to find the main fault. Lets see if any expert helps in ths issue.
    -

  4. #4
    PakWheeler Follow
    priuslover's Avatar
    Join Date
    Nov 2008
    Location
    Lahore
    Age
    38
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hi there ..many thanks for your useful reply. In the meanwhile however, i had contacted the cng workshop and he had another expert of his install another 'emlator' in addition to the existing one (its sticker say 'for honda' ..dont know the exact brand).

    what they say is that this the additional emulator is an oxygen emulator (neotek) ...charged 2500k for this + 300 for labor...

    the engine check light is gone for now...lets hope it works well and engine remain ok.

    regards

  5. #5
    PakWheeler Follow
    ati41's Avatar
    Join Date
    Oct 2007
    Location
    Islamabad
    Age
    45
    Posts
    234
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You should read my reply again carefully. You should also ensure that the check light is NOT gone due to them cutting a wire. Remember ur engine is dependent on a variety of sensors such as Crank case sensor, Throttle Position Sensor and a host of other sensors, not to mention the fact that all these and others are connected to an ECU ( electronic control Unit).

    There is ABSOLUTELY NO NEED what so ever for TWO EMULATORS on ONE ENGINE and it does ABSOLUTELY no good. I am surprised at what exactlly they have actually done.. Connect them in parallel??

    I think people are ripping u off caz you have not done ur homework properly.

    I once again suggest to you to go to a REPUTABLE WELL KNOWN SHOP so that you do not unintentionally damage your Brand New car.

    Read my abov reply again.. and on those basis speak to the technicians at that repuatable shop.

    For now i suggest u to leave out LC01 part of the KIt that i suggested to u above in my replyas u lack the required skills. You shouod ensure however that all the parts THAT I STATED above are installed in ur car CORRECTLY. You DO NOT need any additional parts REGARDLESS of what anyone may suggest to you.


    hope this helps.

  6. #6
    PakWheeler Follow
    priuslover's Avatar
    Join Date
    Nov 2008
    Location
    Lahore
    Age
    38
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hi thanks ati41 once again for feedback and concern.

    Well unfortunately had this done already and so far no problem.

    To share info abt car cng
    --landi renzo TN
    --STAP 78 Landi Renzo
    --emulator injector autotek AT-E12
    --The one the workshop fitted now is neotek. Its sticker reads, model O2E6, type s/w, 'oxygen sensor emulator'. Now may be you could assess + advise better as to what they missed and did. (perhaps they should have used proper emulator first time taking proper care of oxygen sensor)


    I myself doubted that they could cut the wire simply and then declare it is fine. therefore was quite vigilant during installation. While there was some 'hit and trial' the simple cut off does not seem to be the case. A technical bi-pass of the sensor..cant say.
    And i also note that engine check light turns in regular fashion as with normal cars. so apparently it is ok.

    What could be the check by the way??
    Any exhaust emission check from enercon?? or something similiar.

    thanks
    regards

  7. #7
    PakWheeler Follow
    rashid68's Avatar
    Join Date
    Mar 2007
    Location
    Rawalpindi
    Age
    42
    Posts
    50
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I am having similar problem in my city idsi 2008.

    Please check the link:
    https://www.pakwheels.com/forums/cng...city-2008-idsi

    Any useful guidance would be appreciated.

  8. #8
    PakWheeler Follow
    kazmi_muzammil's Avatar
    Join Date
    Oct 2010
    Location
    Hyde Park
    Posts
    813
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bro i have had this issue in my friends' iDSi.. there is no issue in CNG kit

    Get your car throttle body serviced, and drive it at least one kilometer on petrol then daily and then convert to cng. the light will go away. you may contact me at: 03314002910 because i have worked out on this problem myself. I reside in Lahore i can refer you to a reliable person who serviced my friends' car throttle body at a price lower than Honda (honda would say replace the throttle body) and then the light went off... He was facing the issue for like 9 months and then we came upto this great conclusion.

  9. #9
    PakWheeler Follow
    rashid68's Avatar
    Join Date
    Mar 2007
    Location
    Rawalpindi
    Age
    42
    Posts
    50
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks Muzammal for help.
    I have updated my problem:

    https://www.pakwheels.com/forums/cng...city-2008-idsi

  10. #10
    PakWheeler Follow
    sajjadmemon82's Avatar
    Join Date
    Jun 2009
    Location
    Hyderabad
    Age
    34
    Posts
    206
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have got somewhat the same problem, the engine light comes out of nowhere and then i restart the engine and it goes away. this does not happen everyday but rarely, but when it happens then the engine light keeps on coming up. I have been ignoring it but I am worried that this might grow as a bigger problem, any insight on this will be appreciated.

    Many Thanks

  11. #11
    PakWheeler Follow
    rashid68's Avatar
    Join Date
    Mar 2007
    Location
    Rawalpindi
    Age
    42
    Posts
    50
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The best thing would be to get it checked from Honda Center with Computer.
    2ndly if it is not causing any problem during normal run than can be because of faulty adjustments, but only the Honda center can finally tell.

  12. #12
    Senior PakWheeler Follow
    car_bus2008's Avatar
    Join Date
    Jan 2008
    Location
    Karachi
    Posts
    1,770
    Follows
    2
    Following
    1
    Mentioned
    23 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    my civic is also doing this problem but sometimes it restarts automatically after it shuts down and sometime cel come ON speed become slow like engine has shut off and after again giving igntion and then again starts for 100km and then again give CEl.
    Money differs from an automobile or mistress in being equally important to those who have it and those who do not.

  13. #13
    Senior PakWheeler Follow
    talhawaleed's Avatar
    Join Date
    May 2009
    Location
    Islamabad
    Posts
    1,812
    Follows
    1
    Following
    0
    Mentioned
    115 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    If the problem is even occurring on Petrol :

    Oxygen sensor light. Guys this sensors needs to be replaced after every 100,000 km or 120,000 km but unfortunately in Pakistan we take these things for granted. This is a signal to ECU that oxygen currently being mixed with fuel is not of right quantity or readings which is being sent to ECU is faulty. Replace this sensor and then you will also experience a better fuel economy.

    I know that this sensor from Honda would cost you Rupees 21000 and wiring harness is made such that if you will install any other then you will face a problem configuring the wirings to match correctly to that of the female part. Good advice is that tell your local mechanic to take this sensor out then find alternate sensor for good price and configure the wiring harness to work with original wiring harness.

    If its Honda city IDSI then I can help you out as I have done this in past.

  14. #14
    Senior PakWheeler Follow
    car_bus2008's Avatar
    Join Date
    Jan 2008
    Location
    Karachi
    Posts
    1,770
    Follows
    2
    Following
    1
    Mentioned
    23 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    yes the problem is also on petrol this happens rarely a mechanic was telling me that it is the ignition switch of my car but where the oxygen sensor is located on civic 97 and i also checked for o2 sensors on my car but there is no oxygen sensor on civic 97
    Money differs from an automobile or mistress in being equally important to those who have it and those who do not.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •