Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 35 of 35
Like Tree1Likes

Thread: City idsi-braking problem.

  1. #1
    Senior PakWheeler Follow
    ahmadbila's Avatar
    Join Date
    Aug 2005
    Location
    Dubai
    Age
    26
    Posts
    12,963
    Follows
    5
    Following
    1
    Mentioned
    95 Post(s)
    Tagged
    11 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default City idsi-braking problem.

    hi all guy i hav a problem wid my city idsi 06.a couple of week ago,i was travelling at about 120km/h nd i had to brake suddenly.the car tends to turn left.i mean u press the brakes hard enough nd the car wud want to shift towards left side.i asked my mechanic,he said k brake pads r finished.which acutally were.i got the brake pads changed,got my car alligned(but not balanced) but still,the problem presists.the tyres r almost 20k kms done 195/60r14. can anyone explain wats the problem nd wat shud b done to cure this problem? Thanx
    When the power of love exceeds the love for power, the world will finally know peace=Every man is guilty of all the good he didn't do

  2. #21
    PakWheeler Follow
    FM01's Avatar
    Join Date
    Feb 2008
    Location
    YYZ, Karachi, Pakistan
    Age
    36
    Posts
    369
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    If your car is still pulling to the left, then swap the left wheel with the right side wheel and see If the car pulls to the right side. If it pulls to the right then it confirms that the tire is the culprit.

  3. #22
    PakWheeler Follow
    Ocean's Avatar
    Join Date
    May 2008
    Location
    Islamabad
    Posts
    861
    Follows
    0
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    breaks are not balanced. Just go to Good 3S and adjust your breaks. May be one side is jamming. other point bleed the oil. Do check rear breaks too sumtime they also add a little problem while ppl asuming only front one.
    May Allah give us strength to extend happiness around us

  4. #23
    Senior PakWheeler Follow
    RedBull_ar's Avatar
    Join Date
    Jun 2005
    Location
    Tank
    Age
    30
    Posts
    6,722
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    my car also goes to left under heavy braking

    balanced, aligned, brakes changed with original costing 3400rs, rotors werent damaged, brake oil replaced/bleeded, tyres swaped front/back

    same thing before and after all of the above.
    Alpha Romeo 156

  5. #24
    Senior PakWheeler Follow
    RedBull_ar's Avatar
    Join Date
    Jun 2005
    Location
    Tank
    Age
    30
    Posts
    6,722
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    any luck dude? my left front is locking badly these days, i think front right caliper is jamned. any one know how to adjust brake balance/bais in house?
    Alpha Romeo 156

  6. #25
    PakWheeler Follow
    harisw's Avatar
    Join Date
    Mar 2009
    Location
    Karachi
    Age
    86
    Posts
    104
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yar the same thing happen 2 me also ....yesterday i was luckly escaped from da major accident .. i applied da break but the car spins on da road.. THnx 2 ALLAH i m alright...

  7. #26
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get the piston of left side calliper assembly serviced,it seems that, it has gone sticky and not move freely when u applied brake.
    Never loose hope in life,every step gives u something.

  8. #27
    PakWheeler Follow
    CamryHybrid's Avatar
    Join Date
    Apr 2009
    Location
    Paradise Point
    Age
    46
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Is ur car suddenly do that after applying brakes? if yes.


    drive ur car again at 50, 60km and apply brakes many times (in a test area), by doing this 2-3 times, stop the car, and check ur rims one by one by applying ur hands on each rims, If any of the rim gets over heated as compared to other rims, the problem will be with that rim's brake pads,disc or brake adjustment etc.


    This is an expert suggestion, if in doubt ask ur mechanic this whole story.........
    Always thank Allah what you have!!!

  9. #28
    Senior PakWheeler Follow
    RedBull_ar's Avatar
    Join Date
    Jun 2005
    Location
    Tank
    Age
    30
    Posts
    6,722
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    its also happening if i apply the brakes gently, i think my right side caliper is dead.
    googled alot, and got different opinions such as
    bad pad
    bad rotor
    bad jamed caliper
    air in oil lines
    bad bushings of control arms
    bad ball bearing nut
    bad tyre pressure

    thnx will try
    Alpha Romeo 156

  10. #29
    PakWheeler Follow
    CamryHybrid's Avatar
    Join Date
    Apr 2009
    Location
    Paradise Point
    Age
    46
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by RedBull_ar

    its also happening if i apply the brakes gently, i think my right side caliper is dead. googled alot, and got different opinions such as bad pad bad rotor bad jamed caliper air in oil lines bad bushings of control arms bad ball bearing nut bad tyre pressure thnx will try

    tyre air pressure is a big issue, if air pressure is different in all the 4 wheels, ur ride will show abnormal behaviour, but plz dont mess ur car with "desi or climatic" mechanics.
    Always thank Allah what you have!!!

  11. #30
    Senior PakWheeler Follow
    RedBull_ar's Avatar
    Join Date
    Jun 2005
    Location
    Tank
    Age
    30
    Posts
    6,722
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    any update?
    Alpha Romeo 156

  12. #31
    Senior PakWheeler Follow
    afnan_88's Avatar
    Join Date
    Jun 2005
    Location
    Dubai
    Age
    28
    Posts
    2,405
    Follows
    0
    Following
    1
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    to all , yaar aap loo gkyo is bundey ko khali bili ultey sedhaey siggestions de rehay ho , yeh wala masla sirf is k sath nhe hia yeh tu city k original brakes hi esay hey , 120 kya aap above 60 per sudden brake maro tu bhi gari skid karey gi chaya brand new tyres n pads ho . . . me khud apni city ki braking ki wajah sey pareshan ho but iska koi hul nhe hai
    I Love JDM Cars . . .

  13. #32
    PakWheeler Follow
    blue_transam's Avatar
    Join Date
    Mar 2005
    Location
    montreal
    Age
    42
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    when the car pulls while you are breaking that means you have jame caliper and check the condition of the brake disc.

  14. #33
    PakWheeler Follow
    CamryHybrid's Avatar
    Join Date
    Apr 2009
    Location
    Paradise Point
    Age
    46
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan_88



    to all , yaar aap loo gkyo is bundey ko khali bili ultey sedhaey siggestions de rehay ho , yeh wala masla sirf is k sath nhe hia yeh tu city k original brakes hi esay hey , 120 kya aap above 60 per sudden brake maro tu bhi gari skid karey gi chaya brand new tyres n pads ho . . . me khud apni city ki braking ki wajah sey pareshan ho but iska koi hul nhe hai



    City mai koi braking problem nahin hai, bila waja shor machaya jarha hai, agar gari skid horahi hai to iss ki 2 possibilities hosakti hain.


    1- Ap ki gari ka frame terha hai, Ye masla accidental cars mai ziada hota hai,


    2- Kisi 1tyre per brake system sahi kaam nahi kr raha.
    Always thank Allah what you have!!!

  15. #34
    Senior PakWheeler Follow
    afnan_88's Avatar
    Join Date
    Jun 2005
    Location
    Dubai
    Age
    28
    Posts
    2,405
    Follows
    0
    Following
    1
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @camry hybrid , yaar aap kisi bhi city dsi user sey poch lo , city ka main problem hai iski braking . . .
    I Love JDM Cars . . .

  16. #35
    Senior PakWheeler Follow
    RedBull_ar's Avatar
    Join Date
    Jun 2005
    Location
    Tank
    Age
    30
    Posts
    6,722
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    got the rotors re surfaced, car drifting to left while braking is reduced upto 90%, remaining 10% i beleive can be due to bad pads or allignment.
    Alpha Romeo 156

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •