Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Thread: check engine light civic 2002

  1. #1
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default check engine light civic 2002

    Salam...i was driving normally as i do...i just stretched my car a little to around 4000rpm...then my car hit a stone...a slightly big stone and the car jumped a little...after 2 seconds my car gav the check engine light on...and the car lost all power although didnt turn off.....then i came to the end of the road and i stopped the car to turn...then the car turned off....i switched off the switch completely and then turned the car back on..it was back on with no check engine light....like the check engine light went off...i took the car straight to the mechanic and he checked thec ar and said everything is ok....we stretched the car again to 4000 rom evrything was ok..the mechanic said that it may be becz of the wired touched each other because of the jump with the stone....wat do u guys say....the car is running fine now!! Masha Allah say!!

    -

  2. #2
    PakWheeler Follow
    atherrr's Avatar
    Join Date
    Jun 2009
    Location
    Toronto
    Age
    24
    Posts
    446
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The mechanic is right... ;=)....may be because of the big jhatka the car turned off...
    Religion and Science are not at odds, Science is just too young to understand.

  3. #3
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    and like as far as i hav heard the check engine light comes on and the car keeps on running like normal and it does not turn off...or if the check engine light comes on it never goes away until u fix the issue...my case is a unique one...the light came on the car got off...i started it again and everything back to normal!!!
    -

  4. #4
    PakWheeler Follow
    atherrr's Avatar
    Join Date
    Jun 2009
    Location
    Toronto
    Age
    24
    Posts
    446
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yaar ye chotay chotay maslay hotain hi hain.....just relax and be happy..aapki car dobara start ho gae... :p
    Religion and Science are not at odds, Science is just too young to understand.

  5. #5
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    now my car did this once again and turned off....now it is strating but again going off...and i cant move the car one meter....wat could be the problem!!
    -

  6. #6
    Senior PakWheeler Follow
    bango's Avatar
    Join Date
    Jun 2009
    Location
    Select City
    Posts
    8,055
    Follows
    1
    Following
    0
    Mentioned
    57 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Take the Battery terminals off for one minute, and put them on again. Make sure you tighten them

    Also make sure your battery is fitted correctly, and doesn't ''bounce'' making the terminals hit the bonnet on every ''jhatka''.

    One more thing - at times the stick which holds the bonnet up when it is opened, doesn't fit in its clip, and at jumps it tends to hit one of the terminals. Check that too.
    A Post-Wh0re is a user who's only aim in life is to increase his post count. He/she gets off by receiving likes and mentions, and considers his post count a medal on his skinny chest. A post-Wh0re is the human equivalent of Chihuahua..bickering pointlessly, effortlessly, permanently.

  7. #7
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,367
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    u can try what bango said or
    ur car needs to be diagnosed for what error code its generating. once diagnosed it can be fixed. so tow ur car to a place which deals with efi cars and such problems
    Life is short and very unpredictable just like a Quarter mile .....

  8. #8
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,952
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    some of ur sensors loosed its place on the jump. of one of the coils lost current that caused it. if its off then theres no issue.
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  9. #9
    PakWheeler Follow
    Civic_Crazed's Avatar
    Join Date
    Mar 2010
    Location
    Karachi
    Age
    36
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Agreed with chinyoti. It is very much possible that one or more sensors are having issues after that bump. Get it checked from some good efi mechanic. (Try to aviod roadside ones as they will only aggravate your problem).

  10. #10
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    well i called my trusted mechanic and asked him to check the car...nothing could be found and the car acted just fine as it normally does..no missing nothin...he said it is possible that the fuel pump is weak...but he wasn't sure....he said he cant be absolutely sure unitl the fuel pump dies off...let me remind u guy that the engine check light is off all the time...it justs comes on and the engine goes off and then when i switch the key to off and start again the engine check light goes off when teh car starts...the light is permanently on...and i wanted to ask where is shamim motors located becz i read in another thread about them havin an obd scanner...and plzz also tell me how much will they chrage for having an obd scan becz that scan will tell me abt the condition of the fuel pump...m i right??
    -

  11. #11
    Senior PakWheeler Follow
    bango's Avatar
    Join Date
    Jun 2009
    Location
    Select City
    Posts
    8,055
    Follows
    1
    Following
    0
    Mentioned
    57 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    1- No, it will just tell you if any of the sensors is malfunctioning. They shouldn't charge you more than 400 for the diagnostics.
    2- Did this ever happen when the car was cold? Or does it always happen when it has reached the optimum temperature (temp guage in the middle)?

    Any other symptoms?
    A Post-Wh0re is a user who's only aim in life is to increase his post count. He/she gets off by receiving likes and mentions, and considers his post count a medal on his skinny chest. A post-Wh0re is the human equivalent of Chihuahua..bickering pointlessly, effortlessly, permanently.

  12. #12
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    this happens when the temp guage is in the middle any idea on wat the prob could be....
    -

  13. #13
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,952
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    if the cars getting hot and u missed the hot/cold needle somehow, the A/c trips.

    diagnostic charges are around 300-600 depending wat the shop charges.

    btw are u saying that the check light is coming on when the car gets over heated?

    the check light only comes on if some sensor is maulfunctioning or theres some kinda short circuit.

    it has nothing to do with the fuel pump or the car getting hot.

    and ya the fuel pump presure can be checked at all times if its weak or not. its not like that , k u can not determine anything unless it dies or its working.
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  14. #14
    Senior PakWheeler Follow
    bango's Avatar
    Join Date
    Jun 2009
    Location
    Select City
    Posts
    8,055
    Follows
    1
    Following
    0
    Mentioned
    57 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Well if you have checked the minor details I've metnioned above, then:

    I'm pretty sure you have a faulty timing sensor. It stops working when heated. You would face this problem more in summers with AC on. Its no big deal...costs around 1500 rupees from bilal ganj.

    The worst part is that it won't be detected on the OBD scanner as well, because it works fine until the moment it gets heated, and stops working. And it cools down instantly as well...
    A Post-Wh0re is a user who's only aim in life is to increase his post count. He/she gets off by receiving likes and mentions, and considers his post count a medal on his skinny chest. A post-Wh0re is the human equivalent of Chihuahua..bickering pointlessly, effortlessly, permanently.

  15. #15
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    the ac wasnt on when the car died off both of the times but yes i had returned after a long journey both of the times....timing sensor laga kahaan hota hay.....can a good skilled mechanic get it rectified.....and how can u determine if the timing sensor is the prob if it cant be detected on the obd sensor....and how can the fuel pressure be checked???
    and will the car face the issue if the fuel is not coming with the proper pressure??
    -

  16. #16
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    and the timing sensor u said it cools down instantly as well....so it can be the possible reason becz like if u wait 5 seconds the car starts again.....
    -

  17. #17
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    one more thing.....if the fuel pump is bad...the car would not start properly and not run well like it wont run smooth even when the engine is cold.....and even when the car dies off after showing the engine check light it still is sunning smooth till the last moment until and unless it shows the light!!
    -

  18. #18
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    also suggest me which mechanic should i go to??
    -

  19. #19
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,952
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    ^ im not sure abt the timing sensor, but the fuel pump is checked some how, (im not sure how) and if the fuel pump is bad it wud be acting baad all the times not that some times its going tobe a gud fuel pump and then disturb u again
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  20. #20
    PakWheeler Follow
    manaskajn126's Avatar
    Join Date
    Jan 2007
    Location
    Abu Dhabi
    Age
    28
    Posts
    260
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    sahi sahi...thanks chinyoti bhai...by the way do u know a good mechanic that i can go to!!
    -

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •