Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 33

Thread: why hand brake of civic 05 doesent work

  1. #1
    Senior PakWheeler Follow
    Shahrukhali's Avatar
    Join Date
    May 2009
    Location
    Karachi
    Age
    18
    Posts
    2,411
    Follows
    1
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default why hand brake of civic 05 doesent work

    Signature not available

  2. #2
    Senior PakWheeler Follow
    mubeenshahid's Avatar
    Join Date
    Mar 2010
    Location
    Sargodha
    Age
    25
    Posts
    8,355
    Follows
    1
    Following
    0
    Mentioned
    31 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    can u further explain the problems.as i have kept the 2004 model oriel handbrake was fine
    Aunda Fan

  3. #3
    PakWheeler Follow
    ali5128438's Avatar
    Join Date
    Apr 2009
    Location
    Islamabad
    Age
    24
    Posts
    428
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    4 civics and handbrake doesnt works of all!

  4. #4
    Senior PakWheeler Follow
    airomerix's Avatar
    Join Date
    Aug 2009
    Location
    Lahore
    Age
    26
    Posts
    4,373
    Follows
    1
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get them fixed. Simple isnt it
    R18 boyz!.....Powered by Honda

  5. #5
    Senior PakWheeler Follow
    karakoram's Avatar
    Join Date
    Feb 2009
    Location
    Peshawar
    Age
    28
    Posts
    3,535
    Follows
    12
    Following
    0
    Mentioned
    106 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    my 2005 exi have also the same problem. i got it from honda north os time 4500 ki mili thi orignal cable
    I Was Born Brilliant; Education Ruined Me

  6. #6
    959
    959 is offline
    Senior PakWheeler Follow
    959's Avatar
    Join Date
    Jan 2007
    Location
    Karachi
    Age
    32
    Posts
    3,121
    Follows
    1
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Shahrukhali View Post
    i got 4 civics .... the hand brake doesent work of all ..???
    Sir I have had 13 Civics, everything works in all of them.

    Just simply check the brake wire.
    Readers are Leaders.

  7. #7
    Site Banned Follow
    Zeejigs's Avatar
    Join Date
    Aug 2006
    Location
    Rawalpindi
    Age
    30
    Posts
    3,121
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check the rear brakes and wire!

  8. #8
    PakWheeler Follow
    shoaib22's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Posts
    575
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I'm guessing you didn't use the handbrake regularly in any of those ?

  9. #9
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,960
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    tooti huwi taar

  10. #10
    Site Banned Follow
    BackToCivicFaiez's Avatar
    Join Date
    Jun 2010
    Location
    Lahore
    Posts
    6,164
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    wat he probably is trying to say is that the tires dont lock while the car is moving when handbrake is pulled...
    get the wire tightened....

  11. #11
    PakWheeler Follow
    tariqazama's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Age
    36
    Posts
    158
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    i had the same prob, solution is to use genuine cable from honda,its expensive but the only solution

  12. #12
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,960
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by 959 View Post
    Sir I have had 13 Civics, everything works in all of them.

    Just simply check the brake wire.
    wah barey ameer ho 13 civis kya mazaak kar rahey ho

  13. #13
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    you do know that the parking brake shoes are different than your the regular brake shoes in a Honda civic - I know they are made of poop but they are somewhat effective. the biggest reason for failure is brake dust and corrosion, next time when you get brakes serviced buy some Poly Butyl Cuprisil grease (copper slip grease) and use that on the autoadjuster and parking brake mechanism levers. And have the cable tightened slightly only
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  14. #14
    Senior PakWheeler Follow
    SpoonMotorSports's Avatar
    Join Date
    May 2010
    Location
    Peshawar
    Posts
    1,493
    Follows
    1
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    if its ABS then sorry u cant drift ur car!!

  15. #15
    fso
    fso is offline
    Senior PakWheeler Follow
    fso's Avatar
    Join Date
    Jul 2007
    Location
    Faisalabad
    Age
    32
    Posts
    1,400
    Follows
    1
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have 2005 vti and 2004 exi and 2006 exi and funny thing guess same prb in all of them i mean i cant even remember when they worked its common prb in these model somthing is wrong with cable the machinic says that the cable is broken and a new one will cos abround 4500 ...
    r3act

  16. #16
    PakWheeler Follow
    mohsinhp's Avatar
    Join Date
    Mar 2010
    Location
    Karachi
    Age
    36
    Posts
    493
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Same here in my Civic 04 exi (eagle eye)
    http://www.youtube.com/mohsinhp

  17. #17
    Site Banned Follow
    vyrus's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    25
    Posts
    1,611
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Same here. Handbrake never works.

  18. #18
    Senior PakWheeler Follow
    takko's Avatar
    Join Date
    Dec 2005
    Posts
    5,047
    Follows
    0
    Following
    0
    Mentioned
    17 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    civic vti has the issue, even m facin that alot, i was told by someone that its a fault only in vti that even honda couldn't fix, [03-06] vti
    people who use Highbeams.. once day would suffer too bigtime. People who drive slow on fast lanes, remember one day a vehicle carryin ur son, dad might get late to hospital coz people like u. underaged driving will land u in bigtime trouble one day or the other.. And the Blue indication light on ur speedometer denotes "High Beams"

  19. #19
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    I sometimes get custom made cables, work like a charm, in some cases better than original
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  20. #20
    Senior PakWheeler Follow
    tayyabbaig's Avatar
    Join Date
    Nov 2008
    Location
    Oslo
    Age
    34
    Posts
    2,706
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Had this problem in my civic but i tried to fix it last year. New cables, cost me 3800 + labour not remember. But not satisfied, so i give up and m happy the way it is.

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •