Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Thread: Honda Civic 'Check Engine Light' Problem

  1. #1
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Honda Civic 'Check Engine Light' Problem

    There's engine check light in my honda civic 05(prosmatic). Sometimes it lights up, sometimes it doesn't. When its lighted up, the car changes the gear at 4rpm and if the light is off it shifts the gear at 2.5 or 3rpm max. What could be the problem? I got is checked by the mechanic, he said that "Sensor is faulty". If the sensor is faulty then why the light shuts off and car is back to normal? Help me guys, Its really bothering me.
    I'm talking about this:
    Honda Civic 'Check Engine Light' Problem - dsc01256kh


  2. #2
    PakWheeler Follow
    psyke's Avatar
    Join Date
    Aug 2011
    Location
    Lahore
    Posts
    57
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    get it diagnosed properly and replace the faulty sensor
    And don't continue to drive like this it may lead to some big problem
    I am old-fashioned that is why I listen first.

  3. #3
    Senior PakWheeler Follow
    fahadwizz's Avatar
    Join Date
    Feb 2011
    Location
    Karachi
    Age
    35
    Posts
    2,383
    Follows
    1
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    3

    Default

    Which sensor is bad ? It can only be found out by running a proper diagnoses. It can be anything, when the check engine comes on, ECU goes into back up/limp mode and car drives like crap. Retrieve the code first then proceed on replacing any parts/sensors.

  4. #4
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by fahadwizz View Post
    Which sensor is bad ? It can only be found out by running a proper diagnoses. It can be anything, when the check engine comes on, ECU goes into back up/limp mode and car drives like crap. Retrieve the code first then proceed on replacing any parts/sensors.
    I don't have any idea whats ECU and limp up. and yeah you're right, the car runs like crap, it feels like a truck. The mechanic scanned the car with a touch screen machine after that he asked me to replace the sensor. Should i?

  5. #5
    Senior PakWheeler Follow
    fahadwizz's Avatar
    Join Date
    Feb 2011
    Location
    Karachi
    Age
    35
    Posts
    2,383
    Follows
    1
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by HassanS View Post
    I don't have any idea whats ECU and limp up. and yeah you're right, the car runs like crap, it feels like a truck. The mechanic scanned the car with a touch screen machine after that he asked me to replace the sensor. Should i?
    Ok, so you have already scanned. Which sensor is bad?

  6. #6
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by fahadwizz View Post
    Ok, so you have already scanned. Which sensor is bad?
    I don't know the name of the sensor but i think this region was faulty. He opened this and then told me about the sensor
    Honda Civic 'Check Engine Light' Problem - civic05enginelarge

  7. #7
    PakWheeler Follow
    khan1995's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Age
    21
    Posts
    46
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    its the throttle body sensor and because of this faulty sensor you are having the gear shifting problem same happend to me on my prosmatic now after changing its running fine

  8. #8
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khan1995 View Post
    its the throttle body sensor and because of this faulty sensor you are having the gear shifting problem same happend to me on my prosmatic now after changing its running fine
    For how much did you got that sensor? New or used?

  9. #9
    PakWheeler Follow
    khan1995's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Age
    21
    Posts
    46
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i got it from the kabuli engines for 300 LOL and fixed it myself LOL

  10. #10
    PakWheeler Follow
    khan1995's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Age
    21
    Posts
    46
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    maximum would be 500 rs not more than that

  11. #11
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khan1995 View Post
    i got it from the kabuli engines for 300 LOL and fixed it myself LOL
    Pretty sweet! Did you followed a tutorial or what? If yes then can you please link me to it? I want to do it by myself.

  12. #12
    PakWheeler Follow
    khan1995's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Age
    21
    Posts
    46
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i knew where it was because i love doing things with my ride firstly you have to remove the air filter box and is located on the side of the throttle blade shaft you can replace the sensor by simply unscrewing the old one, and replacing it with a new one, making sure that it is inserted exactly like the old one was.and for the sensor get the sensor for auto tranny engine


  13. #13
    PakWheeler Follow
    khan1995's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Age
    21
    Posts
    46
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    one thing don't drive your car with this problem it can damage your gear box

  14. #14
    Senior PakWheeler Follow
    Marschall's Avatar
    Join Date
    Aug 2009
    Location
    Chowha saidan shah
    Age
    31
    Posts
    1,145
    Follows
    0
    Following
    0
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I had the same problem got throttle body cleaned and rechecked the sensors i.e tightened them up the problem was over
    "Stand by your glasses steady and drink to your comrade's eyes.
    Here's a toast to the dead already and hurrah for the next to die."

  15. #15
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khan1995 View Post
    i knew where it was because i love doing things with my ride firstly you have to remove the air filter box and is located on the side of the throttle blade shaft you can replace the sensor by simply unscrewing the old one, and replacing it with a new one, making sure that it is inserted exactly like the old one was.and for the sensor get the sensor for auto tranny engine
    Do i need a special toolkit for it? or the normal screwdrivers would do? btw Which model do you own?

  16. #16
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Marschall View Post
    I had the same problem got throttle body cleaned and rechecked the sensors i.e tightened them up the problem was over
    When the mechanic messed up with the Throttle, it was working fine. I 'll try cleaning it, Thanks!

  17. #17
    PakWheeler Follow
    khan1995's Avatar
    Join Date
    Jan 2011
    Location
    Islamabad
    Age
    21
    Posts
    46
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i own a 2002 oriel no special toolkit is required just screwdrivers and voila ur done

  18. #18
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khan1995 View Post
    i own a 2002 oriel no special toolkit is required just screwdrivers and voila ur done
    Aye. Whats Voila :|

  19. #19
    PakWheeler Follow
    mfarhansabir's Avatar
    Join Date
    Sep 2012
    Location
    Lahore
    Posts
    840
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by HassanS View Post
    Aye. Whats Voila :|
    Voila is equivalent of Eureka...

    Sent from my Nexus S using Tapatalk 2

  20. #20
    PakWheeler Follow
    HassanS's Avatar
    Join Date
    May 2012
    Location
    Peshawar
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    haha, I thought of a tool or something, nvm!

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •