Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 36 of 36
Like Tree3Likes

Thread: 7th gen Civic: Missing and Stalling

  1. #1
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy 7th gen Civic: Missing and Stalling

    Hello

    Car: 7th Generation PKDM CIVIC

    Issues:
    All this happens when car obtains its optimum temperature.

    1: Missing at idle, like it
    breathing RMP varies between 300-800.
    2:
    Stalls while taking a turn in 1st gear.
    3: Giving fuel average
    7km/l.

    Procedures done:
    1:
    TP sensor changed.
    2:
    IAC valve changed.
    3:
    crank sensor checked.
    4:
    Throttle Serviced.
    5:
    Injector assembly replaced.
    6:
    Tappet adjusted.
    7:
    Spark plug replaced.
    8:
    Ignition Coils replaced.

    It was done on 9th jan, car was good again. But all of the symptoms are back
    today, same missing and stuff.
    Now mechanic are insisting that the
    Valves are burned down and are leaking pressure.
    My daily drive is of 100+km, really tired of this.

    Looking forward to some Idea bulbs.

    Thanks.

  2. #21
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by rizkhan2010 View Post
    @op... how can u even bear the forever ON check engine light ??
    It takes practice
    But seriously the only option I have is to find a manual transmission wiring, believe me finding one is a lot more difficult than it seems.

    Sent from my HTC One using PW Forums mobile app

  3. #22
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Soban00 View Post
    and the world is full of "Ustaad jee".
    well, I do have a good mechanic with first hand overhauling experience of honda engine, He also worked in Toyota multan for 6+ years.
    estimated expense is of 30K and I will get a kabli engine in less than that.
    30k? Are u kidding me???? LOL LOL. New valve seals will cost you dead maximum 8k including head gasket and labor.

    Change your mechanic haha.


    Sent from my iPhone
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  4. #23
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I got it done on my exi a year back, but the problem was different. The timing belt tensioner slipped and the pistons hit the open valves from underneath thereby bending them.

    It cost me 14k including new valves, and I got it done from a mechanic in my hometown mianwali. Just that he is a genuine person, my neighbor and not a rip off.

    Car has 180k kms and is going flawless. Been 45000 kms since the new valves.


    Sent from my iPhone
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  5. #24
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Guys PKDM cars do not have secondary O2 sensor they have primary O2 Or AFR sensor. It is necessary to adjust your short term and Long term fuel trims. Well if you have not genuine harness then it may not get connected to scanner via your odb2 port. So you would be diagnosing problems by hit and trial

    What engine you have got in there ? D series? if yes wiring is easily available here complete uncut wiring would cost you approximately 5-8k. I have seen many here.

    Is your car manual or Automatic?

    Seems like this car has been done by another Nito Tape Ustaad. I have one accord and i sorted it out each bit of it.

    If you are getting CEL in regards to generic P700 transmission code then again your car would run like crap and wont rev beyond 4800-5k RPM. I think you are using Auto ECU. In this case your VTEC would not even kick in.
    93 Accord CB7 (Sold) / 2005 CL7

  6. #25
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by RollOnBigMaMa View Post
    30k? Are u kidding me???? LOL LOL. New valve seals will cost you dead maximum 8k including head gasket and labor.

    Change your mechanic haha.


    Sent from my iPhone

    That was the price of new valves, seals and something he said 'sleebs' will check all this from somewhere else

    Sent from my HTC One using PW Forums mobile app

  7. #26
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by RollOnBigMaMa View Post
    I got it done on my exi a year back, but the problem was different. The timing belt tensioner slipped and the pistons hit the open valves from underneath thereby bending them.

    It cost me 14k including new valves, and I got it done from a mechanic in my hometown mianwali. Just that he is a genuine person, my neighbor and not a rip off.

    Car has 180k kms and is going flawless. Been 45000 kms since the new valves.


    Sent from my iPhone
    Thanks for giving me an estimate of cost

    Sent from my HTC One using PW Forums mobile app

  8. #27
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    Guys PKDM cars do not have secondary O2 sensor they have primary O2 Or AFR sensor. It is necessary to adjust your short term and Long term fuel trims. Well if you have not genuine harness then it may not get connected to scanner via your odb2 port. So you would be diagnosing problems by hit and trial

    What engine you have got in there ? D series? if yes wiring is easily available here complete uncut wiring would cost you approximately 5-8k. I have seen many here.

    Is your car manual or Automatic?

    Seems like this car has been done by another Nito Tape Ustaad. I have one accord and i sorted it out each bit of it.

    If you are getting CEL in regards to generic P700 transmission code then again your car would run like crap and wont rev beyond 4800-5k RPM. I think you are using Auto ECU. In this case your VTEC would not even kick in.
    Buddy you must be right about sensors thing.
    But I have genuine harness, but that's arr auto transmission, grips are there for O2 sensor but there's no sensor on manifold, so scanners are working well.
    It's a manual D17a2, availability of manual harness and ecu was issue in multan.
    You are right about generic transmission code. But it does rev above 5000RPM and VTEC did give an error when car was started for the first time but it was gone after a 2,3km of driving.

    Can you please tell me the actual ecu code number for manual D17a2?

    Sent from my HTC One using PW Forums mobile app

  9. #28
    Senior PakWheeler Follow
    fawadakbarkhan's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    100
    Posts
    6,218
    Follows
    4
    Following
    0
    Mentioned
    143 Post(s)
    Tagged
    52 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Soban00 View Post

    That was the price of new valves, seals and something he said 'sleebs' will check all this from somewhere else

    Sent from my HTC One using PW Forums mobile app
    He meant piston sleeves. Why would he suggest new piston sleeves for an okay engine?

    I now know u already have a kabli engine in there. Well, if the engine lacks compression, go for a new motor. If the valve seals are problematic, get them replaced.


    Sent from my iPhone
    Agar chy bu'tt' hain Jama'at ki Aasteenon main - Mujhay Hai Hukm-e-Aazaan LA ILA HA ILL ALLAH...!

  10. #29
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by RollOnBigMaMa View Post
    He meant piston sleeves. Why would he suggest new piston sleeves for an okay engine?

    I now know u already have a kabli engine in there. Well, if the engine lacks compression, go for a new motor. If the valve seals are problematic, get them replaced.


    Sent from my iPhone
    No idea about piston sleeves, will ask

    Bro just to be confirmed does value problem only occurs in closed loop operations, and after driving for say 10kms?

    Sent from my HTC One using PW Forums mobile app

  11. #30
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Soban00
    ECU Number for your engine is 37820-PLR-L05 though last numbers may vary as they are versions. There is something i am not understanding.

    Is your Transmission Manual or Automatic ?

    Is your Wiring Harness Automatic or Manual ?

    In regards to O2 sensor you can locate it when your car is lifted up and you can see whole exhaust. Generally its not that back its near the place where exhaust is connected to head.
    93 Accord CB7 (Sold) / 2005 CL7

  12. #31
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    @Soban00
    ECU Number for your engine is 37820-PLR-L05 though last numbers may vary as they are versions. There is something i am not understanding.

    Is your Transmission Manual or Automatic ?

    Is your Wiring Harness Automatic or Manual ?

    In regards to O2 sensor you can locate it when your car is lifted up and you can see whole exhaust. Generally its not that back its near the place where exhaust is connected to head.
    Thank you so much, I'll source it out. right now vehicle is running on 37820-PSA-J52.
    Transmission is manual, Wiring harness is of automatic transmission, it's really a messed setup.

    and buddy, Still not able to fine any O2 sensor, checked it again and again.

  13. #32
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well @Soban00 dont worry if its messed up setup. I sorted same situation my self. I had similar situation. Well to my knowledge you are using AT ECU. This will be one of many other problems. See the ECU wants to have signal from Main Shaft and Counter Shaft so that it can see the car moving. In manual ECU the car simply will have VSS signal. In your case car would not have good performance plus NO VTEC

    Same situation that I was in.

    If you visit Lahore goto Bilal Ganj and find manual Harness + ECU (5k+8K) and your car will be in beast mode. You can figure out O2 later on as it wont be the cause of your missing. Get your fuel pressure checked ASAP
    93 Accord CB7 (Sold) / 2005 CL7

  14. #33
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    Well @Soban00 dont worry if its messed up setup. I sorted same situation my self. I had similar situation. Well to my knowledge you are using AT ECU. This will be one of many other problems. See the ECU wants to have signal from Main Shaft and Counter Shaft so that it can see the car moving. In manual ECU the car simply will have VSS signal. In your case car would not have good performance plus NO VTEC

    Same situation that I was in.

    If you visit Lahore goto Bilal Ganj and find manual Harness + ECU (5k+8K) and your car will be in beast mode. You can figure out O2 later on as it wont be the cause of your missing. Get your fuel pressure checked ASAP
    Right buddy, tomorrow I'll check the fuel pressure and will do a compression test to rule out valve issue.
    and will check the market for Harness and ECU, hopefully I'll find one as now I know what I'm look for. Thank you Afnan.

  15. #34
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Welcome and may be when you come to Lahore we can go together to and perhaps i can get you things at lesser price as while doing work on my ride i made many friends in market
    93 Accord CB7 (Sold) / 2005 CL7

  16. #35
    PakWheeler Follow
    Soban00's Avatar
    Join Date
    Aug 2012
    Location
    Kabir wala
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    Welcome and may be when you come to Lahore we can go together to and perhaps i can get you things at lesser price as while doing work on my ride i made many friends in market
    Again thank you, I'll try to source it out here, if not, then I'll defiantly give you some trouble in 1-2 weeks and after all the trouble we will have a good steak.

  17. #36
    Senior PakWheeler Follow
    bradpit's Avatar
    Join Date
    Nov 2010
    Location
    Karachi
    Age
    42
    Posts
    2,064
    Follows
    1
    Following
    0
    Mentioned
    87 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    @Soban00
    ECU Number for your engine is 37820-PLR-L05 though last numbers may vary as they are versions. There is something i am not understanding.

    Is your Transmission Manual or Automatic ?

    Is your Wiring Harness Automatic or Manual ?

    In regards to O2 sensor you can locate it when your car is lifted up and you can see whole exhaust. Generally its not that back its near the place where exhaust is connected to head.
    Brother its 1.7L US Model will work fine but wiring would be different plenty available here for 4K in Shershah.
    All life is an experiment. The more experiments you make the better.

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •