Survey by Qualaroo
+ Reply to Thread
Page 1 of 4 123 ... LastLast
Results 1 to 20 of 64
Like Tree2Likes

Thread: Honda Civic (2008) Rpm meter flash

  1. #1
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Honda Civic (2008) Rpm meter flash

    Aoa everyone!
    Hope you all are doing good. Ive come across an issue today, needed advice and professional help asap.
    Today, i took the car out and noticed the rpm meter flashing after abt 8 secs. The rpm/tachometer/odometer along with speedometer flashes for a sec and then resets to normal position. Even if its on ignition II it doesnt stop flashing. I took it to honda point (lhr) and asked for help. They didnt attach it to the computer to check anything out, instead they went with the diasgnosis step. Everything seemed normal apart from the rpm needle which on its way back gets stuck at arnd 1.5rpm mark and starts to vibrate (they didnt mention any error code appearing)They even checked the battery charge level, the terminals and the wires which connected the meter but cudnt figure out anythng. Afterwards, they tuk the meter out and attached it to another car which resulted in the same flashing after 8 secs (even on ignition II). Hence everyone said to change the meter from honda for Rs. 31,500 ONLY. Lol
    The alternative method is to get the meter repaired from "Jublee meter shop" on montogmery road or get a second hand meter from billal gunj and get the ic changed with the current one.
    Im attching a pic while it flashed. It flashed with handbrake, seat belt and oil light on while rpm went from 1 or so to 0 and back to 1.

    Need to know if anyone else went through the same problem. If so, what options do i have? Shall i go n try getting it repaired or does anyone think theres a different problem altogether? The car is rarely driven, last week i got it washed n waxed and i didnt experience anything back then, so i dont knw how it all happened wothout driving or doing anything watsoever. Kindly help and guide!



    Sent from my Nexus 5 using PW Forums mobile app

  2. #2
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Image while flashing

    Sent from my Nexus 5 using PW Forums mobile app
    Attached Images Attached Images  

  3. #3
    Senior PakWheeler Follow
    vagabondpiper's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Age
    34
    Posts
    1,325
    Follows
    1
    Following
    0
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    strange problem . why temperature guage is showing temp near H mark?
    No one cares for Toyota more then Toyota

  4. #4
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by vagabondpiper View Post
    strange problem . why temperature guage is showing temp near H mark?
    Its flashing.. As in reaching the max and coming back to normal.. Same goes with the fuel level.. Temp is normal when its stable, fuel is at abt 4 points bt when flashed it shows as shown in the pic.

    Sent from my Nexus 5 using PW Forums mobile app

  5. #5
    Senior PakWheeler Follow
    vagabondpiper's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Age
    34
    Posts
    1,325
    Follows
    1
    Following
    0
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    got that
    No one cares for Toyota more then Toyota

  6. #6
    Senior PakWheeler Follow
    incognito59's Avatar
    Join Date
    Sep 2006
    Location
    Lahore
    Age
    57
    Posts
    3,174
    Follows
    1
    Following
    0
    Mentioned
    41 Post(s)
    Tagged
    16 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Strange since it is less than 10k driven.

    Sent from my GT-I9082 using PW Forums mobile app
    life is but wheels!

  7. #7
    Senior PakWheeler Follow
    faiz.aslam.121's Avatar
    Join Date
    Jan 2013
    Location
    Oslo
    Age
    21
    Posts
    7,464
    Follows
    5
    Following
    0
    Mentioned
    148 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Try resetting the ECU by removing negative battery cable. I am no expert, let the experts comment
    Turbo lag is like foreplay. You know it's coming. And it's gonna be good.

  8. #8
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    90% its loose connection or wire. Even if not that it may be something loose or desoldered on pcb. Check fuses first most likely its power related
    93 Accord CB7 (Sold) / 2005 CL7

  9. #9
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by faiz.aslam.121 View Post
    Try resetting the ECU by removing negative battery cable. I am no expert, let the experts comment
    Did that.. Nothing changed.

    Sent from my Nexus 5 using PW Forums mobile app

  10. #10
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    90% its loose connection or wire. Even if not that it may be something loose or desoldered on pcb. Check fuses first most likely its power related
    They attached my meter to another civic which was thrre for serive etc.. Flashing didnt stop..so probably no fuse issue.. Idk, There has to be some logic behind it. As in how n why did such a thing start in the first place. Even the electrician said that he hasnt seen such an issue befre.
    Pcb? Sorry im nt that literate with such terms.

    Sent from my Nexus 5 using PW Forums mobile app

  11. #11
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by incognito59 View Post
    Strange since it is less than 10k driven.

    Sent from my GT-I9082 using PW Forums mobile app
    Yup.. Its 08 model with such mileage.. V rare to spot one.

    Sent from my Nexus 5 using PW Forums mobile app

  12. #12
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by 458_Italia View Post
    They attached my meter to another civic which was thrre for serive etc.. Flashing didnt stop..so probably no fuse issue.. Idk, There has to be some logic behind it. As in how n why did such a thing start in the first place. Even the electrician said that he hasnt seen such an issue befre.
    Pcb? Sorry im nt that literate with such terms.

    Sent from my Nexus 5 using PW Forums mobile app
    If your meter flashes even pluged in other car this means that none is at fault than your meter. PCB means Printed Circuit Board. aka Chip inside meter may have some loose connection.
    93 Accord CB7 (Sold) / 2005 CL7

  13. #13
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    If your meter flashes even pluged in other car this means that none is at fault than your meter. PCB means Printed Circuit Board. aka Chip inside meter may have some loose connection.
    Ok. Got it! Yes, then i think i should get it checked from the shop on montgomry road (Jublee meter) as ppl at Honda said to just buy a new one as they dont deal in repairing.

    Sent from my Nexus 5 using PW Forums mobile app

  14. #14
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yep. If i was you i would try and open to see whats the prob but if it was me as i have some knowledge of embedded systems
    93 Accord CB7 (Sold) / 2005 CL7

  15. #15
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    If your meter flashes even pluged in other car this means that none is at fault than your meter. PCB means Printed Circuit Board. aka Chip inside meter may have some loose connection.
    On the other hand, do you think i shud get it repaired? Or go for a newer one.. Im in doubt to get it repaired for some odd reason. I think i shud get it checked again from some other honda dealer.

    Sent from my Nexus 5 using PW Forums mobile app

  16. #16
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Man get it repaired. You can buy new one any time first give it a try are you in LHR?
    93 Accord CB7 (Sold) / 2005 CL7

  17. #17
    Senior PakWheeler Follow
    faiz.aslam.121's Avatar
    Join Date
    Jan 2013
    Location
    Oslo
    Age
    21
    Posts
    7,464
    Follows
    5
    Following
    0
    Mentioned
    148 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    One thing,

    Is your car in Warranty? they might fix it or replace it! Go to a different dealership this time
    Turbo lag is like foreplay. You know it's coming. And it's gonna be good.

  18. #18
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    Man get it repaired. You can buy new one any time first give it a try are you in LHR?
    Yes bro.. Frm lahore.

    Sent from my Nexus 5 using PW Forums mobile app

  19. #19
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by faiz.aslam.121 View Post
    One thing,

    Is your car in Warranty? they might fix it or replace it! Go to a different dealership this time
    Not in warranty bro bt yes on monday ill surely do visit some other dealer before getting this one repaired. Insh Allah!

    Sent from my Nexus 5 using PW Forums mobile app

  20. #20
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    Yep. If i was you i would try and open to see whats the prob but if it was me as i have some knowledge of embedded systems
    Im a noob at such systems the guy opened the meters body to figure out something, but he too cudnt find anything.. Probably he doesnt knw much to start of with. Bt ur right, il gt it checked n if posble repaired too.

    Sent from my Nexus 5 using PW Forums mobile app

+ Reply to Thread
Page 1 of 4 123 ... LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •