Survey by Qualaroo
+ Reply to Thread
Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 64
Like Tree2Likes

Thread: Honda Civic (2008) Rpm meter flash

  1. #1
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Honda Civic (2008) Rpm meter flash

    Aoa everyone!
    Hope you all are doing good. Ive come across an issue today, needed advice and professional help asap.
    Today, i took the car out and noticed the rpm meter flashing after abt 8 secs. The rpm/tachometer/odometer along with speedometer flashes for a sec and then resets to normal position. Even if its on ignition II it doesnt stop flashing. I took it to honda point (lhr) and asked for help. They didnt attach it to the computer to check anything out, instead they went with the diasgnosis step. Everything seemed normal apart from the rpm needle which on its way back gets stuck at arnd 1.5rpm mark and starts to vibrate (they didnt mention any error code appearing)They even checked the battery charge level, the terminals and the wires which connected the meter but cudnt figure out anythng. Afterwards, they tuk the meter out and attached it to another car which resulted in the same flashing after 8 secs (even on ignition II). Hence everyone said to change the meter from honda for Rs. 31,500 ONLY. Lol
    The alternative method is to get the meter repaired from "Jublee meter shop" on montogmery road or get a second hand meter from billal gunj and get the ic changed with the current one.
    Im attching a pic while it flashed. It flashed with handbrake, seat belt and oil light on while rpm went from 1 or so to 0 and back to 1.

    Need to know if anyone else went through the same problem. If so, what options do i have? Shall i go n try getting it repaired or does anyone think theres a different problem altogether? The car is rarely driven, last week i got it washed n waxed and i didnt experience anything back then, so i dont knw how it all happened wothout driving or doing anything watsoever. Kindly help and guide!



    Sent from my Nexus 5 using PW Forums mobile app

  2. #21
    Senior PakWheeler Follow
    sk_020's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Age
    22
    Posts
    3,316
    Follows
    1
    Following
    0
    Mentioned
    66 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Very strange problem. Even on 8th gen civic forums this problem has not been reported before. I'd suggest to change the meter to a new one or used from bilal gunj. Repairing this meter will be little hard for our mechanics as it is digital.

  3. #22
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yup.. Indeed. Gona check a shop n see what he does with it. He deals with digital meters.. Hope it gets resolved. My concern is why did such a thing happen? Short circuit or just bad luck? Honda ppl hav no answer to it.. They just say electronic cheez hai, kuch nahe keh saktay kab kharab hojaye.. Thats the lamest excuse to hear..So thats y posted here for some proper advice.


    Sent from my Nexus 5 using PW Forums mobile app

  4. #23
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @458_Italia well they are correct. Electronics comes with no guarantees especially if it is manufactured in china. We know these PKDM civics are not Japanese at least. Did they tried same meter on some other car?
    93 Accord CB7 (Sold) / 2005 CL7

  5. #24
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    @458_Italia well they are correct. Electronics comes with no guarantees especially if it is manufactured in china. We know these PKDM civics are not Japanese at least. Did they tried same meter on some other car?
    Heres a video i just took after a diagnostic run. Check out the flash in the end

    VID_20140202_150458 - Video Dailymotion

  6. #25
    Senior PakWheeler Follow
    mehran's Avatar
    Join Date
    Dec 2010
    Location
    Rawalpindi
    Age
    45
    Posts
    1,374
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Question Software...

    A friend owns a Honda City 2007 and his speedometer started giving erratic readings. Took the car to an electronics mechanic (not to an authorized Honda dealership) and it was diagnosed as a software fault. The technician connected the car to a diagnosis unit and read out some fault codes. He then reset the speedometer system and the problem was gone. Your problem seems to be something like that so its probably in the software. And I find it strange that the Honda guys did not connect it to their diagnosis unit. That should be the first step in any fault finding procedure. But good luck in your repair efforts. Please let us know what was the outcome.
    :-)

  7. #26
    Senior PakWheeler Follow
    faiz.aslam.121's Avatar
    Join Date
    Jan 2013
    Location
    Oslo
    Age
    21
    Posts
    7,464
    Follows
    5
    Following
    0
    Mentioned
    148 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^ or do try resetting the ECU!
    Turbo lag is like foreplay. You know it's coming. And it's gonna be good.

  8. #27
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mehran View Post
    A friend owns a Honda City 2007 and his speedometer started giving erratic readings. Took the car to an electronics mechanic (not to an authorized Honda dealership) and it was diagnosed as a software fault. The technician connected the car to a diagnosis unit and read out some fault codes. He then reset the speedometer system and the problem was gone. Your problem seems to be something like that so its probably in the software. And I find it strange that the Honda guys did not connect it to their diagnosis unit. That should be the first step in any fault finding procedure. But good luck in your repair efforts. Please let us know what was the outcome.
    Im going to visit another honda dealer tmrw, Honda city sales (lhr).. If they too dont find any ans then gona get it repaired. Yes, insh Allah will let everyone know.

    Sent from my Nexus 5 using PW Forums mobile app

  9. #28
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by faiz.aslam.121 View Post
    ^^ or do try resetting the ECU!
    Ill look into that option too.. Will ask honda ppl to do so.

    Sent from my Nexus 5 using PW Forums mobile app

  10. #29
    Senior PakWheeler Follow
    afnan.bashir's Avatar
    Join Date
    Jan 2013
    Posts
    1,994
    Follows
    5
    Following
    0
    Mentioned
    147 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Pull your car battery terminals for 10 minutes it would reset the ECU. I would suggest visit Iqbal Pyara near chuburgy at back of surya azim.
    93 Accord CB7 (Sold) / 2005 CL7

  11. #30
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnan.bashir View Post
    Pull your car battery terminals for 10 minutes it would reset the ECU. I would suggest visit Iqbal Pyara near chuburgy at back of surya azim.
    Ok.. Ill do that.. I ws also told to go to some elctrician near chuburgi chowk.. Its i guess before the chowk on the right, oposte to the graveyard? Is this the same guy? Sir, if you have any number, plz share! Thank you!

    Sent from my Nexus 5 using PW Forums mobile app

  12. #31
    PakWheeler Follow
    raza115's Avatar
    Join Date
    Dec 2010
    Location
    Lahore
    Posts
    334
    Follows
    0
    Following
    1
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    remove the negative TErminal and then put it back and tight it problem solved

  13. #32
    Senior PakWheeler Follow
    shazo's Avatar
    Join Date
    Aug 2010
    Location
    Lahore
    Age
    26
    Posts
    3,418
    Follows
    2
    Following
    0
    Mentioned
    240 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Lets try this
    Turn key to steering lock n take key out, insert again n move to ignition, turn ur parking lights ON while key on ignition, press n hold cluster brightness control button and mean while do ur parking light OFF-ON-OFF and tap that brightness control button 3 times. By this you will be in cluster test mode, might be this could solve, as more u tap the button, cluster will give u demo everytime

    Sent from my HTC Desire HD A9191 using Tapatalk 2

  14. #33
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by shazo View Post
    Lets try this
    Turn key to steering lock n take key out, insert again n move to ignition, turn ur parking lights ON while key on ignition, press n hold cluster brightness control button and mean while do ur parking light OFF-ON-OFF and tap that brightness control button 3 times. By this you will be in cluster test mode, might be this could solve, as more u tap the button, cluster will give u demo everytime

    Sent from my HTC Desire HD A9191 using Tapatalk 2
    Did that.. When tapping the button the demo does start but after the flash it resets to normal.. As in the demo ends right there.
    Took it to Honda and got it connected to the computer, no issue in anything at all.. No sensor issue neither does it show any error, hence rpm meter is faulty.

    Sent from my Nexus 5 using PW Forums mobile app

  15. #34
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Took the negative terminal out for a good period of time.. Doesnt solve anything.. Its confirmed, the meter itself is faulty.. Will b getng it repaired, will post abt the issue n repairing cost once done.

    Sent from my Nexus 5 using PW Forums mobile app

  16. #35
    PakWheeler Follow
    DIRTYDEVIL's Avatar
    Join Date
    Feb 2007
    Location
    Karachi
    Age
    31
    Posts
    29
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    even i faced the same problem as my car is hardly used. it was a headache to diagnose this problem and finally i found out that the main IC's inside the meter were malfunctioning. i got those IC's replaced and everything was back to normal. but i had to pay around 7000 for the repairs
    If tomorrow comes , It'll be too late............!

  17. #36
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by DIRTYDEVIL View Post
    even i faced the same problem as my car is hardly used. it was a headache to diagnose this problem and finally i found out that the main IC's inside the meter were malfunctioning. i got those IC's replaced and everything was back to normal. but i had to pay around 7000 for the repairs
    Where did you get it fixed from? What abt the meter reading? Was it altered or reset?

    Sent from my Nexus 5 using PW Forums mobile app

  18. #37
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Tried getting the meter repaired from Jublee meters on montgomery road. Lasted for 1km only. Lol. The guy tried to so call program the ic after takin it off.. Now the meter flashes after 4 seconds. The seat belt light and beep has gone for good, the tachometer has stopped working too.. So bascally it goes in the bin now. Went to another electrician for advice, he said the ssame thing as in thers no point of getting it fixed, this issue will re appear after a few days or even months. So now, ive asked a mechanic to find one in billal gunj. Lets see what he has to say.

    Sent from my Nexus 5 using PW Forums mobile app

  19. #38
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    If anyone here has any link from where i could purchase a second hand rpm meter (fr manual trans) plz let me knw.
    (Preferably if its in mint condition)

    Sent from my Nexus 5 using PW Forums mobile app

  20. #39
    PakWheeler Follow
    458_Italia's Avatar
    Join Date
    Apr 2013
    Location
    Lahore
    Age
    32
    Posts
    336
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Any1?

    Sent from my Nexus 5 using PW Forums mobile app

  21. #40
    Senior PakWheeler Follow
    faiz.aslam.121's Avatar
    Join Date
    Jan 2013
    Location
    Oslo
    Age
    21
    Posts
    7,464
    Follows
    5
    Following
    0
    Mentioned
    148 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I'll take a look in Bilal gunj Faisalabad.
    Turbo lag is like foreplay. You know it's coming. And it's gonna be good.

+ Reply to Thread
Page 2 of 4 FirstFirst 1234 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •