Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: civic 05 one horn does not work (sometimes)

  1. #1
    Senior PakWheeler Follow
    HellsGuardian's Avatar
    Join Date
    Nov 2007
    Location
    Islamabad
    Age
    26
    Posts
    2,206
    Follows
    1
    Following
    0
    Mentioned
    84 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default civic 05 one horn does not work (sometimes)

    I got stock horn in my civic 05. A month ago, the sound of horn changed so last weekend, I removed the bumper of the car. First I removed connector of left horn to see if right was working and it was working. Then I did same with other horn and both were working.

    So I simply unbolted right horn, adjusted its screw a bit to change the sound. tested the horn with a spare battery I had and bolted it back on. Some 2 days it worked perfect, now the issue is that sometimes the right horn works, some times it doesn't (random).

    I checked relay (while both horns were disconnected) and it looked and sounded fine...
    What might be the reason for it? I can open the bumper again to have a look but any ideas what might be wrong?
    Do both horns have one common switch (inside steering) or both got different... Any suggestions for troubleshooting it?

    Similar Threads:

    • #2
      PakWheeler Follow
      Ally1's Avatar
      Join Date
      May 2011
      Location
      Other
      Posts
      381
      Follows
      0
      Following
      0
      Mentioned
      7 Post(s)
      Tagged
      0 Thread(s)
      Problems Posted
      0
      Problems Solved
      0
      Best Answers
      0
      Good Answers
      0

      Default

      Check the earth wire of ur horns n secondly open steering cover n clean terminals it might get dirty or rusty
      The cars we drive say a lot about us.

    • #3
      Senior PakWheeler Follow
      HellsGuardian's Avatar
      Join Date
      Nov 2007
      Location
      Islamabad
      Age
      26
      Posts
      2,206
      Follows
      1
      Following
      0
      Mentioned
      84 Post(s)
      Tagged
      4 Thread(s)
      Problems Posted
      0
      Problems Solved
      0
      Best Answers
      0
      Good Answers
      0

      Default

      Quote Originally Posted by Ally1 View Post
      Check the earth wire of ur horns n secondly open steering cover n clean terminals it might get dirty or rusty

      so both horns got separate terminals? earth is the car body itself so i wonder how do i check that.. (its bolted tight so not loose) @Xulfiqar

    • #4
      Senior PakWheeler Follow
      Xulfiqar's Avatar
      Join Date
      Aug 2003
      Location
      Other
      Age
      38
      Posts
      24,405
      Follows
      131
      Following
      0
      Mentioned
      3991 Post(s)
      Tagged
      94 Thread(s)
      Problems Posted
      0
      Problems Solved
      4
      Best Answers
      0
      Good Answers
      6

      Default

      There is only 1 connector at the horn pad. both horns take a common source to work. They do wear out, replace with a spare part. Infact junk the little city horns and install fanfares.
      ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

    • #5
      Senior PakWheeler Follow
      HellsGuardian's Avatar
      Join Date
      Nov 2007
      Location
      Islamabad
      Age
      26
      Posts
      2,206
      Follows
      1
      Following
      0
      Mentioned
      84 Post(s)
      Tagged
      4 Thread(s)
      Problems Posted
      0
      Problems Solved
      0
      Best Answers
      0
      Good Answers
      0

      Default

      Quote Originally Posted by Xulfiqar View Post
      There is only 1 connector at the horn pad. both horns take a common source to work. They do wear out, replace with a spare part. Infact junk the little city horns and install fanfares.
      so its the horn itself the problem? and no am good with stock setup

    + Reply to Thread

    User Tag List

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •