Survey by Qualaroo
+ Reply to Thread
Results 1 to 15 of 15
Like Tree5Likes
  • 2 Post By asim510
  • 1 Post By irfansiddique
  • 1 Post By shuja11
  • 1 Post By newtechautos

Thread: Heard a bang from bonnet

  1. #1
    Senior PakWheeler Follow
    HellsGuardian's Avatar
    Join Date
    Nov 2007
    Location
    Islamabad
    Age
    26
    Posts
    2,207
    Follows
    1
    Following
    0
    Mentioned
    84 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Heard a bang from bonnet

    This morning while going to my work, there is a U-turn right before my workplace. Traffic was coming from front so i waited on u-turn for the road to clear. When it was clear, i released clutch too quickly so the engine died but with a bang like sound.
    The bang was from front of the car, it was not loud at all... just enough for me to hear it. Since I was now in middle of the road, I tried starting the car and it started easily.

    I reached office and by the look of engine bay, nothing seemed to be wrong. There was no bad smell, no smoke, engine check light didn't turn on either. I did saw some broken pieces of timing belt casing/seal

    But i am wondering what was it.... Did the car backfired through throttle body? if yes how can i confirm it and whats the solution to fix it

    Edit: Car is civic 05 manual. Was driving it on CNG

  2. #2
    Senior PakWheeler Follow
    asim510's Avatar
    Join Date
    Nov 2009
    Location
    Islamabad
    Age
    33
    Posts
    3,393
    Follows
    0
    Following
    0
    Mentioned
    72 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    1
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    Was it on CNG? Car is baleno or Santro?


    Sent using portable handheld device.
    Before you criticize someone, Make sure you are better than them.............

  3. #3
    Senior PakWheeler Follow
    irfansiddique's Avatar
    Join Date
    Oct 2008
    Location
    Karachi
    Age
    33
    Posts
    1,765
    Follows
    2
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    its called mis-fire check your air filter it must have burned marks.

  4. #4
    Senior PakWheeler Follow
    HellsGuardian's Avatar
    Join Date
    Nov 2007
    Location
    Islamabad
    Age
    26
    Posts
    2,207
    Follows
    1
    Following
    0
    Mentioned
    84 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes cng...

  5. #5
    PakWheeler Follow
    shuja11's Avatar
    Join Date
    Nov 2013
    Location
    Lahore
    Age
    32
    Posts
    523
    Follows
    2
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bang bang, she shot me down
    Bang bang, I hit the ground
    Bang bang, that awful sound
    Bang bang, my baby shot me down

    Seasons came and changed the time
    And we grew up, I called her mine
    She would always laugh and say
    "Remember when we used to play?"

    "Bang bang, I shot you down"
    "Bang bang, you hit the ground"
    "Bang bang, that awful sound"
    "Bang bang, I used to shoot you down

  6. #6
    Senior PakWheeler Follow
    irfansiddique's Avatar
    Join Date
    Oct 2008
    Location
    Karachi
    Age
    33
    Posts
    1,765
    Follows
    2
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    definately misfire / backfire = check coils, cng advancer , emulator , spark plugs.

  7. #7
    Senior PakWheeler Follow
    HellsGuardian's Avatar
    Join Date
    Nov 2007
    Location
    Islamabad
    Age
    26
    Posts
    2,207
    Follows
    1
    Following
    0
    Mentioned
    84 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by irfansiddique View Post
    its called mis-fire check your air filter it must have burned marks.
    no marks on air filter or its housing...
    Quote Originally Posted by irfansiddique View Post
    definately misfire / backfire = check coils, cng advancer , emulator , spark plugs.
    My car was earlier diagnosed with faulty advancer/emulator but it went fine on its own i did not replaced it...

  8. #8
    PakWheeler Follow
    newtechautos's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    As per your above comment for Advancer/emulator there could be a cause of mix fuel that may result in misfire/backfire. As you told about faulty advancer above, better to change it or else may effect on your MAP sensor as well. Yes, sign of miss fire can easily seen by removing your air filter with burnt areas on it. Beyond this issue, you probably in need to check engine foundation as well specifically for that sound. That could be the possible cause as well prior to that sound.

  9. #9
    Senior PakWheeler Follow
    HellsGuardian's Avatar
    Join Date
    Nov 2007
    Location
    Islamabad
    Age
    26
    Posts
    2,207
    Follows
    1
    Following
    0
    Mentioned
    84 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by newtechautos View Post
    As per your above comment for Advancer/emulator there could be a cause of mix fuel that may result in misfire/backfire. As you told about faulty advancer above, better to change it or else may effect on your MAP sensor as well. Yes, sign of miss fire can easily seen by removing your air filter with burnt areas on it. Beyond this issue, you probably in need to check engine foundation as well specifically for that sound. That could be the possible cause as well prior to that sound.

    Mounting right? I checked it too, it looks fine. 2 weeks ago i replaced the front engine mount with new one worth 5k...
    With car on wheels, i could see only front mount. Will take it to some pit and get the rest of the mounts checked

    Btw there were no burn marks on air filter... Could it be because the filter itself is not right above the throttle body intake? the filter place offset to the in take as can be seen in the picture
    Heard a bang from bonnet -1376511

  10. #10
    Senior PakWheeler Follow
    YAC_Ventura's Avatar
    Join Date
    Apr 2013
    Location
    Karachi
    Posts
    1,020
    Follows
    1
    Following
    0
    Mentioned
    110 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Also check air intake pipe connection from T (CNG connection) for lose or gap.
    YASER

  11. #11
    Senior PakWheeler Follow
    HellsGuardian's Avatar
    Join Date
    Nov 2007
    Location
    Islamabad
    Age
    26
    Posts
    2,207
    Follows
    1
    Following
    0
    Mentioned
    84 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by YAC_Ventura View Post
    Also check air intake pipe connection from T (CNG connection) for lose or gap.
    air intake pipe (the one on left) or from where venturi is coming in?

  12. #12
    Senior PakWheeler Follow
    YAC_Ventura's Avatar
    Join Date
    Apr 2013
    Location
    Karachi
    Posts
    1,020
    Follows
    1
    Following
    0
    Mentioned
    110 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by HellsGuardian View Post
    air intake pipe (the one on left) or from where venturi is coming in?
    From the place where it join with CNG pipe (T section) and go in the engine.
    YASER

  13. #13
    Senior PakWheeler Follow
    HellsGuardian's Avatar
    Join Date
    Nov 2007
    Location
    Islamabad
    Age
    26
    Posts
    2,207
    Follows
    1
    Following
    0
    Mentioned
    84 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by YAC_Ventura View Post
    From the place where it join with CNG pipe (T section) and go in the engine.
    Bro in my car, the air intake pipe is not joined with CNG pipe/T
    But i will check all connections anyway. Thanks!

  14. #14
    Senior PakWheeler Follow
    YAC_Ventura's Avatar
    Join Date
    Apr 2013
    Location
    Karachi
    Posts
    1,020
    Follows
    1
    Following
    0
    Mentioned
    110 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by HellsGuardian View Post
    Bro in my car, the air intake pipe is not joined with CNG pipe/T
    But i will check all connections anyway. Thanks!
    Share your ride's engine bay pictures, so that experts can help you more effectively.
    YASER

  15. #15
    PakWheeler Follow
    newtechautos's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    As in the picture of air filter, it seems fine even the placement of filter is fine as well. This blast sort of sound occurs due to following reasons.

    1. Retired timing of valves (mostly if you have had any engine repairing or installed it in recent time)

    2. Due to mixing of fuels and issue due to CNG

    3. Due to engine mount/foundations if those are expired.

    4. most probably it might occur due to crank/cam sensor as well but in that case it will keep on with this issue again and again.

    You may judge and see things on your own according to points above. Other than this, if your car is doing well for a time or persisting any issue still? if not then better neglect this concern. If you are car not creating problems any more then my suggestion to keep enjoy your ride rather to think on it again and again which might incur you extra portion of investment which i think 'll not be healthy for you

    That incident was due to you just released the clutch instantly by mistake but you heard it in another way. This is normal, could be done in manual car as well. even in small cars like coure or alto if you do the same so.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •