Survey by Qualaroo
+ Reply to Thread
Results 1 to 2 of 2

Thread: CIVIC 2005 Heating problem

  1. #1
    Newbie Follow
    gr8admirer's Avatar
    Join Date
    Jul 2014
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default CIVIC 2005 Heating problem

    Hi,

    This post may sound a common issue, but I am in much pain as just started experiencing this some 3 days ago. My car was working properly when suddenly I felt the ac started losing its coolness. I check the temperature and noticed that the it was getting on the H. So I stop the car and waited couple of minutes before opening the radiator cap. Also when I opened the radiator cap, the coolent was all gone. I didn't know what happened.
    Then I filled the radiator with coolent again and then after a day samething happened.
    Therefore, can anyone help me here as to what seems to be the problem. Should be get the radiator service or is there any thing else which you guys can recommend.

    BR

    Zeeshan


  2. #2
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,377
    Follows
    18
    Following
    0
    Mentioned
    406 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    u never bothered to check radiator fan is working properly or for any leaks

    Sent from my GT-I9300 using PW Forums mobile app
    Life is short and very unpredictable just like a Quarter mile .....

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •