Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Thread: honda civic meter in khyber

  1. #1
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default honda civic meter in khyber

    Dear Friends,

    I have installed Honda Civic 1997 model speedometer in khyber with G15A. Its not showing me the correct speed, if i am at 100km/h its showing me 180km/h. Can someone help me out, i need to know how to fix this issue?? Its also not showing the correct temp, the moment i switch on the ignition, it starts showing half temp without even starting the car.

    Regards,
    Adeel

    "Even the word 'IMPOSSIBLE' says 'I M POSSIBLE"

  2. #2
    Senior PakWheeler Follow
    john0995's Avatar
    Join Date
    Jun 2008
    Location
    Hari pur
    Posts
    1,532
    Follows
    1
    Following
    0
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    why you installed civic speedometer in Khyber? civic have ECU and Khyber don't have there is a big difference between them I don't think this speedometer wil work in Khyber. wait for some professionalx
    CoMmiNg SoOoOoOoOoOoOoOoOn

  3. #3
    Senior PakWheeler Follow
    ToxicDevil's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Posts
    1,317
    Follows
    2
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    13
    Problems Solved
    0
    Best Answers
    3
    Good Answers
    0

    Default

    you need to adjust the needles

  4. #4
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @john, i am ruuning g15a under the hood it's efi 1500cc engine

    @toxic, how to do that?

  5. #5
    Senior PakWheeler Follow
    Spano's Avatar
    Join Date
    Dec 2006
    Location
    Islamabad
    Age
    34
    Posts
    6,891
    Follows
    21
    Following
    1
    Mentioned
    321 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    1

    Default

    what is your tyre size in khyber ?

    try using the temperature gauge of civic
    Ehtesham Bokhari
    https://www.facebook.com/sebokhari

  6. #6
    PakWheeler Follow
    Deadly_Flame's Avatar
    Join Date
    Feb 2012
    Location
    Islamabad
    Posts
    600
    Follows
    0
    Following
    0
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have you changed the speedometer sensor? If not check that. But according to what you are telling either there isn't a sensor installed or if there is then its faulty.

  7. #7
    Senior PakWheeler Follow
    meh1's Avatar
    Join Date
    Feb 2012
    Location
    Sahiwal
    Posts
    1,361
    Follows
    0
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    so you are using input from g15a sensors to honda city speedo. how can they work compatible? is signal of g15a sensor compatible with honda city's speedo.
    best would be to use a suzuki speedo for compatibily.

  8. #8
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @ Spano, tyre size is 165/65/13
    @ Deadly Flame, thats i need to know, whr is this sensor?
    @meh1, this is what i need help for,i dnt think so G15A sensor is compatible with Honda Civic meter, but i have scene ppl made honda speedometer work with other engines. There is person in lhr as well who is saying he will install some kit n speedometer will work fine, but i need to help to do it on my own
    "Even the word 'IMPOSSIBLE' says 'I M POSSIBLE"

  9. #9
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    honda civic meter in khyber -1466756

    This is the honda civic meter i am using
    "Even the word 'IMPOSSIBLE' says 'I M POSSIBLE"

  10. #10
    DCA
    DCA is offline
    PakWheeler Follow
    DCA's Avatar
    Join Date
    Oct 2008
    Location
    Lahore
    Age
    35
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro if you need correct speed u should go for swift Gti meter or its OEM meter will work just fine,no alteration required.Save your time and money!!

  11. #11
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @DCA, u r right, but unfortunately I have already installed in my car, so no I need to fix it
    "Even the word 'IMPOSSIBLE' says 'I M POSSIBLE"

  12. #12
    Senior PakWheeler Follow
    ToxicDevil's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Posts
    1,317
    Follows
    2
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    13
    Problems Solved
    0
    Best Answers
    3
    Good Answers
    0

    Default

    I dont know about compatibility of this meter but if you want to adjust the needles. Remove the needle, bring the key to On position without starting the engine. Then put your needle at the zero mark and plug it in.

    There are pots for calibration inside the meter too. I am not sure if the speedometer has them too but the rpm meter definitely has them.

  13. #13
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Rpm is doing fine, only issue is with speedometer, n that is a compatibility issue

  14. #14
    PakWheeler Follow
    mwanwar's Avatar
    Join Date
    Feb 2009
    Location
    Islamabad
    Age
    36
    Posts
    538
    Follows
    1
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Addy346 View Post
    Rpm is doing fine, only issue is with speedometer, n that is a compatibility issue
    bhai speed sensor is missing as original cluster was connected with wire for speed from engine

    once you have switched to pulse cluster u need a speed sensor which send speed signals to cluster, electrician who has installed should have installed the sensor also

  15. #15
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^ can u guide, where is this senspor placed? cuz meter working but not showing the correct speed, so by fixing the sensor issuse, my issue will be resolved or i need to do something else as well
    "Even the word 'IMPOSSIBLE' says 'I M POSSIBLE"

  16. #16
    Senior PakWheeler Follow
    ToxicDevil's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Posts
    1,317
    Follows
    2
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    13
    Problems Solved
    0
    Best Answers
    3
    Good Answers
    0

    Default

    It is usually mounted on the transmission and has 3 pins

  17. #17
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have installed engine's orginal sensor and using it with ths speedometer
    "Even the word 'IMPOSSIBLE' says 'I M POSSIBLE"

  18. #18
    PakWheeler Follow
    Deadly_Flame's Avatar
    Join Date
    Feb 2012
    Location
    Islamabad
    Posts
    600
    Follows
    0
    Following
    0
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well your problem is the the speed sensor then. Get that changed and it should be fine. I don't know where it is installed exactly, but its definitely the speed sensor. I've the camry/lexus meter in my khyber and some corolla speed sensor was used with it to make it work fine, initially I hadn't installed the speed sensor and I was facing exactly the same issue.

    Regards,

    P.S: I got the sensor from speedometer guys in sultan ka khoo rawalpindi.

  19. #19
    PakWheeler Follow
    Addy346's Avatar
    Join Date
    Feb 2006
    Location
    Lahore
    Age
    34
    Posts
    623
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^ thats guy make some chip for you or u have just buy the sensor n intalled in ur car, cuz i will be needing honda sensor then. Can someone guide me how to do it in lhr?
    "Even the word 'IMPOSSIBLE' says 'I M POSSIBLE"

  20. #20
    PakWheeler Follow
    Deadly_Flame's Avatar
    Join Date
    Feb 2012
    Location
    Islamabad
    Posts
    600
    Follows
    0
    Following
    0
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It wasn't a chip was some kind of an analog stick with a small gear at one end and some kind of modification was done to it so that it can fit the engine. They've ready made sensors for lexus/camry meter here in sultan ka khoo since many people opt for it.

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •