Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 26 of 26
Like Tree7Likes

Thread: Civic 99-00 Slip when I apply brake

  1. #1
    PakWheeler Follow
    islamabadboys's Avatar
    Join Date
    Dec 2008
    Location
    Islamabad
    Age
    27
    Posts
    175
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy Civic 99-00 Slip when I apply brake

    AOA Everyone,

    I am experiencing an issue in my car from last 1 month but unfortunately today I hit my car from front as I applied brake on speed of 40-50 km/h and my car totally slipped and hits Mehran...
    I changed my tires last year its Dunlop 185 R14 made in Japan and thread(guddi) still looks good... but whenever I apply brake even on 40-50 km/h car starts slipping and there is no sound of brake when I press hard pedal as car starts slipping (there is sound of slipping seems like no tire friction)...
    P.S. Its Civic 2000 vti oriel (4 wheels disc brakes NO abs)
    I just attached photo of my car
    Civic 9900 Slip when I apply brake -1523530


  2. #21
    PakWheeler Follow
    Mun33b's Avatar
    Join Date
    May 2013
    Location
    Karachi
    Posts
    159
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    For hardness of rubber, check the date of manufacturing of tires. As over exposure to sunlight make tires hard. BTW are your tires snow tread??

  3. #22
    uiv
    uiv is offline
    Senior PakWheeler Follow
    uiv's Avatar
    Join Date
    Jan 2006
    Location
    Lahore
    Posts
    1,683
    Follows
    2
    Following
    0
    Mentioned
    67 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^ That's a good point. Also, you are not, by any chance, using those smuggled tyres, are you?

  4. #23
    PakWheeler Follow
    irfan44's Avatar
    Join Date
    Oct 2008
    Location
    Faisalabad
    Posts
    867
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Had the exact same issue with my ride a few years back.
    The prob was the rear brakes. Rear wasn't gripping well while front was fine. Just do as under:
    - make sure ur rear brakes r good. Change pads if needed with good ones
    - ur hand brake should lock within 3-5 clicks ( although it has nothing to do with ur prob but I get a good idea abt my brakes when it exceeds 3-5 due to wear)
    And I hope u haven't installed those stupid metal studs/ pads to raise the *** of ur car, caz it disturbs the balance or the COG.


    Sent from my iPhone using PW Forums

  5. #24
    Senior PakWheeler Follow
    usama1's Avatar
    Join Date
    Sep 2005
    Age
    37
    Posts
    1,461
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Same problem facing ine exi 2001...brake oil changed from honda..disk pads changed .nissin i think...tytes are in great nick 195-60/15 Dunlop..bleeding done...the prob seems to be with master cylinder or servay..

  6. #25
    PakWheeler Follow
    islamabadboys's Avatar
    Join Date
    Dec 2008
    Location
    Islamabad
    Age
    27
    Posts
    175
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    So brakes get diagnosed and all brakes (front and rear) are working properly but my mechanic told me that car is slipping due to hard suspension (which cause lack of downward force) and tires are not that much soft as its manufacturing date is of December 2013.
    Now I planned to change its suspension spring first (going for stock suspension which is lying somewhere in my home). If problem will be still there then I will go for changing tires.
    Thanks to all pakwheelers for suggestions.

  7. #26
    uiv
    uiv is offline
    Senior PakWheeler Follow
    uiv's Avatar
    Join Date
    Jan 2006
    Location
    Lahore
    Posts
    1,683
    Follows
    2
    Following
    0
    Mentioned
    67 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by islamabadboys View Post
    So brakes get diagnosed and all brakes (front and rear) are working properly but my mechanic told me that car is slipping due to hard suspension (which cause lack of downward force) and tires are not that much soft as its manufacturing date is of December 2013.
    Now I planned to change its suspension spring first (going for stock suspension which is lying somewhere in my home). If problem will be still there then I will go for changing tires.
    Thanks to all pakwheelers for suggestions.
    Told ya'

    Inertia is the word.

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •