Survey by Qualaroo
+ Reply to Thread
Results 1 to 13 of 13

Thread: Engine Check light of CIvic

  1. #1
    PakWheeler Follow
    azeemchowhan's Avatar
    Join Date
    Apr 2005
    Location
    Rawalpindi
    Age
    37
    Posts
    86
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Engine Check light of CIvic

    Dear Experts

    i m having some problem in my civic 2004, its vti oriel, i ve recently installed CNG in it. I m facing a problem, that on CNG car starts missing and after sometime the engine check light is on. When engine check light is on, its stop missing and give me smooth drive. Can any body help me that what is the problem with it and is it dangerous? Why the engine check light keeps on?etc....Kindly advice....

  2. #2
    Senior PakWheeler Follow
    malikg115's Avatar
    Join Date
    Apr 2005
    Location
    Other
    Posts
    6,536
    Follows
    5
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bro i think its INJECTOR'S light
    i hav found many efi cars w cng
    when cng is sent to engine, petrol is not taken by the engine,
    so the petrol machine THE INJECTOR says something but v dont listen 2 it.
    as it is not somthing original
    so v hav 2 compromise for these things otherwise
    this light should not b ON aftr starting the car,
    othrwise in efi it means a prob like SENSOR ETC.
    For Riding Jackets & Gloves, Armors, Saddle Bags, Knee & Elbow Guards etc: https://www.facebook.com/PbcMotorSport?fref=ts

  3. #3
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,379
    Follows
    18
    Following
    0
    Mentioned
    406 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    Which dope head did the wiring for the emulator? engine check light should not show up with proper wiring...
    Life is short and very unpredictable just like a Quarter mile .....

  4. #4
    PakWheeler Follow
    azeemchowhan's Avatar
    Join Date
    Apr 2005
    Location
    Rawalpindi
    Age
    37
    Posts
    86
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    So....hash4u please tell me......what can b done for this? Is there a wiring problem, if yes, who should i for in Rwp/Isb..who can fix this problem brother.....thanks for response...

  5. #5
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,737
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Hello!
    the emulator is thus placed to send false signals to ECU that injectors are working while car was on CNG...
    thats what emulator do and convert petrol to CNG conversions....!!
    there is mess up with wiring...!get it check before u end up frying any one Electronics....!
    Thanxxxxx
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  6. #6
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    it can be solved..........................
    AE 86

  7. #7
    PakWheeler Follow
    fahadkhang's Avatar
    Join Date
    Jan 2006
    Location
    Gujranwala
    Age
    31
    Posts
    505
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    My Dear, When you start your car, give it a full eccelerater for a few seconds, I hope the problem will solved. Beacuse Efi Engine start on Petrol & then Automatically go on CNG, So need a little accelerator to give it proper transfer on CNG, TRY This,
    (( Proud to Be a Muslim ))

  8. #8
    Senior PakWheeler Follow
    spectra's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Age
    40
    Posts
    19,667
    Follows
    3
    Following
    0
    Mentioned
    304 Post(s)
    Tagged
    24 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Azeem

    CNG fitting in your car is not SOA compliant. Also further disclosures are needed from your side to understand the problem
    Keep a cool head and wear seatbelts!

  9. #9
    PakWheeler Follow
    azeemchowhan's Avatar
    Join Date
    Apr 2005
    Location
    Rawalpindi
    Age
    37
    Posts
    86
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Spectra

    I also think the same way , my mechanic is not SOA compliant..c u soon.

  10. #10
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,379
    Follows
    18
    Following
    0
    Mentioned
    406 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    SOA compliant?
    well u can goto any...
    Shann cng,
    al mubarik,
    cng complex to rectify the problem
    Life is short and very unpredictable just like a Quarter mile .....

  11. #11
    Senior PakWheeler Follow
    spectra's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Age
    40
    Posts
    19,667
    Follows
    3
    Following
    0
    Mentioned
    304 Post(s)
    Tagged
    24 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Hash
    Azeem is a fellow accountant with Ford Rhodes Sidat Hyder and they happen to be Auditors of telenor, so i know him personaly

    SOA is a long Audit and Accounting related story. will tell u some other time in person.
    Keep a cool head and wear seatbelts!

  12. #12
    Senior PakWheeler Follow
    Mianz's Avatar
    Join Date
    Apr 2005
    Location
    Melbourne
    Age
    38
    Posts
    1,235
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @azeemchowhan

    Similar thing happened with my friend, he has HYUNDAI LANTRA.
    I had a chance to have a conversation with the Mechanic.
    This is what he said.

    When ever you get this light warning, it means you have either some problem with the internal combustion chamber settings of engine or it is the computer of the car. It can happen at any time, mostly when machinery in the engine compartment is not dealt properly.

    Well in the end the problem in my friend’s car was the computer. So he had to spend $800 to get a new computer for his car.
    I would suggest you to get your car checked by some Honda mechanic as soon as possible. Some big problem is there waiting to happen.
    Act quickly.

  13. #13
    PakWheeler Follow
    yousafzai384's Avatar
    Join Date
    Sep 2006
    Location
    Islamabad
    Age
    40
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bai Saab your car as i know two problem one during startin a littele bit missing here may be emulater problem but you auto switch problem may happen it must be seen.and the second problem you have i think your advacer lose the work this time so you please replace the device otherwise offe the battery and then see what is happen secondly change the wiring at exact places.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •