Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 23
Like Tree3Likes

Thread: Check Engine Light Problem

  1. #1
    PakWheeler Follow
    sherimajeed's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Check Engine Light Problem

    Hello! I am having a problem with my Civic VTi Oriel 2004 Manual.
    The Check engine light turns on and off while driving and it gives a strong jerk when this happens. It turns on and off within a second and everytime the car gives a strong jerk like it has missing issue. I have taken it to many mechanics in Rawalpindi and Islamabad but none have been able to diagnose the issue. The computer check always shows that all is ok. I am driving it on Petrol for last 3 years and have removed the CNG kit.
    Someone plzzzzz help me out in this or do tell of a good mechanic in Rawalpindi / Islamabad.

    Thanks


  2. #2
    PakWheeler Follow
    tareen's Avatar
    Join Date
    Feb 2005
    Age
    43
    Posts
    634
    Follows
    2
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Its an auto electrician 's job who is well versed with efi systems. Probably some lose connection or fuse.

    I hv seen similar issue in a similar car and was sorted out by the electrician.
    *** Its a SATISFACTION thing. Only DIY guys will understand! ***
    DIYs require Space, Money, Time, Skill & Knowledge....or.......the absence of them

  3. #3
    Senior PakWheeler Follow
    shaheryar.khokhar's Avatar
    Join Date
    Dec 2013
    Location
    Lahore
    Posts
    1,692
    Follows
    3
    Following
    0
    Mentioned
    28 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It might be your air temp sensor or throttle position sensor, when it turns off your engine starts asking for Fuel/Air and gives a jerk. Just a guess!
    Take your mechanic for a short test drive with his scanner and get it diagnosed as quickly as the light appears.
    - Honda Civic ES, Build Thread. Link ---> http://goo.gl/3SocBg
    - Honda Civic EG - SiR-T F20B Build Thread. Link ---> http://goo.gl/5Y4W9m

  4. #4
    PakWheeler Follow
    sherimajeed's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    anyone knows of a very good mechanic in Rwp/Isd???
    My mechanic has given up as he is unable to find the error.

  5. #5
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,312
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by sherimajeed View Post
    anyone knows of a very good mechanic in Rwp/Isd???
    My mechanic has given up as he is unable to find the error.
    Blinking cel means a misfire..whats the code??


    Sent from my iPhone using PW Forums
    Just Do It Your Self!!!!!

  6. #6
    Senior PakWheeler Follow
    dayrider's Avatar
    Join Date
    Mar 2006
    Location
    Islamabad
    Age
    27
    Posts
    1,908
    Follows
    5
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    4
    Problems Solved
    2
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by sherimajeed View Post
    anyone knows of a very good mechanic in Rwp/Isd???
    My mechanic has given up as he is unable to find the error.
    Naseer autos, g8/1. Mr satar there, one of the best available. your problem can only be diagnosed when the problem occurs while the scanner is connected, only then will it be able to detect the code.

  7. #7
    PakWheeler Follow
    sherimajeed's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by dayrider View Post
    Naseer autos, g8/1. Mr satar there, one of the best available. your problem can only be diagnosed when the problem occurs while the scanner is connected, only then will it be able to detect the code.
    Any contact number?? Its in G-8 Markaz??

  8. #8
    Senior PakWheeler Follow
    dayrider's Avatar
    Join Date
    Mar 2006
    Location
    Islamabad
    Age
    27
    Posts
    1,908
    Follows
    5
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    4
    Problems Solved
    2
    Best Answers
    0
    Good Answers
    3

    Default

    03335340127
    Not in the markaz. It's in the alleyway behind the headstart campus. Neighboring allied bank

  9. #9
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    in any instance of misfire or error - that causes the check lamp to illuminate, the code will be stored in memory and will be available for scanning.

    If for some reason you dont see the code in the error log, then there is a chance that your main relay is malfunctioning which is shutting down the ECU for a split second and restarts it under engine inertia.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  10. #10
    PakWheeler Follow
    sherimajeed's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The main issue is that the Check light flickers within a second and the scanners are unable to detect the error. It doesn't stay ON for more than half a second, specially when its being checked by a scanner. I drove for 30mins with scanner attached and that light dint stay On. Today in morning while going to office it came on for about 30secs.

  11. #11
    Senior PakWheeler Follow
    metalhead's Avatar
    Join Date
    Oct 2006
    Location
    Wah cantt
    Posts
    1,306
    Follows
    1
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Just read previous errors on the scanner.

  12. #12
    PakWheeler Follow
    sherimajeed's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thats the problem....NO PREVIOUS ERROR FOUND.

  13. #13
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by sherimajeed View Post
    Thats the problem....NO PREVIOUS ERROR FOUND.
    as I wrote above - if your engine is bucking and the check light flashes for a second your ECU is momentarily losing 12V switched power on the run, this almost always leads to a main relay problem, in your car the "main relays" are nestled behind the glovebox. To test this. its best to run an LED or something from the ECU switched power supply and place it somewhere where it can be monitored - then run the car and watch it when the car misbehaves again, if the LED goes out, you are losing 12V supply to the ECU, you can also put a similar LED to the ground wires to the ECU to check if its losing ground.

    The check lamp flash is happening because the ECU resets back to "wake" as in Key on - but as the engine is rotating - the cam and crank signals are coming in, it starts running the engine as is.

    I have repaired cars like these - I recall 3 quite vividly as they required 2 days to diagnose, one of them was key switch only, one had a bad key switch and main relay and one had a bad ECU.

    the bad key switch one was due to "aasum type R branded keyless remote - with duck quack horn"
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  14. #14
    PakWheeler Follow
    burhanzaki's Avatar
    Join Date
    Dec 2014
    Age
    20
    Posts
    406
    Follows
    0
    Following
    1
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Timing sensor


    Sent from my iPhone using PW Forums

  15. #15
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by burhanzaki View Post
    Timing sensor


    Sent from my iPhone using PW Forums
    which one - there are two
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  16. #16
    PakWheeler Follow
    burhanzaki's Avatar
    Join Date
    Dec 2014
    Age
    20
    Posts
    406
    Follows
    0
    Following
    1
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check both of them i had the same issue and the same car it had a faulty timing sensor


    Sent from my iPhone using PW Forums

  17. #17
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,379
    Follows
    18
    Following
    0
    Mentioned
    406 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    Cam sensor should be checked for sure
    Life is short and very unpredictable just like a Quarter mile .....

  18. #18
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by burhanzaki View Post
    Check both of them i had the same issue and the same car it had a faulty timing sensor


    Sent from my iPhone using PW Forums
    Quote Originally Posted by hash4u View Post
    Cam sensor should be checked for sure

    In both of your cases, there would be an error recorded, like the CKP or TDC sensor error In the OP case there is no error reported at all. And this is a driveable car, its not a dead case that we have to wait for a 30 second starter cycle in order for the ECU to record
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  19. #19
    PakWheeler Follow
    sherimajeed's Avatar
    Join Date
    Jul 2011
    Location
    Islamabad
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yhanks guys fir all the valuable info n help. Really appreciated. Finally the issue is resolved i think cuz since morning it has not shown any problem. The spark plugs were short. Changed them n its working perfectly now. But the main test will b tomorrow morning as will be going to Attock for Eid.

    Once again thanks and a Happy Eid Mubarak to All...

  20. #20
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by sherimajeed View Post
    Yhanks guys fir all the valuable info n help. Really appreciated. Finally the issue is resolved i think cuz since morning it has not shown any problem. The spark plugs were short. Changed them n its working perfectly now. But the main test will b tomorrow morning as will be going to Attock for Eid.

    Once again thanks and a Happy Eid Mubarak to All...
    one spark plug shorted would not shut down the engine and will record a misfire error code - dont fully trust this car for long journey as yet.

    All spark plugs cannot go bad at the same time - Your mechanic is a bit lost in diagnosis, find a smarter one.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •