Survey by Qualaroo
+ Reply to Thread
Results 1 to 18 of 18

Thread: Civic 2005 Pick up issue

  1. #1
    PakWheeler Follow
    qaiser_numl's Avatar
    Join Date
    Apr 2013
    Posts
    83
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    6
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Post Civic 2005 Pick up issue

    Assalam Alaikum,

    Brothers need URGENT advice on following issues.


    1. i have got 2005 exi and i have the pickup issues with this car. the car seems heavy and take long rpms and the engine is noisy.... cleaning spark plugs resolves the issue temporarily,serviced throttle body few time and issue is resolved for few days only.....Washing MAP sensor and washing it with petrol resolves the issue for time being(the exhaust gives burning smell when engine is hot),There is knocking on petrol and the engine is missing a bit..............have done the above work quite a few times but the issue is never resolved permanently. In previous days i had the issue of car having high rmps even at stationary position but that got resolved after adjusting the butterfly of throttle body now problem is wht pickup.Checking the car on sensor mechine says everything is OK.Also on pressing the throttle hard car first hesitate to run fast even inspite of clutch and pressure pressure plate changed 1 month ago.

    Please advice what to do to get the good acceleration permanently. How can i check the sensors by my self? and how to resolve following issues and from where to get this sorted out in rawalpindi.

    1.bad accelaration(heavypickup).
    2. bad smell of the burning from exhaust.
    3.knocking.

    Another but different issue is with continous vibration on clutch pedal which remains on idle and also when the car is driven.(Inspite of steering assembly being changed recently along with front bushes)


  2. #2
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    565
    Follows
    1
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Clutch and pressure plate OEM?

    Have the timing checked of the car, first thing.

  3. #3
    PakWheeler Follow
    qaiser_numl's Avatar
    Join Date
    Apr 2013
    Posts
    83
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    6
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    its time to replace timing belt for sure, any good reliable mechanic around bahria town area??what cud be the next thing if timing is ok

  4. #4
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have you cleaned the air filter? When was the last time you changed it?A relative had the same issue of 'bad acceleration'. Changing the air filter solved that.

    Sent from my GT-I9300I using Tapatalk

  5. #5
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    565
    Follows
    1
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by qaiser_numl View Post
    its time to replace timing belt for sure, any good reliable mechanic around bahria town area??what cud be the next thing if timing is ok
    Mileage of car? and when was last time it was changed?

    Even if you dont change it, just check if timing is what it should be.

  6. #6
    PakWheeler Follow
    qaiser_numl's Avatar
    Join Date
    Apr 2013
    Posts
    83
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    6
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    car is 110 driven, bought it at 92ks i have never changed it...not sure when x owner changed it....how to check timing???my mechanic without using scanner says this issue is due to faulty MAP sensor as cleaning it with petrol temporarily resolve the issue.....what abt knocking and bad smell from exhaust??

  7. #7
    PakWheeler Follow
    qaiser_numl's Avatar
    Join Date
    Apr 2013
    Posts
    83
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    6
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    air filter aaaaaaaaah dont think so is the issue.....its pretty clean.

  8. #8
    PakWheeler Follow
    qaiser_numl's Avatar
    Join Date
    Apr 2013
    Posts
    83
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    6
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    are scanners really trustful....everytime they are plugged in..........its says ALL IS WELL......

  9. #9
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have you checked the spark plug gap? Too much gap can result in misfires and loss of power.

    Sent from my GT-I9300I using Tapatalk

  10. #10
    PakWheeler Follow
    shehbaz5959's Avatar
    Join Date
    Jul 2006
    Location
    Rawalpindi
    Age
    31
    Posts
    44
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    5
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Will do that.....any particular sensors that affect pickup of the car.....specially that burning smell one thing oiling the MAP resolves smell and pickup issue for few days.... Let me check if this issue exists on CNG or not.... If it doesn't then what cud be the issue ?

  11. #11
    PakWheeler Follow
    shehbaz5959's Avatar
    Join Date
    Jul 2006
    Location
    Rawalpindi
    Age
    31
    Posts
    44
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    5
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Also cleaning plugs resolves issue for time being

  12. #12
    PakWheeler Follow
    qaiser_numl's Avatar
    Join Date
    Apr 2013
    Posts
    83
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    6
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    just checked no knocking and smell on CNG......also when on starting car on CNG....Car when shifts from petrol to CNG engine dies if throttle is not pressed.....any idea????

  13. #13
    PakWheeler Follow
    abuzerkhan's Avatar
    Join Date
    Sep 2008
    Location
    Lahore
    Age
    32
    Posts
    342
    Follows
    0
    Following
    4
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by qaiser_numl View Post
    car is 110 driven, bought it at 92ks i have never changed it...not sure when x owner changed it....how to check timing???my mechanic without using scanner says this issue is due to faulty MAP sensor as cleaning it with petrol temporarily resolve the issue.....what abt knocking and bad smell from exhaust??
    its better to change timing belt if you are not certain about it. i bought my ride with 120k mileage and owner told that he has changed everything but i later found out that he lied to me and i changed timing belt and all fluids myself.

  14. #14
    Senior PakWheeler Follow
    dayrider's Avatar
    Join Date
    Mar 2006
    Location
    Islamabad
    Age
    27
    Posts
    1,911
    Follows
    5
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    4
    Problems Solved
    2
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by qaiser_numl View Post
    just checked no knocking and smell on CNG......also when on starting car on CNG....Car when shifts from petrol to CNG engine dies if throttle is not pressed.....any idea????
    Setting has an issue. as for the clutch vibrations and smell, who changed the clutch plate and pressure plate? it seems that they didn't do their job correctly

  15. #15
    PakWheeler Follow
    AffaanAlAziz1's Avatar
    Join Date
    Jul 2010
    Location
    Rawalpindi
    Age
    32
    Posts
    709
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Visit Honda 3S. Your issue will be resolved.

  16. #16
    PakWheeler Follow
    shadab_lodhi's Avatar
    Join Date
    Feb 2012
    Location
    Rawalpindi
    Posts
    85
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get the valve timing be checked by a skilled technician.

  17. #17
    PakWheeler Follow
    nawaz.khan's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Posts
    54
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abuzerkhan View Post
    its better to change timing belt if you are not certain about it. i bought my ride with 120k mileage and owner told that he has changed everything but i later found out that he lied to me and i changed timing belt and all fluids myself.
    Cost of changing timing belt and bearing???

  18. #18
    PakWheeler Follow
    abuzerkhan's Avatar
    Join Date
    Sep 2008
    Location
    Lahore
    Age
    32
    Posts
    342
    Follows
    0
    Following
    4
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by nawaz.khan View Post
    Cost of changing timing belt and bearing???
    dont know the latest rate. i changed last year. timing belt costed 4200 and bearing costed 6000 plus labor, which was around 1500, from honda.

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •