Survey by Qualaroo
+ Reply to Thread
Page 3 of 6 FirstFirst 12345 ... LastLast
Results 41 to 60 of 117
Like Tree5Likes

Thread: Need help senior members Civic 95 stock engine

  1. #1
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need help senior members Civic 95 stock engine

    @Xulfiqar
    @Maverickiz3d
    @metalhead

    Dear Brothers Assalam-O-Alaikum,

    Recently i have done car heater work and the mechanic told me to service the radiator so i went to tariq road and the guy opened my radiator.. my radiator was totally blocked...he advised me to change the jali of radiator in 2000rs... i said him ok change it after few time he came with another metal radiator and installed it.... we added 2 bottles of zic coolant and purge the air from cooling system. i drive back to home and car was making a lot of pressure... even the car parked whole night and in morning when i opened the cap to check water level some pressure throw out the coolant... i told him this and visit him he changed the radiator again with plastic one (Japani) he added tap water and told me to drive 2-3 days for checking purpose the come back and we will add coolant after flushing system.... the same day i drove the car from Tariq road to Nazimabad and temp was at c... i opened the radiator cap and water level was same and no pressure was build. Yesterday night i checked the water level it was fine.. checked engine oil it was orange type... every thing was fine i started the engine and went to board office from nazimabad and parked the car there temp was at notmal 15% due to low temp in night...after 2-3 hours when i went home i pulled the car in 3rd gear on petrol till 90kmh and then shifted 4th and 5th and maintained 80kmh after 1 min i saw the temp was rising fast... when i reached home i parked the car... idle RPM was set to 800 when i was pressing the peddle 800-1500 rpm car was jerking and engine vibrating badly... i got confused the time... i opened the radiator cap and it was empty... i opened and it was over filled i got no other water bottle at that time so i added the water to radiator from reservoir bottle and the whole reservoir bottle went inside radiator ... after few mins temp was totally down at 0% but car engine was jerking badly.. so i switched off the car and went home.. today morning i was going for office i checked engine oil... it was yellowish and creamy white and level is increased from its mark..... i opened radiator cap and there was no water i started adding water and 700ml water went inside radiator then i noticed that water was leaking from engine near manifold there was a bolt under upper hose pipe.... i didnt start the engine and leave it as it... as today is friday and mechanics are on holiday.... any senior or experienced can advise me what will be the issue in my case ??? my head gasket gone or water body ??

    Thanks.

    Similar Threads:

  2. #41
    PakWheeler Follow
    ch.talal's Avatar
    Join Date
    Mar 2014
    Location
    Lahore
    Posts
    663
    Follows
    0
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by ranker84 View Post
    Yes Mechanic told me it will work with carb... Plus we are getting some extra pipes and alot of things along with engine... The shopkeeper is punjabi and i told him im also punjabi so he gave me extra fav... We opened the engine head and its like brand new.
    Shinning from inside. My mechanic told me if i repair old engine it will cost more and alot of days and no guarantee it will work or not but if we add this engine i will be tension free for next 5-10 years
    So you opened its head to take a look inside. But I have a bad feeling, if head bolts not properly torqued will result in bending head and damaging it.

  3. #42
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    0
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ranker84 View Post
    Shazo its written in japanes ... How can i check recomended plugs

    post picture

  4. #43
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    We just opened tapet cover

  5. #44
    PakWheeler Follow
    ch.talal's Avatar
    Join Date
    Mar 2014
    Location
    Lahore
    Posts
    663
    Follows
    0
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    Alright. My bad, it's just head cover.

  6. #45
    PakWheeler Follow
    ch.talal's Avatar
    Join Date
    Mar 2014
    Location
    Lahore
    Posts
    663
    Follows
    0
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    I got confused when you said we opened the head. lol.

  7. #46
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Maverickiz3d View Post
    post picture
    Maverick attached for your ref
    Attached Images Attached Images  

  8. #47
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ch.talal View Post
    I got confused when you said we opened the head. lol.
    Hahhhhh when we opened the tappet cover it was opened for first times.

  9. #48
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    0
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    That Japanese doesnt say anything about spark plugs.

    Its only about timing belt change date and kilometres travelled.

  10. #49
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Maverickiz3d View Post
    That Japanese doesnt say anything about spark plugs.

    Its only about timing belt change date and kilometres travelled.
    Hmmm shazo told me its written on there so i start finding it but nothing found :-(

  11. #50
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    0
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    As for the plugs, most d15b uses ZFR5J-11 (NGK)

  12. #51
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I will check its pre installed plugs mechanic told me we dnt need to change them they are new

  13. #52
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    0
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yep do that.

  14. #53
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    How much labor for swaping ?

  15. #54
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    0
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ranker84 View Post
    How much labor for swaping ?
    around 5k-6k

  16. #55
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Maverickiz3d View Post
    around 5k-6k
    Paid 5K... Today we removed the engine from bay and also removed the gear and after cleaning attached the gear with new engine... InSha'ALLAH tomorrow morning he will mount the engine and in evening we will roar this new beast. Today i opened one of the plug.. They are original denso plug and new condition... Mechanic told me these original plugs dont come any more.

  17. #56
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    0
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Good enough.

    Checked the model of the plug?

    Must be KJ16CR-L11, KJ20CR-L11, or maybe K16PR-U11, K20PR-U11.

    These are the OEM plugs for d15bs.

  18. #57
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I just noticed k then 16 like that i will check tomorrow

  19. #58
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Adding this in engine
    10w40 purchased it for PKR 2,200/- any comments about this .. is this a good oil ?

    Need help senior members Civic 95 stock engine -1645766

  20. #59
    Senior PakWheeler Follow
    Fahad.Ayub's Avatar
    Join Date
    Aug 2013
    Location
    Karachi
    Age
    21
    Posts
    1,959
    Follows
    3
    Following
    2
    Mentioned
    32 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    it would be a good time to get a new radiator along with a new T stat valve and new hose pipes and make the fan automatic
    make sure you leave no weak links

  21. #60
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Today i got the car.. Pick is awsome and engine is so smooth and quite... On petrol just presses the pedal and it start flying... Pulled the car till 140 today :-D .... Im getting one issue as per mechanic my carb is not good and i also faced this prob with old engine as well... On petrol my rpm is not stable... When we accelerate and release pedal rpm drops extremely low and car shut off.. When i turn off the car with key engine gives jerks for like 3-4 sec and then cmpltly off.... What will be the issue any idea and for how much i can get a new carb ?

+ Reply to Thread
Page 3 of 6 FirstFirst 12345 ... LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •