Survey by Qualaroo
+ Reply to Thread
Page 4 of 6 FirstFirst ... 23456 LastLast
Results 61 to 80 of 117
Like Tree5Likes

Thread: Need help senior members Civic 95 stock engine

  1. #1
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need help senior members Civic 95 stock engine

    @Xulfiqar
    @Maverickiz3d
    @metalhead

    Dear Brothers Assalam-O-Alaikum,

    Recently i have done car heater work and the mechanic told me to service the radiator so i went to tariq road and the guy opened my radiator.. my radiator was totally blocked...he advised me to change the jali of radiator in 2000rs... i said him ok change it after few time he came with another metal radiator and installed it.... we added 2 bottles of zic coolant and purge the air from cooling system. i drive back to home and car was making a lot of pressure... even the car parked whole night and in morning when i opened the cap to check water level some pressure throw out the coolant... i told him this and visit him he changed the radiator again with plastic one (Japani) he added tap water and told me to drive 2-3 days for checking purpose the come back and we will add coolant after flushing system.... the same day i drove the car from Tariq road to Nazimabad and temp was at c... i opened the radiator cap and water level was same and no pressure was build. Yesterday night i checked the water level it was fine.. checked engine oil it was orange type... every thing was fine i started the engine and went to board office from nazimabad and parked the car there temp was at notmal 15% due to low temp in night...after 2-3 hours when i went home i pulled the car in 3rd gear on petrol till 90kmh and then shifted 4th and 5th and maintained 80kmh after 1 min i saw the temp was rising fast... when i reached home i parked the car... idle RPM was set to 800 when i was pressing the peddle 800-1500 rpm car was jerking and engine vibrating badly... i got confused the time... i opened the radiator cap and it was empty... i opened and it was over filled i got no other water bottle at that time so i added the water to radiator from reservoir bottle and the whole reservoir bottle went inside radiator ... after few mins temp was totally down at 0% but car engine was jerking badly.. so i switched off the car and went home.. today morning i was going for office i checked engine oil... it was yellowish and creamy white and level is increased from its mark..... i opened radiator cap and there was no water i started adding water and 700ml water went inside radiator then i noticed that water was leaking from engine near manifold there was a bolt under upper hose pipe.... i didnt start the engine and leave it as it... as today is friday and mechanics are on holiday.... any senior or experienced can advise me what will be the issue in my case ??? my head gasket gone or water body ??

    Thanks.

    Similar Threads:

  2. #61
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    1
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ranker84 View Post
    Today i got the car.. Pick is awsome and engine is so smooth and quite... On petrol just presses the pedal and it start flying... Pulled the car till 140 today :-D .... Im getting one issue as per mechanic my carb is not good and i also faced this prob with old engine as well... On petrol my rpm is not stable... When we accelerate and release pedal rpm drops extremely low and car shut off.. When i turn off the car with key engine gives jerks for like 3-4 sec and then cmpltly off.... What will be the issue any idea and for how much i can get a new carb ?
    Congrats brother. I know the feeling. Dont push it too much after its an old engine ;-)

    Your engine is dieseling. When engine runs rich or engine is burning oil, it builds up carbon inside the cylinders which act as spark when hot. Any smoke out of exhaust? If yes, color of smoke?

    Another reason for dieseling is wrong adjusted carb. What is the idle rpm?

  3. #62
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No smoke from exhaust and idle was set to 800 but now rpm is dropped to very low around 100 i will take to mechanic... My old engine also did this after runing 300-400km on petrol it was got fixed... I filled up the tank to top... I will run it on petrol i hope it will get fixed... Also my mechanic have removed advance distributor vacum pipe he said that is not working.

  4. #63
    PakWheeler Follow
    Maverickiz3d's Avatar
    Join Date
    Jun 2010
    Location
    Karachi
    Age
    32
    Posts
    560
    Follows
    1
    Following
    1
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get the carb checked then. I havent researched much on it so cant tell possible problems which can be fixed.

  5. #64
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    My car spark plug cables dnt fit perfectly they are loose... Mechanic told me they are fine just take care when servicing the car.... Should i change them one guys asking 2000 for 4 cables how much they cost any idea ?

  6. #65
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Any one can advise me what is the price of spark plug cables for d15b exi efi engine

  7. #66
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by ranker84 View Post
    Adding this in engine
    10w40 purchased it for PKR 2,200/- any comments about this .. is this a good oil ?


    Need help senior members Civic 95 stock engine -1645766
    Bad choice of Honda d series are happy with api SG,sf grade oils

  8. #67
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Bad choice of Honda d series are happy with api SG,sf grade oils
    Dear Saboor

    Can you please advise me which one should i use if you post pic of shell or zic oil bottle will help me alot... I dnt knw much about these codes etc.

  9. #68
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I already added this in engine so what should i do now :-( pour it out will it make any damage ?

  10. #69
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by ranker84 View Post
    I already added this in engine so what should i do now :-( pour it out will it make any damage ?
    It won't harm in just first oil change but can harm your engine in long terms I used pour in PSO generator oil in flat tappet engine(funny ehh) available in 15w-40 and 10w-40 delo gold Is also excellent alternate

  11. #70
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ok bro i will search these

  12. #71
    Senior PakWheeler Follow
    ahmed2396's Avatar
    Join Date
    Dec 2011
    Age
    36
    Posts
    2,330
    Follows
    5
    Following
    1
    Mentioned
    55 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    7

    Default

    Quote Originally Posted by ranker84 View Post
    This was efi engine my mechanic fitted carb in it... Yeh on next change i will get zic or delo.
    So why didnt you buy a carb engine? what is the use of buying efi and slamming carb on it, it wont work on factory spec with desi jugar
    Your ego is writing cheques, your body can't cash.

  13. #72
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    We were unable to find such good condition it was like brand new and price was also reasonabke

  14. #73
    Senior PakWheeler Follow
    ahmed2396's Avatar
    Join Date
    Dec 2011
    Age
    36
    Posts
    2,330
    Follows
    5
    Following
    1
    Mentioned
    55 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    7

    Default

    Removing advance mechanism is not good put it bad and look up all vacum pipes are good and was this engine EFI or your mechanic slammed carb on it? This is a flat cam engine it needs Delo Gold Ultra 15W40 else ZIC 15W40
    Your ego is writing cheques, your body can't cash.

  15. #74
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ahmedraja1996 View Post
    Removing advance mechanism is not good put it bad and look up all vacum pipes are good and was this engine EFI or your mechanic slammed carb on it? This is a flat cam engine it needs Delo Gold Ultra 15W40 else ZIC 15W40
    This was efi engine my mechanic fitted carb in it... Yeh on next change i will get zic or delo.

  16. #75
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Maverick3d @saboor73

    My mechanic fitted efi assembly with carb... Will it make any probls ???

  17. #76
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by ranker84 View Post
    @Maverick3d @saboor73

    My mechanic fitted efi assembly with carb... Will it make any probls ???
    Yes it will thing like vaccum advanceer won't work

  18. #77
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    :-/ damn he told ne it will fork fine

  19. #78
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Self editted

  20. #79
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    All vacumes are working he installed old manifold

  21. #80
    PakWheeler Follow
    ranker84's Avatar
    Join Date
    Aug 2014
    Posts
    153
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes he has disabled the advance distributor vacum

+ Reply to Thread
Page 4 of 6 FirstFirst ... 23456 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •