Survey by Qualaroo
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 55
Like Tree4Likes

Thread: My Civic 2005 EXi giving bad fuel average, I need help.

  1. #1
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default My Civic 2005 EXi giving bad fuel average, I need help.

    Hi;

    I have recently bought a Honda Civic Exi Prosmatec model 2005. 160k kms done in original condition and sealed engine. The car has been running on petrol and never been on CNG.My driving style is usually very calm i.e. I hardly go above 2500 rpm and allow the gears to change quickly. Usually I drive by keeping rpm just under 2500 hence I cannot digest that civic should give just around 7 km/l in full tank ...what should i do..there also black carbon in silencer which shows that the car is drinking ppetrol


  2. #21
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Lot of petrolheads use deoo gold ultra in d series Honda engine and if manual transmission than se for gearbox too ( yes honda manual gearbox take engine oil)
    okay so how much oil gonna cost?

  3. #22
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by salman.95 View Post
    some times it goes down to C like Khyber that i previously owned but mostly in mid point
    Start engine when cold open radiator cap and see of coolant is moving if coolant is moving on dead cold engine you don't have a t.valve install one if missing

  4. #23
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Lot of petrolheads use deoo gold ultra in d series Honda engine and if manual transmission than se for gearbox too ( yes honda manual gearbox take engine oil)
    okay so how much oil gonna cost?

  5. #24
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by salman.95 View Post
    ive observed alot of smell comes inside the car whenever i topups the petrol and it remains for quite some time....but couldnt find any leakage
    Fuel smell on start engine?

  6. #25
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by salman.95 View Post
    okay so how much oil gonna cost?
    3k for 4 liters if I recall it right

  7. #26
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Start engine when cold open radiator cap and see of coolant is moving if coolant is moving on dead cold engine you don't have a t.valve install one if missing
    its radiator is also slightly rusted...will post picture of radiator nd engine...but engine apparently has no leakage of anything its dried...car has good pickup nd all .but the thing is its avg....nd loosening of grip at 90...the steering wheel and car starts shivering

  8. #27
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Fuel small on start engine?
    yes fuel smell comes...like smell of KACHA PETROL....nd dry carbon in exhaust too...

  9. #28
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by salman.95 View Post
    yes fuel smell comes...like smell of KACHA PETROL....nd dry carbon in exhaust too...
    From engine bay?

  10. #29
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    no i guess it comes from the exhaust

  11. #30
    PakWheeler Follow
    junaid53's Avatar
    Join Date
    Apr 2012
    Location
    Islamabad
    Posts
    132
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.95 View Post
    which oil should i use?? and which plugs are best for it? should i go for synthetic oil/ ya koi b shell havoline..
    zic A+ BEST HA HONDA ENGINES KAY LIYA

  12. #31
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by junaid53 View Post
    zic A+ BEST HA HONDA ENGINES KAY LIYA
    Civic throttle body service done from showroom..
    Fuel pump and filter changed..
    All plugs new NGK,
    Tuning done.
    All Error removed from computer..only two were found MAp sensor nd another..but still there is jogging in car and very bad fuel avg..just 6 or 7 km/l..in full tank it does hardly 250 km

  13. #32
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Mirza967 View Post
    check plugs for carbon.....usually exhaust has some carbon in it......also check for CAT blockage......check for all the wheels for any deep resistance felt while rotating freely with hand.......if problem is not solved then check for any error codes.....if there are any try resetting the ecu.....after all this change your petrol station from where u fillup..moreover install thrmostat back if removed and make fan auto.
    Civic throttle body service done from showroom..
    Fuel pump and filter changed..
    All plugs new NGK,
    Tuning done.
    All Error removed from computer..only two were found MAp sensor nd another..but still there is jogging in car and very bad fuel avg..just 6 or 7 km/l..in full tank it does hardly 250 km

  14. #33
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by junaid53 View Post
    ap apni gari ka engine oil air filter ar spark plug saaf karo agr change hunay wala ha to change kar du ar apni gari may high octane use karo ek dafa atlest 20 liters ar tb dilwana jb petrol bilkul end pay hu ar mix mat karwana hight octne kay sat super ar cranke sensor b saaf kar wahu jb yea sari cheezain hoon jahain gi ap ka masala haal hu jahay ga umeedh ha
    Civic throttle body service done from showroom..
    Fuel pump and filter changed..
    All plugs new NGK,
    Tuning done.
    All Error removed from computer..only two were found MAp sensor nd another..but still there is jogging in car and very bad fuel avg..just 6 or 7 km/l..in full tank it does hardly 250 km

  15. #34
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    What was the other code? Did you change the MAP sensor with a new one? How long has it been since you last changed or cleaned the air filter? Did you buy BKR5E-11 as specified in the manual. What is the condition of your coils? Any cracks? Did you check whether you have a Thermostat valve and that it is operating properly?

    Sent from my GT-I9300I using Tapatalk

  16. #35
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    From engine bay?
    Civic throttle body service done from showroom..
    Fuel pump and filter changed..
    All plugs new NGK,
    Tuning done.
    new air filter
    All Error removed from computer..only two were found MAp sensor nd another..but still there is jogging in car and very bad fuel avg..just 6 or 7 km/l..in full tank it does hardly 250 km

  17. #36
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by hash4u View Post
    this model has no catalytic converter

    check and change 02 sensor if it has one
    (service throttle body/get tappets done etc)
    Civic throttle body service done from showroom..
    Fuel pump and filter changed..
    All plugs new NGK,
    Tuning done.
    All Error removed from computer..only two were found MAp sensor nd another..but still there is jogging in car and very bad fuel avg..just 6 or 7 km/l..in full tank it does hardly 250 km

  18. #37
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ahmmadrizwan View Post
    Calme at 03008898898
    i hv the solution. I was facing the same issue but now my Exi giving me 12km locally and 14.5 to 15 km on long. Without ac
    Civic throttle body service done from showroom..
    Fuel pump and filter changed..
    All plugs new NGK,
    Tuning done.
    All Error removed from computer..only two were found MAp sensor nd another..but still there is jogging in car and very bad fuel avg..just 6 or 7 km/l..in full tank it does hardly 250 km

  19. #38
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by sr107 View Post
    What was the other code? Did you change the MAP sensor with a new one? How long has it been since you last changed or cleaned the air filter? Did you buy BKR5E-11 as specified in the manual. What is the condition of your coils? Any cracks? Did you check whether you have a Thermostat valve and that it is operating properly?

    Sent from my GT-I9300I using Tapatalk
    i did change Air filter with a new one with all these..and dont knw about the second error code..no map sensor error code was removed later check after driving a mile then there was no error found...my driving style is also very calm under 2500 rpm

  20. #39
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by sr107 View Post
    What was the other code? Did you change the MAP sensor with a new one? How long has it been since you last changed or cleaned the air filter? Did you buy BKR5E-11 as specified in the manual. What is the condition of your coils? Any cracks? Did you check whether you have a Thermostat valve and that it is operating properly?

    Sent from my GT-I9300I using Tapatalk
    i did change Air filter with a new one with all these..and dont knw about the second error code..no map sensor error code was removed later check after driving a mile then there was no error found...my driving style is also very calm under 2500 rpm

  21. #40
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.95 View Post
    i did change Air filter with a new one with all these..and dont knw about the second error code..no map sensor error code was removed later check after driving a mile then there was no error found...my driving style is also very calm under 2500 rpm
    Do you, by any chance remember the other code? What about the other things I mentioned?

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •