Survey by Qualaroo
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 41 to 55 of 55
Like Tree4Likes

Thread: My Civic 2005 EXi giving bad fuel average, I need help.

  1. #1
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default My Civic 2005 EXi giving bad fuel average, I need help.

    Hi;

    I have recently bought a Honda Civic Exi Prosmatec model 2005. 160k kms done in original condition and sealed engine. The car has been running on petrol and never been on CNG.My driving style is usually very calm i.e. I hardly go above 2500 rpm and allow the gears to change quickly. Usually I drive by keeping rpm just under 2500 hence I cannot digest that civic should give just around 7 km/l in full tank ...what should i do..there also black carbon in silencer which shows that the car is drinking ppetrol


  2. #41
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.95 View Post
    i did change Air filter with a new one with all these..and dont knw about the second error code..no map sensor error code was removed later check after driving a mile then there was no error found...my driving style is also very calm under 2500 rpm
    Often the codes come back after a while, so scan your car again. If the error codes come again, then you need to do something about it. If it gives the MAP sensor code , replace it with a new one. A bad map sensor can cause low fuel efficiency. And if the second error comes back post the code here or you could check it yourself.

  3. #42
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    no i didnt change as mech said the error has been removed...i dont remember..my problem was bad avg nd jogging..that's why i went to him..nd i recent around 2 weeks ago changed the Air filter...nd yes i bought them he said they are the honda original NGK..before them i was aslo using NGK

  4. #43
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i dont remember about any cracks.didnt check that..ill check it..thermostat..ill check it..i guess there is a minor leakage in radiator as it reduces some water in 6 or 7 days...but couldnt find any leakage

  5. #44
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by sr107 View Post
    What was the other code? Did you change the MAP sensor with a new one? How long has it been since you last changed or cleaned the air filter? Did you buy BKR5E-11 as specified in the manual. What is the condition of your coils? Any cracks? Did you check whether you have a Thermostat valve and that it is operating properly?

    Sent from my GT-I9300I using Tapatalk
    somes times the temperature needle comes down from its midpoint...its happening frequently..now a days..every day it happends around 2 times

  6. #45
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.95 View Post
    somes times the temperature needle comes down from its midpoint...its happening frequently..now a days..every day it happends around 2 times
    I think your thermostat gets stuck when it opens. Take it out and test it yourself to be sure. When was the last time you flushed your cooling system?

  7. #46
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by sr107 View Post
    I think your thermostat gets stuck when it opens. Take it out and test it yourself to be sure. When was the last time you flushed your cooling system?
    how can i take it out and test it?? i didnt flushed in 2 years

  8. #47
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Although I'm pretty sure your thermostat needs changing but here's the way to check it.
    Your car must be cold when you do it, like leaving it overnight and the next morning it'll be stone cold.
    Get 2-3 cloths, a small bucket or donga and a 10 mm ring pana.
    1, Disconnect the negative battery terminal.
    2, In the following picture, the thermostat is under the big pipe. Place the cloths and donga/bucket under it so that the coolant falls into it and avoid spilling on the wires.

    my civic 2005 exi giving bad fuel average i need help -1683188

    3, Disconnect this sensor's clip. It will be towards the left.


    my civic 2005 exi giving bad fuel average i need help -1683190
    4, (Pic from the right) Remove the 2 bolts using a 10 mm pana. Now grab onto the pipe and pull it out.

    my civic 2005 exi giving bad fuel average i need help -1683189

    You'll immediately identify the thermostat. Take a picture of it to remember which side goes where.
    Take the thermostat out carefully.

    5, Use a pan, like the ones used to make tea, pour water in it so that it would submerge the thermostat completely. *Take precaution and don't 'exactly' tell your wife or mother what you're doing *
    Turn on the fire, put the pan on it. Wait for the water to reach around 50?C and put the thermostat in using a wire or a chimta(tong). Make sure fire is ample to get the water boiling. Once water reaches 76-80?C it will start to open. At 90?C it should be fully open. Let it stay there for a while and then take it out. If it doesn't close then the temp drop is because of the thermostat.
    Now, you said it happens 1-2 times a day so repeat step 5 a couple times if it doesn't get stuck the first time and just to be sure that it's the problem.

    When you replace the thermostat with a new one, replace the gasket as well, it comes separately. Once you install the thermostat, bleed out the air by squeezing that pipe while the radiator cap is open. Pour coolant or distilled water as the level drops. Reconnect the connecter. Start your car and let it idle to see whether the temp needle doesn't go too high.
    And please flush your cooling system too with the thermostat removed so that there can be more flow.

    Note: If you feel hesitant in doing this you can always go to the dealership or any other trustworthy mechanic.

    I hope this will help you and if I've written something wrong, other members feel free to correct me.

  9. #48
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hmmm... Pictures aren't loading for some reason. @salman.95 pm me your number so that I can send them to you.

  10. #49
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.r107 View Post
    Hmmm... Pictures aren't loading for some reason. @salman.95 pm me your number so that I can send them to you.
    https://www.facebook.com/Muhammadsalman95

  11. #50
    PakWheeler Follow
    junaid53's Avatar
    Join Date
    Apr 2012
    Location
    Islamabad
    Posts
    132
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.95 View Post
    Civic throttle body service done from showroom..
    Fuel pump and filter changed..
    All plugs new NGK,
    Tuning done.
    All Error removed from computer..only two were found MAp sensor nd another..but still there is jogging in car and very bad fuel avg..just 6 or 7 km/l..in full tank it does hardly 250 km
    ha uska map sensor b saaf karwa lo ar ais model may ek ar b problem a hi hay in ka ptrol tank ek dusary say change ha matlb kisi may ziadha dalta ha kisi may kam dalta ha kisi may tank chota aya hay kisi may bara company ki taraf say ar ek aur kam ap petrol lid open karo ae dekhu jo petrol cap ha uskay sat hi koi hole ya koi black colour ki koi ruber to ni lagi hwi agr koi aisi bat hay to ais ka matlb ha aismay cng lagi hwi thi agr to aisa hay phr bht mushkil hay average nikalna q kay honda kay engines kay liya cng zehar ha engin khatam hu jata ha ar ap kay model ki jo original average ha wo 9 ya 10 km per litter hay prosmatic may

  12. #51
    PakWheeler Follow
    junaid53's Avatar
    Join Date
    Apr 2012
    Location
    Islamabad
    Posts
    132
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    arapni gari ha fuel pump ar fuel injector b check kar wa lo

  13. #52
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by junaid53 View Post
    ha uska map sensor b saaf karwa lo ar ais model may ek ar b problem a hi hay in ka ptrol tank ek dusary say change ha matlb kisi may ziadha dalta ha kisi may kam dalta ha kisi may tank chota aya hay kisi may bara company ki taraf say ar ek aur kam ap petrol lid open karo ae dekhu jo petrol cap ha uskay sat hi koi hole ya koi black colour ki koi ruber to ni lagi hwi agr koi aisi bat hay to ais ka matlb ha aismay cng lagi hwi thi agr to aisa hay phr bht mushkil hay average nikalna q kay honda kay engines kay liya cng zehar ha engin khatam hu jata ha ar ap kay model ki jo original average ha wo 9 ya 10 km per litter hay prosmatic may
    yes there is hole...CNG pehly lgi thi car me...owner said k 2010 me lgwai thi phr nikal di thi....fuel pump 3s dealership ne change kea tha but wo kharab tha ab monday ko new lga kr dengy..

  14. #53
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by junaid53 View Post
    ha uska map sensor b saaf karwa lo ar ais model may ek ar b problem a hi hay in ka ptrol tank ek dusary say change ha matlb kisi may ziadha dalta ha kisi may kam dalta ha kisi may tank chota aya hay kisi may bara company ki taraf say ar ek aur kam ap petrol lid open karo ae dekhu jo petrol cap ha uskay sat hi koi hole ya koi black colour ki koi ruber to ni lagi hwi agr koi aisi bat hay to ais ka matlb ha aismay cng lagi hwi thi agr to aisa hay phr bht mushkil hay average nikalna q kay honda kay engines kay liya cng zehar ha engin khatam hu jata ha ar ap kay model ki jo original average ha wo 9 ya 10 km per litter hay prosmatic may
    yes there is hole...CNG pehly lgi thi car me...owner said k 2010 me lgwai thi phr nikal di thi....fuel pump 3s dealership ne change kea tha but wo kharab tha ab monday ko new lga kr dengy..

  15. #54
    PakWheeler Follow
    salman.95's Avatar
    Join Date
    Aug 2014
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.r107 View Post
    Do you, by any chance remember the other code? What about the other things I mentioned?
    Found these Error in My Civic Exi 2005 Petrol

    10-02 IAT SENSOR
    (PO CIRCUIT HIGH
    113) VOLTAGE

    today again ive put her on computer

  16. #55
    PakWheeler Follow
    salman.r107's Avatar
    Join Date
    Jun 2015
    Posts
    125
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salman.95 View Post
    Found these Error in My Civic Exi 2005 Petrol

    10-02 IAT SENSOR
    (PO CIRCUIT HIGH
    113) VOLTAGE

    today again ive put her on computer
    Was this the other code you were talking about? Before changing the sensor check a couple of things.
    1, Is your air filter dirty. If yes, then clean it or replace it needs to be.
    2, Check whether the iat is where it should be and is connected
    3, Connect the scan tool and check what temp reading the iat is giving. If it's too high or too low e.g around 200?C or -20?C. Then you can suspect it to be the problem.
    4, Check to see whether there is damaged wiring at and near the connector. If yes, then replace that portion.
    5, While the obd2 and iat is connected, shake the connector wires and check for an abrupt change in temperature value. If they do, then check the connector wires. Make sure not to damage the wires yourself.
    6, With the iat disconnected bypass the connector wires using any external wire, if the temp shoots up around 200?C then your connector is ok. If not, then your wiring will be bad. Make sure not to damage the connector terminal or they will damage the sensor terminals aswell.
    You can look into this issue more yourself. If the wires and connectors are ok, then change the iat. Ask the Honda guys to use the new sensor on a trial basis. Before changing it, clear the codes.

+ Reply to Thread
Page 3 of 3 FirstFirst 123

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •