Survey by Qualaroo
+ Reply to Thread
Results 1 to 3 of 3

Thread: 8th gen, fuel injectors not getting electricity

  1. #1
    PakWheeler Follow
    usmantahirr's Avatar
    Join Date
    Dec 2015
    Location
    Lahore
    Age
    23
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default 8th gen, fuel injectors not getting electricity

    4 days back, my car was running little underpowered, and suddenly it started running even more. I thought my spark plugs are gone, I went to workshop and asked them to change my spark plugs and tune the car.

    Next day he said, your fuel pump's motor gone bad. We have to change it. I said ok, kr du

    He tried starting but instead car started blowing and white smoke came out of engine. They opened head and said wals of head are gone bad, we have to change them, and gasket is also bad. After all this mess, when they tried to start car, fuel injectors stopped getting current.

    What all this happened? What Mechanic is trying to do? My car never ever had any electronic problem. How can this problem be produced? Mechanic done something wrong while tuning or cleaning throttle body?

    Please help

    Sent from my Nexus 5 using PW Forums mobile app

  2. #2
    Senior PakWheeler Follow
    incognito59's Avatar
    Join Date
    Sep 2006
    Location
    Lahore
    Age
    57
    Posts
    3,177
    Follows
    1
    Following
    0
    Mentioned
    41 Post(s)
    Tagged
    16 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Take your car to a 3S workshop

    Sent from my KIW-L21 using PW Forums mobile app
    life is but wheels!

  3. #3
    Senior PakWheeler Follow
    ashbal's Avatar
    Join Date
    Sep 2006
    Location
    Lahore
    Age
    22
    Posts
    2,076
    Follows
    1
    Following
    0
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    It could have been just a choked catalytic convertor that caused the problem in the firstplace...its a 1.8 car even if engine geats weak you will feel only slight difference in power wont even make a difference


    Sent from my iPhone using PW Forums
    M @ c!v!c '95 L0v3&

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •