Survey by Qualaroo
+ Reply to Thread
Results 1 to 6 of 6

Thread: Civic 95 Speed Meter Stopped ...!

  1. #1
    a_k
    a_k is offline
    Senior PakWheeler Follow
    a_k's Avatar
    Join Date
    Feb 2005
    Location
    Karachi
    Age
    39
    Posts
    2,012
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Civic 95 Speed Meter Stopped ...!

    My Civic 95, speedo meter has suddenly stopped functioning, we had discussed the same some time ago, I cant find the thread, please suggest what sould I do??
    by the way the needle some time jumps to 160km/h even when the car is around 40km/h !!
    If better were within, better would come out.

  2. #2
    PakWheeler Follow
    faisi001's Avatar
    Join Date
    Apr 2007
    Location
    london
    Age
    36
    Posts
    533
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    salam,

    how are you? well coming to the point i had the similar prob with my townace 96 model . the problem was with the unit attached to the gear as in my car the meter was electric as in no cable only wires what we call digitally controlled. if the other function on your speedometer are working properly as in rpm meter gauges and lights then im sure that is the only prob as the transponder might be damaged and is not sending out the right signal to the speedometer and it jumps and please do check the connections of the transponder on the gear and if byany chance you have the cable type meter then please check the speedometer garari in the gear which will be bolted on the gear....
    if all these things are ok then go to the local electrician ask him to open ur speedometer and get it replaced from bilal ganj as i dont think the electricians wud be able to fix it if its digital.....
    im sure its a small prob nothing to worry abt u just need to spend 2 hrs on it which is not a good idea in this summer
    very hot
    salam i hope this wud help
    HAPPINESS INCREASES AND SADNESS DECREASES WHEN SHARED......

  3. #3
    PakWheeler Follow
    rizwanf's Avatar
    Join Date
    Dec 2006
    Location
    Lahore
    Age
    31
    Posts
    306
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    next time , wenever the needle jums to 160 kmph , take a pic and post it on pakwheels

    no need of lifting ur car on jack
    -

  4. #4
    PakWheeler Follow
    nadan_don88's Avatar
    Join Date
    Jun 2007
    Location
    Sialkot
    Age
    28
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    may be a wire circiut u should change the wire.
    the thing i want is to find sialkoty member,s@pakwheels.com plz help me to do so - naveed4speed

  5. #5
    Senior PakWheeler Follow
    robin's Avatar
    Join Date
    Jun 2005
    Location
    Islamabad
    Posts
    2,825
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    in ur case, speedo is goverened mechanically from the transmission box so u'd better check the speedo cable especially the link where it connects with trans. its gears might ve play or are free. is there any visible leakage on that linkage.

  6. #6
    a_k
    a_k is offline
    Senior PakWheeler Follow
    a_k's Avatar
    Join Date
    Feb 2005
    Location
    Karachi
    Age
    39
    Posts
    2,012
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I've visited a mechanic he say may the sprocket is damaged that is connected to gear box coz all other meters, lights etc are functioning properly

    Any way thanx for the help
    If better were within, better would come out.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •