Survey by Qualaroo
+ Reply to Thread
Results 1 to 11 of 11

Thread: problems in the engine (turbo civic)

  1. #1
    Senior PakWheeler Follow
    ahad_civic's Avatar
    Join Date
    Nov 2004
    Location
    Bhan saeedabad
    Age
    24
    Posts
    5,147
    Follows
    3
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default problems in the engine (turbo civic)

    i got a f** ihi rhb5 turbo for my d17 a few days back and got it rebuilt but sadly it didnt work out, the turbo gave me around 3-4 psi and spooled up at 4k rpm with all these f*** up sounds prior to spooling up, overall it was totally messed up and i just had it on for the heck of it, it wasnt even tuned

    now a few days back i was out on a cruise and suddenly out of no where the turbo just stopped making a sound, it was dead silent and the exhaust started emmiting even more smoke than it did before, so i still drove around for an extra 10-15 km, and not to forget the turbo was hardly 35-40 km driven overall in the two weeks it was on

    then for the next two days i had it parked and didnt start it, on the third day i started it and it started up, giving the usual smoke, didnt rev it up, just kept it on idle for around 2-3 minutes before it shut down it self and never started up again

    when i try starting it, it doesnt start up as if theres a problem in the plugs


    so what could it be? f** turbo+excesive amounts of smoke+plus no sound what so ever=???

    should i worry about a blown motor? cuz i havent taken it above 4k rpm, and besides a motor blows right at the spot , right?
    Reliable, Fast, Cheap....Pick two

  2. #2
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,363
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    this will answer everything!

    http://www.turbotechnics.com/docs/turbo/tips.htm
    Life is short and very unpredictable just like a Quarter mile .....

  3. #3
    Senior PakWheeler Follow
    ahad_civic's Avatar
    Join Date
    Nov 2004
    Location
    Bhan saeedabad
    Age
    24
    Posts
    5,147
    Follows
    3
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thnks hashim bhai!

    any more help?
    Reliable, Fast, Cheap....Pick two

  4. #4
    Senior PakWheeler Follow
    kiani1's Avatar
    Join Date
    Jan 2005
    Location
    Rawalpindi
    Age
    27
    Posts
    3,238
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Another possibility is that the turbine broke to pieces and was fed to your engine !

    Heard that if turbo's break up, they might end up in ur engine !

    Do get it checked up from some expert b4 further tries. And remove the turbo pipe from the manifold and then try starting.
    B2 Innovations - Events & Media Managers

    http://www.facebook.com/group.php?gid=129332754507

  5. #5
    Senior PakWheeler Follow
    wasay_ahmed's Avatar
    Join Date
    Nov 2006
    Location
    Lahore
    Age
    29
    Posts
    4,959
    Follows
    3
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro
    Your turbine must be giving oil Open the Induction Pipe and have a look if it has Mobil oil then you are in a bit trouble.I have a practical cure for it first confirm if it has happened
    DIY The Best Workshop on the Holy Planet!
    Every thing changes,Its only the "change" which never changes.

  6. #6
    Senior PakWheeler Follow
    wasay_ahmed's Avatar
    Join Date
    Nov 2006
    Location
    Lahore
    Age
    29
    Posts
    4,959
    Follows
    3
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro amd tht cure is DIY but with some patience
    DIY The Best Workshop on the Holy Planet!
    Every thing changes,Its only the "change" which never changes.

  7. #7
    Senior PakWheeler Follow
    ahsan1702's Avatar
    Join Date
    Mar 2006
    Location
    Karachi
    Age
    27
    Posts
    4,028
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Take off the boost pipe.

    Take out all the plugs and clean them. Take one out, attach the wire ... crank n see if its sparking (be careful though)

    Btw Ahad, colour of smoke ? Black or white ?
    1st Generation Integration

  8. #8
    N2O
    N2O is offline
    Senior PakWheeler Follow
    N2O's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Posts
    2,317
    Follows
    4
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    not again :O :|
    man its time u thought about an N/A engine
    knowledge is horsepower

  9. #9
    Senior PakWheeler Follow
    AusI's Avatar
    Join Date
    Nov 2004
    Location
    Karachi
    Age
    28
    Posts
    1,960
    Follows
    3
    Following
    0
    Mentioned
    20 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    NA is the way to go ...

    @ahad

    really sorry abt ur car ... try gtin it checked out frm an expert beofre checkin it urself ... atleast thts wat i would do ... best if luck tio u man .. !!

  10. #10
    Senior PakWheeler Follow
    ahad_civic's Avatar
    Join Date
    Nov 2004
    Location
    Bhan saeedabad
    Age
    24
    Posts
    5,147
    Follows
    3
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanks for all the helps bros!!

    @wasay, yah i think the turbo threw up some oil, there was oil on the floor as well, i havent chekd the oil as of yet to see if its dry or not, thanks to hpr my cars oil dipstick tip that lets u put ur finger in and take it out was broken

    @furrukh, we all like intercourse dont we? this shud sum it up

    i havent chekd the car out yet, ill give it over to hpr and see what happens
    Reliable, Fast, Cheap....Pick two

  11. #11
    PakWheeler Follow
    KillaMuf's Avatar
    Join Date
    Jul 2006
    Location
    Philadelphia/Karachi
    Age
    28
    Posts
    299
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hey man, one of my friends had the same problem couple of months ago, well almost the same....... only difference was that his car just shut off while he was driving, he said he heard minor sounds from the engine basically the turbo, it spat back oil in his engine and i think a piece of his turbine got in there tooo, was a huge mess.

    Well he had it coming to him, he was all untuned and running lean.....told him to take care of it but his a$$ was to lazy. lol

    Well good luck bro, keep us updated!
    Land Rover Series 3 88inch.......PakWheels FTW!!!

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •