Survey by Qualaroo
+ Reply to Thread
Results 1 to 18 of 18

Thread: Civic 2000 Dilemma (D16/PK6 Variant)

  1. #1
    PakWheeler Follow
    1JZGTE's Avatar
    Join Date
    Feb 2007
    Location
    Karachi
    Age
    31
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Civic 2000 Dilemma (D16/PK6 Variant)

    I bought a Civic 2000 VTi Oriel AT about a year back. The guy sold it to me with a busted engine so long story short I had to get it overhauled.

    Now after the overhauling, its not been able to perform completely normal condition, or maybe I'm being a perfectionist.

    There are a few things I have not been able to get under control despite putting a lot of money into the car. It could be because I'm not diagnosing the problem right or due to my mechanic's incompetence. I've taken second opinions in the matter but to no avail. Anyways I'm citing down the problems below and hope somebody's able to help me.

    1. After the overhaul, I've not been able to get it run on CNG with complete satisfaction. The RPM is always way too low at idle, around 500-700 RPM (temp at normal level) with the AC on. If I turn off the AC the RPM improves a bit by 100 RPMs. If I'm at a traffic signal with the car in still "D", the RPM drops wayy below to like 200-300 RPMS. Now I understand that at this moment the Transmission, the airconditioner, the brake master cylinders are all putting a substantial amount of load on the engine but I've driven other auto cars and none of them behave like this. Heck it never used to behave like this even before I got the overhaul. Now I've been to several CNG people, they've been able to fix this problem temporarily but it always returns after a few days.
    I have a sort of a feeling that during the overhaul process, some settings of the EFi have been distrubed which arent normally disturbed during CNG installation and because of this its behaving like this. So, can this be one of the reasons? If so what do I need to check.

    2. Secondly, the car's performance on petrol alot better as compared to CNG, but there is one thing that has bothered me. Sometimes the car's RPM goes up and down, from like 1000-1500 RPM. It does this two or three times and then settles down. Sometimes an anomaly occurs and it just stays up at 1500 RPMs.

    On CNG, the RPM doesnt do the up and down dance, but sometimes it goes to 1500 RPMs, stays there for a few seconds and the check light comes on. Now at this moment if I put my car into "D", the RPM drops to 500 RPM mark. If I switch off my car and start it again, it returns to normal.


    Personally I'm really baffled by these bizzare occurance of events. I possess some technical knowledge and am an engineer by profession, but so far I've not been able to sort out a solution.

    Please help me. I've spent alot of money on this car uptil now, and have yet to see a return.

    Thanks.

  2. #2
    Senior PakWheeler Follow
    Ghuncha's Avatar
    Join Date
    Aug 2005
    Location
    Islamabad
    Age
    35
    Posts
    5,967
    Follows
    2
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    sir all the symptoms point towards some faulty sensor.. experts over here can make some more sense out if it i guess.
    its all about power to weight ratio...

  3. #3
    Senior PakWheeler Follow
    spectra's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Age
    40
    Posts
    19,667
    Follows
    3
    Following
    0
    Mentioned
    303 Post(s)
    Tagged
    24 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You only have to check that air cleaner assembly is okay. Its getting air from some unwanted place. Its a common problem with this honda. Overhaul has nothing to do with all this.
    Keep a cool head and wear seatbelts!

  4. #4
    Senior PakWheeler Follow
    Waqar_14's Avatar
    Join Date
    Oct 2005
    Location
    here
    Age
    26
    Posts
    4,558
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I'd get a new engine if i were you. Overhauling D16s turns out to cost just a fraction cheaper than a new engine. Or that's what my mechanic told me.

  5. #5
    PakWheeler Follow
    Nasir_Zaidi's Avatar
    Join Date
    Apr 2005
    Location
    Karachi
    Age
    31
    Posts
    772
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @ 1JZGTE

    I have nothing to say about your topic nor I've any technical knowledge regarding faulty engines or sensors...

    Being a person who is fond of contributing articles and letters to different dailies from time to time, I am just writing these lines to appreciate the communication skills you possess.

    Take care
    Drive slowly and attentively! It's the only solution to avoid severe on-road accidents.

  6. #6
    Senior PakWheeler Follow
    spectra's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Age
    40
    Posts
    19,667
    Follows
    3
    Following
    0
    Mentioned
    303 Post(s)
    Tagged
    24 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I second that. Its a rare trait in engineers
    Keep a cool head and wear seatbelts!

  7. #7
    PakWheeler Follow
    1JZGTE's Avatar
    Join Date
    Feb 2007
    Location
    Karachi
    Age
    31
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ghuncha
    If there was a faulty sensor I would be getting engine check light continuously.

    spectra
    You know, thats what I've been thinking too. Any ideas where I can start looking?

    And thank you .

    Waqar_14
    If I only I would've found you sooner . No you're right, a new engine would've been a better choice and cheaper too in the long run, but at that moment I was a bit preoccupied than to go looking for an engine.

    Nasir_Zaidi
    Thank you.

  8. #8
    611
    611 is offline
    Site Banned Follow
    611's Avatar
    Join Date
    Sep 2006
    Location
    Lahore
    Age
    36
    Posts
    200
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I would suggest to clean the iacv valve and the choke at the bottom of throttle body.

    If the problem still persists then get the tappets adjusted to a little loose setting.

    Also find a good cng station with good pressure and try to stick to the same pump.

  9. #9
    PakWheeler Follow
    1JZGTE's Avatar
    Join Date
    Feb 2007
    Location
    Karachi
    Age
    31
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @611

    Mileage has not been a big issue. I get 90+ kms/cyliner on a 55Ltr cylinder with AC, and also keeping in mind the car's automatic. The whole EFi unit has been serviced two or three times, the throttle body serviced, tappits adjusted many times to factory spec and other settings but to no avail. I really dont think tappits have anything to do with the pressures dropping at idle. These days things are so bad that the car just stalls. When at a stop light I have to switch off the AC to take load off and prevent stalling.

  10. #10
    Senior PakWheeler Follow
    wasifali89's Avatar
    Join Date
    Aug 2006
    Location
    Dubai
    Age
    26
    Posts
    5,077
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i dont think there is any of these issues related to engines overhaull



    u need to see a good mechanic
    i mean an experienced person
    not the electronic junkys
    (1)Austin of England, a35, 1958, 850cc,,, (2) Mercedes benz , w202, C - 180 ,,, (3) 2003 HONDA CITY,,,, (4) Triumph TRW 500cc, 1952,,,,

  11. #11
    Senior PakWheeler Follow
    spectra's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Age
    40
    Posts
    19,667
    Follows
    3
    Following
    0
    Mentioned
    303 Post(s)
    Tagged
    24 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Its mixture fluctuation definitely. You can start looking from ventury insertion point. Also i think kit is placed far from ventury.
    Keep a cool head and wear seatbelts!

  12. #12
    PakWheeler Follow
    haroon131's Avatar
    Join Date
    Aug 2005
    Location
    Karachi
    Age
    31
    Posts
    299
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    same problem with my VTi Oriel, but solved now
    first of all service ur idle controller and
    then go to CNG tunning and ask for tunning and adjust your rpm on cng like 800, i m pretty sure the engin check problem will not come , btw if u check this error, i t gives 17 which is of Speed sensor, as ur speed o meter is working fine..

  13. #13
    PakWheeler Follow
    termiii's Avatar
    Join Date
    May 2005
    Location
    Karachi
    Age
    31
    Posts
    134
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @IJZ

    Ure car might be giving a code but check engine might not be coming on. Get it checked by ure electrician to see which code is comin on (usually done by jumpering a switch near the ecu and the check light flashs)

    ull find a list of codes easily on the net and how to read them.

    The check engie only comes on wen therez a serious issue. for other miscelaneuous codes therez only this other wa 2 check. solve all ure codes on by one and im sure all ure probs will be solved.. at least thts wat i did wid my pk6

  14. #14
    PakWheeler Follow
    gunshippilot's Avatar
    Join Date
    Aug 2006
    Location
    Lahore
    Age
    43
    Posts
    610
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    as far as engine cx light is concerned i have personally experienced it......
    * Get the timing wire checked it is hidden in the timing belt cover.
    Its a very delicate wire, although it has plastic cover before it enters the timing belt cover,
    But there are all the more chances of this belt being cut / damaged by hydraulic pump belt or any other belt in that area.

    Behaviour of the car: the wire makes and brakes and so does the the light.

    * There is yet another wire which is linked with air cleaner and it is very exposed. It is on the left of tappet cover almost in the middle distance.

    * Must cx it that an additional wire is wrapped on all the ignition wires and subsequently wrapped on the electric current wire of CNG kit. if it is not there must get it installed it provides extra current during high electric load conditions.
    * some time the advancer fails get it checked and do install 4 tip bosch plugs for better pick up and idle running.

    And as far as engine cx is concerned dont bother much as i drove my 2000 civic for about 6 months, while i was busy in hit and try about my problems.
    Good luck
    Flying is my passion.

  15. #15
    Senior PakWheeler Follow
    Suzuki1's Avatar
    Join Date
    Jun 2005
    Location
    Melbourne,Karachi
    Age
    35
    Posts
    1,458
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    this prob is mainly happen when u unplug ur cars air sensor so do check that if its taking some air or its seals are not fitted right after checking these thing find some good mechanic who can tune EFI cars then tune ur car tune it on petrol if its run perfect on petrol then ur CNG mechanic can adjust it on CNG to
    Ford GTP supercharged 305 V8, Commodore SS

  16. #16
    Senior PakWheeler Follow
    aantherax's Avatar
    Join Date
    May 2006
    Location
    Karachi
    Age
    33
    Posts
    3,032
    Follows
    1
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    1JZGTE
    I have no idea where you live but if you ever heard of Yaseenabad GraveYard there is a workshop by the name of Shamim CNG they have all the computer scanning setup and all the latest equipments i m 100 % sure that your problem will be solved go there and meet Mr. Waseem he is there in night shifts (workshop operates 24/7) from 10pm to 10am. He'll charge you a bit more then all your CNG technicians did but sure will rectify your problem. You can use my reference my name is Wara.
    ~ Be a responsible citizen and always drive safely ~

  17. #17
    PakWheeler Follow
    1JZGTE's Avatar
    Join Date
    Feb 2007
    Location
    Karachi
    Age
    31
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    OK, so I had the IAC sensor taken out, cleaned and reinstalled. But this didnt improve much. I'm still facing the same problems. Could there be a problem with the sensor's stepper motor? I'll try swapping it with another sensor. Also, other than IACV, what other sensor could cause this problem?

  18. #18
    Senior PakWheeler Follow
    tauseefmutwahir's Avatar
    Join Date
    Oct 2006
    Location
    Peshawar / Knoxville, TN
    Age
    33
    Posts
    1,298
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @1jz

    do one thing 1st and foremost.
    take the ventury and related parapharnelia of the cng out. and run your car ONLY on petrol without the pipes and fittings of the cng.

    now you will know if the problem is caused in both petrol or cng mode. its difficult to diagnose an engine if it dosent throw a check engine light and code.

    do this 1st and see if your car improves, take all the fittings out and run it like that 1st and then see if it makes any difference.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •