Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 34
Like Tree3Likes

Thread: Urgent-Altis check engine light on

  1. #1
    PakWheeler Follow
    husnain5's Avatar
    Join Date
    Nov 2010
    Location
    Sialkot
    Age
    24
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Urgent-Altis check engine light on

    salam dear fellows today i got my car serviced as it had done 20000kms and oil,filter,air filter and spark plugs,transmission fluid was also checked checked and the technician also check the car with I-T computer and everything was perfect and i am using my car on petrol no CNG i got it serviced from toyota gujranwala and when i came to sialkot and got the petrol filled of rs500 from askari pump(shell) after driving some kilometers engine check engine light came on and a message was being shown on meter that check engine system please advice me that this light is turning on due to any electical fault or petrol as light turn on after filling the petrol please help? thanx

    please remember my car is cruisetronic

    there was no change in acceleration,no over heating or any thing else while check light is on but about smoke i m not sure as i haven't note that!


  2. #2
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    scan it - it'll show up the problem.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  3. #3
    PakWheeler Follow
    honrolla's Avatar
    Join Date
    Feb 2008
    Location
    Karachi
    Age
    37
    Posts
    699
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    go back to toyota can be anything better to get a OBD scanner verdict from toyota - can be anything from a lose sensor connector to faulty O2 etc.

    since it happened on CNG - i am not very sure - not a cng person.

  4. #4
    PakWheeler Follow
    husnain5's Avatar
    Join Date
    Nov 2010
    Location
    Sialkot
    Age
    24
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    scan it - it'll show up the problem.
    you mean i should again scan it with a I-T computer?

  5. #5
    PakWheeler Follow
    husnain5's Avatar
    Join Date
    Nov 2010
    Location
    Sialkot
    Age
    24
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by honrolla View Post
    go back to toyota can be anything better to get a OBD scanner verdict from toyota - can be anything from a lose sensor connector to faulty O2 etc.

    since it happened on CNG - i am not very sure - not a cng person.
    bro my car is not on CNG it's on petrol from very first day

  6. #6
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    scan it fromt the OBD port under the dashboard. Any workshop owning a scanner can do it.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  7. #7
    PakWheeler Follow
    nadir1's Avatar
    Join Date
    Feb 2010
    Location
    Mardan
    Age
    26
    Posts
    39
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    take out both the terminals from batery then give it back

  8. #8
    PakWheeler Follow
    husnain5's Avatar
    Join Date
    Nov 2010
    Location
    Sialkot
    Age
    24
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    scan it fromt the OBD port under the dashboard. Any workshop owning a scanner can do it.
    yes man OBD port is on driver side where computer is attached tomorrow also i will again get it checked from same dealer

  9. #9
    PakWheeler Follow
    hassnainsethi89's Avatar
    Join Date
    May 2010
    Location
    Peshawar
    Age
    26
    Posts
    359
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check out the any electric cable is not out of its place

  10. #10
    PakWheeler Follow
    husnain5's Avatar
    Join Date
    Nov 2010
    Location
    Sialkot
    Age
    24
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by nadir1 View Post
    take out both the terminals from batery then give it back
    regarding taking out the both terminals i m not sure that it would solve the problem but many times i restarted he engine the light was still there

  11. #11
    129
    129 is offline
    PakWheeler Follow
    129's Avatar
    Join Date
    Jul 2007
    Location
    Lahore
    Age
    28
    Posts
    460
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    There might be problem with any sensor, get your car scanned and your problem will be solved. One of my car's check light came on and the problem was defective O2 sensor and my car is on petrol
    S65 "AMG" ( LUXURY WITH POWERHOUSE )
    ^^my power of dreams ^^

  12. #12
    PakWheeler Follow
    husnain5's Avatar
    Join Date
    Nov 2010
    Location
    Sialkot
    Age
    24
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by 129 View Post
    There might be problem with any sensor, get your car scanned and your problem will be solved. One of my car's check light came on and the problem was defective O2 sensor and my car is on petrol
    thanx bro by the way if O2 sensor is damage will it be replaced free or at owners expense because car is in under warranty and by the which was you car?

  13. #13
    PakWheeler Follow
    Devastator's Avatar
    Join Date
    May 2009
    Location
    Riyadh
    Posts
    421
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by husnain5 View Post
    yes man OBD port is on driver side where computer is attached tomorrow also i will again get it checked from same dealer
    it happens when a sensor detects malfunctioning, or itself malfunctions, not necessarily a big issue, but yes, only the scanner will tell the final verdict as to what the problem is!
    the battery just resets the ecu, that is done only when the ecu is goin buzzerg, you have a new car better get it scanned and find the problem!

  14. #14
    PakWheeler Follow
    changwani54's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    370
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    First try what "nadir1" wrote.. I ain't a technical person so can't comment what might the problem be.. However my father's xli had this kind of issue of check engine light 3 months ago.. Mechanic took of the battery terminals for 5 min, then put them back and problem was gone.. No problem again till now.. Try it, if doesn't work then get it scanned..

  15. #15
    Senior PakWheeler Follow
    mani1's Avatar
    Join Date
    Mar 2006
    Location
    Islamabad
    Age
    30
    Posts
    4,524
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No one can help you here. Just go to Toyota and ask them to check everything on OBD. Only then will you be able to find the problem otherwise everyone here is shooting arrows in the dark and the more replies you see here, more worried you will get

  16. #16
    PakWheeler Follow
    Devastator's Avatar
    Join Date
    May 2009
    Location
    Riyadh
    Posts
    421
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    the o2 sensor really is the most common sensor to blow off, strange!

  17. #17
    PakWheeler Follow
    fairleo's Avatar
    Join Date
    Sep 2006
    Location
    Pak pattan sharif
    Age
    33
    Posts
    279
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    try removing batry terminals..

    it works most of the time..

  18. #18
    PakWheeler Follow
    husnain5's Avatar
    Join Date
    Nov 2010
    Location
    Sialkot
    Age
    24
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanx to Devastator,changwani54,fairleo,mani1 all others tomorrow i will be taking car to toyota guys but then also ideas and techniques are welcome so that better results can be found

  19. #19
    Senior PakWheeler Follow
    mani1's Avatar
    Join Date
    Mar 2006
    Location
    Islamabad
    Age
    30
    Posts
    4,524
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by husnain5 View Post
    thanx to Devastator,changwani54,fairleo,mani1 all others tomorrow i will be taking car to toyota guys but then also ideas and techniques are welcome so that better results can be found
    No ideas or techniques would work as everything is electronic in your car and if its an electronics issue it would come up on OBD. The only idea/tip that you need is to ensure that some expert mechanic hooks up the OBD who knows how to operate and read different functions on the device. I have come across a couple of mechanics in Lahori dealerships who knew nothing except how to operate a single button scan

  20. #20
    jz
    jz is offline
    Senior PakWheeler Follow
    jz's Avatar
    Join Date
    Dec 2004
    Location
    Lahore
    Age
    2
    Posts
    26,106
    Follows
    5
    Following
    0
    Mentioned
    185 Post(s)
    Tagged
    12 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    disconnect the batery n reconnect it,see if it helps.
    www.facebook.com/performancepartslahore

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •