Survey by Qualaroo
+ Reply to Thread
Results 1 to 16 of 16

Thread: Need urgnet help (Toyota corolla 2010 GLi)

  1. #1
    PakWheeler Follow
    kingvirgo80's Avatar
    Join Date
    Dec 2011
    Location
    Islamabad
    Age
    26
    Posts
    35
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need urgnet help (Toyota corolla 2010 GLi)

    Salam brothers..
    Today i Faced very weird problem in my Corolla gli 2010 it never happend before...
    Rpm ups and down on petrol 800 to 500 and 500 to 800 (needle moving very fast here)and on road when i push the brake and then clutch to stop car then rpm turns to zero and car shutdown...
    last tuned it at 39000km from garage master
    42000 km driven
    Cng fitted... mostly driven on cng







  2. #2
    PakWheeler Follow
    kingvirgo80's Avatar
    Join Date
    Dec 2011
    Location
    Islamabad
    Age
    26
    Posts
    35
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    anyone ?????

  3. #3
    PakWheeler Follow
    revengez's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    There can be several reasons of such behaviour.

    Check engine light ON or OFF ??? Is the issue on petrol also or just CNG?

  4. #4
    PakWheeler Follow
    zohaibshk's Avatar
    Join Date
    Jan 2008
    Location
    Karachi
    Age
    29
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It's either the advancer, air filter or tunning problem.. get ur advancer checked.. change ur air filter if you havent done it for quite a while now... n change the spark plugs..
    I hope the problem gets solved..

  5. #5
    PakWheeler Follow
    revengez's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by shaikhzohaib20 View Post
    It's either the advancer, air filter or tunning problem.. get ur advancer checked.. change ur air filter if you havent done it for quite a while now... n change the spark plugs..
    I hope the problem gets solved..
    RPM should be stable even if U remove advancer. There must be some other reason.

  6. #6
    Senior PakWheeler Follow
    Naweed's Avatar
    Join Date
    Jul 2008
    Location
    Karachi
    Age
    50
    Posts
    3,469
    Follows
    12
    Following
    0
    Mentioned
    122 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I think this link will give you an idea of where to look for
    to rectify the fault
    Tech - Idle
    "You have not lived today until you have done something for someone who can never repay you."

  7. #7
    PakWheeler Follow
    smokin's Avatar
    Join Date
    Mar 2008
    Location
    Muzaffargarh
    Age
    27
    Posts
    386
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    the main issue with new model on CNG is of unstable RPM and if u want to keep ur engine good u have to fix ur tepid they get jammed after every 40 k kilometres ask ur mechanic if it is the issue with ur car some time the mechanic reset ur ECU to stable ur RPM or raise ur RPM by the presure of CNG and it ll work for the time being but u ll face that issue soon to prvent engine do check ur tepid

  8. #8
    PakWheeler Follow
    zohaibshk's Avatar
    Join Date
    Jan 2008
    Location
    Karachi
    Age
    29
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by revengez View Post
    RPM should be stable even if U remove advancer. There must be some other reason.
    Yaar, I ve faced this kinda problem before.. my mechanic changed the advancer n the RPM got stabled .. i was just sharing my experience.. n that happened to my civic.. my corolla behaved like that when it had some oil filter n intake problem

  9. #9
    Senior PakWheeler Follow
    ussi's Avatar
    Join Date
    Nov 2010
    Location
    Hyderabad
    Age
    27
    Posts
    3,159
    Follows
    0
    Following
    0
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    my idsi behaved the same, after changing advancer and emulator it was fine, if u plan to change the stuff then go for original landirenzo advancer and emulator, others only last for 2,3 months
    Ministry of MAFIA!

  10. #10
    PakWheeler Follow
    kingvirgo80's Avatar
    Join Date
    Dec 2011
    Location
    Islamabad
    Age
    26
    Posts
    35
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanks alot brothers for quick responce...
    -I put new air filter before 2 months..
    -I get tunning done after evry 5000km...
    -Its only occurs on PETROL not on CNG...
    -NO engine light pops
    -spark plugs are good
    -pick is good


    -It never happaned before on PETROL or CNG 43000km driven now,,
    -othee things in mind please tell me em thinking may be its because of throttle body needs service..
    - and tell me about tapets?
    -and my kit is landirenzo..

    thanks



  11. #11
    Senior PakWheeler Follow
    PKTUN's Avatar
    Join Date
    Oct 2011
    Location
    Khuzdar
    Posts
    1,067
    Follows
    1
    Following
    0
    Mentioned
    35 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bhai jan problem ap ki car k ignition timing ka hai 100% CNG kit ka emulator function theek nahi hai

  12. #12
    PakWheeler Follow
    revengez's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by shaikhzohaib20 View Post
    Yaar, I ve faced this kinda problem before.. my mechanic changed the advancer n the RPM got stabled .. i was just sharing my experience.. n that happened to my civic.. my corolla behaved like that when it had some oil filter n intake problem
    If advancer issue - poor acceleration.

    Might be ur mechanic changed emulator. Due to faulty emulator, CNG and Petrol get mix resulting unstable RPM.

    In case your issue get resolved by changing advancer - then ur issue should be resolve by removing advancer.

  13. #13
    PakWheeler Follow
    revengez's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by kingvirgo80 View Post
    Its only occurs on PETROL not on CNG...
    ------

  14. #14
    PakWheeler Follow
    revengez's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    777
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by kingvirgo80 View Post
    -Its only occurs on PETROL not on CNG...

    Check emulator - if its working fine then clean injectors.

  15. #15
    PakWheeler Follow
    kingvirgo80's Avatar
    Join Date
    Dec 2011
    Location
    Islamabad
    Age
    26
    Posts
    35
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    do i need throttle body service???



  16. #16
    PakWheeler Follow
    cool_shaizi's Avatar
    Join Date
    Oct 2012
    Location
    Faisalabad
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by kingvirgo80 View Post
    thanks alot brothers for quick responce...
    -I put new air filter before 2 months..
    -I get tunning done after evry 5000km...
    -Its only occurs on PETROL not on CNG...
    -NO engine light pops
    -spark plugs are good
    -pick is good


    -It never happaned before on PETROL or CNG 43000km driven now,,
    -othee things in mind please tell me em thinking may be its because of throttle body needs service..
    - and tell me about tapets?
    -and my kit is landirenzo..

    thanks


    check your fuel injectors may be they need service or change ..!

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •