Survey by Qualaroo
+ Reply to Thread
Results 1 to 7 of 7
Like Tree2Likes
  • 1 Post By dms664
  • 1 Post By autophile

Thread: Can a loose Petrol tank cap trigger Check Engine Light in Corolla Gli 2010?

  1. #1
    Senior PakWheeler Follow
    dms664's Avatar
    Join Date
    Dec 2007
    Location
    Select City
    Age
    33
    Posts
    7,013
    Follows
    1
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    8 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Can a loose Petrol tank cap trigger Check Engine Light in Corolla Gli 2010?

    Aoa Pals
    Hope u all r doing well.I will like to invite experts about their take on the following issue.
    The other day I topped up petrol in my corolla gli 2010 owing to expected price hike from April 1. At that time the attendant didnt put back the petrol tank cap tightly even though it produced a click sound (but it was loose on later inspection) , I was also in a hurry so took off. On the second day after I took my car out on the road , after some time the Check engine light flashed. I took a u turn and came back home. Open the hood, checked the oil, water levels, filters (oil n air) n bla bla. I then flashed the ecu by removing one terminal from battery. Also I removed the petrol tank cap and put it back securely making it to produce 2 clicks.

    Started the car and check engine light is no more there.(its been 2nd day and I am driving but thanks to Allah CEL didnt flash again)

    My question is is there any mechanism which can trigger check engine light due to loose petrol tank cap in PDM Corolla gli 2010? OR it was something else? if it was something else y it didnt trigger the CEL again?Do I need to go for an OBD scan?

    regards


    My dear ALLAH when I loose hope, help me to remember that Your love is greater than my disappointment and Your plans for my life are better than my Dreams.

  2. #2
    Senior PakWheeler Follow
    autophile's Avatar
    Join Date
    Sep 2004
    Location
    Islamabad
    Posts
    13,574
    Follows
    20
    Following
    6
    Mentioned
    405 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Losen the cap again and drive and then see. Had you first checked the cap and then removed the battery terminal to shoo away the ECL then we could draw up some hypothesis.

    I guess your car in not on CNG. The ECL comes sometimes in some CNG cars, though thanks to Allah I have never experienced in my 05 xil.
    Be polite on the road. Always give way to others, particularly ambulances and pedestrians.

  3. #3
    Senior PakWheeler Follow
    dms664's Avatar
    Join Date
    Dec 2007
    Location
    Select City
    Age
    33
    Posts
    7,013
    Follows
    1
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    8 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by autophile View Post
    Losen the cap again and drive and then see. Had you first checked the cap and then removed the battery terminal to shoo away the ECL then we could draw up some hypothesis.

    I guess your car in not on CNG. The ECL comes sometimes in some CNG cars, though thanks to Allah I have never experienced in my 05 xil.
    yes sir my car is on cng.
    Update:
    after the ecu being refreshed the CEL came in again and this time I got it scanned from toyota 3s n it was O2 sensor error but interesting to mention is that before going to the dealer I had to open the wheel to check the rust on the brake disc rotors so as soon as I refit the wheel back and start the engine the CEL was gone but the code was stored which I got on my visit to 3s after this wheel thingy.

    Now the Question is how to cure this 02 thingy as it was not there since then but today again it flashed the CEL. is there any connection of the wheel opening n fitting back with the o2 sensor?
    I asked the foreman about this but he said that there are only ABS sensors in the wheels which will ignite the ABS light not the CEL.

    Any expert opinions please, I have a long journey planned on monday in sha Allah. Can I undertake about 600+ km journey with this o2 error or not.
    My dear ALLAH when I loose hope, help me to remember that Your love is greater than my disappointment and Your plans for my life are better than my Dreams.

  4. #4
    Senior PakWheeler Follow
    dms664's Avatar
    Join Date
    Dec 2007
    Location
    Select City
    Age
    33
    Posts
    7,013
    Follows
    1
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    8 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by dms664 View Post
    yes sir my car is on cng.
    Update:
    after the ecu being refreshed the CEL came in again and this time I got it scanned from toyota 3s n it was O2 sensor error but interesting to mention is that before going to the dealer I had to open the wheel to check the rust on the brake disc rotors so as soon as I refit the wheel back and start the engine the CEL was gone but the code was stored which I got on my visit to 3s after this wheel thingy.

    Now the Question is how to cure this 02 thingy as it was not there since then but today again it flashed the CEL. is there any connection of the wheel opening n fitting back with the o2 sensor?
    I asked the foreman about this but he said that there are only ABS sensors in the wheels which will ignite the ABS light not the CEL.

    Any expert opinions please, I have a long journey planned on monday in sha Allah. Can I undertake about 600+ km journey with this o2 error or not.
    Just after half an hour I was leaving to call on my friend and when I started the car the check engine light went off along with other lights after the engine started running. same happened prev also and I related it to the wheels thingy but now its clear its nothing to do with wheels thingy,
    (so I ran back to my room to update this on the thread )

    so now we know from OBD scan that its an o2 error and like it has went off now it will show up again after a week or two. what is the remedy? and of course what is the cause? had it been a bad o2 sensor it should have been perm giving the error not letting the CEL go off. most imp can I travel on long route with this? hope it will not put me in the middle of no where.
    Experts please spk.
    My dear ALLAH when I loose hope, help me to remember that Your love is greater than my disappointment and Your plans for my life are better than my Dreams.

  5. #5
    PakWheeler Follow
    ya_jee's Avatar
    Join Date
    Aug 2013
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Good day all PWs

    This thread is the most important one for those having O2 check lights including me. The same issue happened to me from few days and after OBD scan i was warned for O2 sensor with the recommendation of replacement. Whenever i reset ECU it went off and show it's miserable face again after few days. The technician warned me for haecy fuel consumption (Petrol only) if not changed early.
    I found this thread very informative but incomplete and very old i.e. 2012. The first bearer of thread should have definitely solved his O2 problem and he can now share his experience for other PW's.
    Did you replaced the same?
    How was its performance afterwards?
    Any other issues if not replaced?

  6. #6
    PakWheeler Follow
    KhurrumIftikhar1's Avatar
    Join Date
    Feb 2011
    Location
    Gujrat
    Age
    22
    Posts
    253
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    On cng cars it is not due to o2 sensor fault .

    Although the signal is produced by O2 sensor.
    But due to blocked air flow .

    Which was fitted just before throttle body.

    Simply remove the blockage and your problem will be solved

  7. #7
    Senior PakWheeler Follow
    huzaifa.haroon's Avatar
    Join Date
    Aug 2012
    Location
    Islamabad
    Posts
    4,993
    Follows
    10
    Following
    1
    Mentioned
    222 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    In My cars , Honda Insight user manual it is mentioned that CEL can be caused by loosen fuel cap
    Always respect your parents

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •