Survey by Qualaroo
+ Reply to Thread
Results 1 to 7 of 7

Thread: corolla 2007 xli rpm dropping problem in slow

  1. #1
    PakWheeler Follow
    newtechautos's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default corolla 2007 xli rpm dropping problem in slow

    my toyota corolla xli 2007 is having rpm dropping problem. Its a manual car. When i pick up from first gear and give it a speed through speed padel it instantly drops the rpm then return back to normal level. Its mostly happening with air conditioner. We tried every possible thing for this like coils checking, changing of plugs, injectors cleaning, throttle body cleaning etc. We also have gone through with car computer scanner. Its all clear and not giving any sort of sensor or other ecm related fault. I am confused about the next step to sort out this problem. Please help me out


  2. #2
    Senior PakWheeler Follow
    onlyfaith's Avatar
    Join Date
    Sep 2010
    Location
    Islamabad
    Posts
    5,934
    Follows
    3
    Following
    1
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    does this problem occurs on cng or petrol?
    top documentaries " Tears of Gaza"

  3. #3
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Auto a/c cut off system is not functioning on acceleration when A/C is on.Get it checked.
    Never loose hope in life,every step gives u something.

  4. #4
    PakWheeler Follow
    5555's Avatar
    Join Date
    May 2009
    Location
    Lahore
    Age
    25
    Posts
    688
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    unplug your battery cables and after 5 to 10 min install them back then drive your car
    I think there is ecu problem with your car

  5. #5
    PakWheeler Follow
    kawafan's Avatar
    Join Date
    May 2009
    Location
    Lahore
    Age
    68
    Posts
    75
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    did you found any solution i am having exactly same problems ?

  6. #6
    PakWheeler Follow
    Bindas353's Avatar
    Join Date
    Jul 2008
    Location
    Lahore
    Age
    32
    Posts
    540
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    1 . check gap of buterfly in throtle body
    2. check speed sensor or throtle sensor n main imp z map sensor

  7. #7
    PakWheeler Follow
    6Forward's Avatar
    Join Date
    Feb 2012
    Location
    Lahore
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check Valve Clearance
    Clean throttle body & ISCV
    Spark plug
    Fuel Filter

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •